Confilct with exchange server 2000

Hello,
         I'm currently trying to upgrade our network from server 2000 to server 2003. I currently have one server that functions as the domain controller and also hosts exchange server 2000. when i try running forestprep I was greeted with the error "Adprep was unable to extend the schema.
[Status/Consequence]
There is a schema conflict with Exchange 2000. The schema is not upgraded.
[User Action]
The schema conflict must be resolved before running adprep. Resolve the schema c
onflict, allow the change to replicate between all replication partners, and the
n run Adprep. For information on resolving the conflict, see Microsoft Knowledge
 Base article Q325379."

I followed the steps in the KB particularly scenario 2 , however while trying to run the inetorgpersonprevent.ldf file I get the following error

"Connecting to "servername".
Logging in as current user using SSPI
Importing directory from file "inetorgpersonprevent.ldf"
Error occured during initialization
File operation failure
0 entries modified successfully.
An error has occurred in the program"

here's what i have in the inetorgpersonprevent.ldf file

dn: CN=ms-Exch-Assistant-Name,CN=Schema,CN=Configuration,DC=X
changetype: Modify
replace:LDAPDisplayName
LDAPDisplayName: msExchAssistantName
-

dn: CN=ms-Exch-LabeledURI,CN=Schema,CN=Configuration,DC=X
changetype: Modify
replace: LDAPDisplayName
LDAPDisplayName: msExchLabeledURI
-

dn: CN=ms-Exch-House-Identifier,CN=Schema,CN=Configuration,DC=X
changetype: Modify
replace: LDAPDisplayName
LDAPDisplayName: msExchHouseIdentifier
-

dn:
changetype: Modify
add: schemaUpdateNow
schemaUpdateNow: 1
-

I've been searching for a solution for hours. Please help.

--Tim.

Tim_MohamedAsked:
Who is Participating?
 
oBdACommented:
It says "File operation failure"; make sure that
1. you saved the file as Unicode,
2. there are no spaces at the end of each line,
3. there's an empty line after the last line with the hyphen "-".
0
 
Tim_MohamedAuthor Commented:
Yeah I verified that the file is correct, I read somewhere that someone had the same problem, here's what they wrote:-

I found the error !!!

I found how to solve my problem on this page
http://support.microsoft.com/?id=314649 on scenario 2.

The problem was that I used the "Inetorgperson Kit" from Microsoft
W2000. This package content the file "inetorgperson-fix.ldf". This file
doesn't content the value "HouseIdentifier".

It means that this LDF file doesn't work in my case.

I copy the script from the link http://support.microsoft.com/?id=314649
in a file titled "inetorgpersonprevent.ldf"

Then I run the command: ldifde -i -f inetorgpersonprevent.ldf -v -c
DC=X "dn path for forest root domain"

but it didn't work.

I had to check with "ADSI Edit" (found in the Microsoft 2000 Support
Tools) the values from the script in my Active Directory.

Finally, I found that the value "HouseIdentifier" had a wrong
displayname.

Before: HouseIdentifier
Now: msExchHouseIdentifier


Well that worked for him but I have no clue how he did it. Any ideas?
0
 
Tim_MohamedAuthor Commented:
Ok did a double check of the file and found a couple of extra white spaces, it ran perfectly after that, also make sure you are in the right directory when running from command prompt. I just ran forestprep and domain prep and it completed without errors.

Cheers,
Tim.
0
 
Tim_MohamedAuthor Commented:
Please see my second to last comment.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.