• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1670
  • Last Modified:

ASA 5505 split tunnel not working

New to the ASA and not very bright with Cisco. Fresh out of the box, got the basics setup and Working on VPN.

ASA authenticating with RADIUS on NPS- Check
Split tunnel config- Check
Split tunnel verified on client details- Check

But, I cannot ping or access any LAN resources. LAN and VPN IP addresses are on different subnets, but this worked in the PIX we had previously. I want to have all VPN clients use 192.168.10.X addresses and they'll need access to the entire network at 192.168.254.X.

All of the config I've done is through the ASDM. It's also on a test environment behind a NAT'd static IP which is why the external is a LAN address. Pleasse don't worry about that.

Can someone please help me get the LAN access worked out? Thanks! Below is the running config.

------------------------------------------------------

: Saved
:
ASA Version 8.2(1)
!
hostname asa
domain-name xxx
enable password xxx encrypted
passwd xxx encrypted
names
name 192.168.10.0 VpnIpPool description VPN pool
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.254.2 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.1.10.13 255.255.255.0
!
interface Vlan5
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address dhcp
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
 switchport access vlan 5
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name dac.dom
access-list no-nat extended permit ip any VpnIpPool 255.255.255.192
access-list Split_Tunnel_List remark LAN behind the ASA for VPN ppol addresses.
access-list Split_Tunnel_List standard permit 192.168.0.0 255.255.0.0
access-list outside_access_in extended permit ip VpnIpPool 255.255.255.0 any
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip local pool VpnIpPool 192.168.10.1-192.168.10.50 mask 255.255.0.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no-nat
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 10.1.10.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server AdRadiusGroup protocol radius
aaa-server AdRadiusGroup (inside) host 192.168.254.240
 timeout 5
 key xxx
http server enable
http 192.168.254.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable outside
 svc image disk0:/vpn/anyconnect-win-2.3.0254-k9.pkg 1 regex "Windows NT"
 svc enable
 tunnel-group-list enable
group-policy RadiusGrpPolicy internal
group-policy RadiusGrpPolicy attributes
 vpn-tunnel-protocol svc
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Split_Tunnel_List
tunnel-group DomainAdmins type remote-access
tunnel-group DomainAdmins general-attributes
 address-pool VpnIpPool
 authentication-server-group AdRadiusGroup
 default-group-policy RadiusGrpPolicy
tunnel-group DomainAdmins webvpn-attributes
 group-alias DomainAdmins enable
 group-url https://10.1.10.13/DomainAdmins enable
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:74f11e3cfe2aede6abd24b251a07a704
: end
asdm location VpnIpPool 255.255.255.255 inside
no asdm history enable

0
dacIT
Asked:
dacIT
  • 8
  • 5
  • 2
2 Solutions
 
dacITAuthor Commented:
One other thing to note, the split tunnel is working some in that I can access non-LAN resources when connected to the VPN client. I just can't access the LAN resources that are behind the ASA.
0
 
Pete LongConsultantCommented:

Firstly turn on nat traversal
crypto isakmp nat-traversal  20
Then try again
Add the following
group-policy RadiusGrpPolicy attributes
 default-domain value {yourdomain}
other than that it looks ok
0
 
bignewfCommented:
It might not be working to overlapping routes:
192.168.10.0 is your client vpn pool, I see this:
access-list Split_Tunnel_List standard permit 192.168.0.0 255.255.0.0 -- since your internal network is 192.168.254.0, could be the issue as the above split-tunnel list could actually overlap with above statement

I would change my vpnclient pool to something like 172.16.254.0 so there is no route overlap. Make sure your internal lan hosts have a route to this new subnet

Also, I would include a access list to permit your decrypted traffic to pass throught the asa:

asa(config)#  access-list outside_inside permit ip 172.16.254.0 255.255.255.0 192.168.254.0 255.255.255.0

then apply access-list to outside interface:

access-group outside_inside in interface outside

and your nat exempt rules:
access-list nonat extended permit ip 192.168.254.0 255.255.255.0 172.16.250.0 255.255.255.0
nat (inside) 0 access-list nonat

so first remove your split tunnel lists to make sure you have local lan access,
then when confirmed that is working, re-apply your split tunnel lists, so if lan access still works but split tunnel does not, you have confined your troubleshooting to only the split tunnel config





0
Become a Leader in Data Analytics

Gain the power to turn raw data into better business decisions and outcomes in your industry. Transform your career future by earning your MS in Data Analytics. WGU’s MSDA program curriculum features IT certifications from Oracle and SAS.  

 
Pete LongConsultantCommented:
though I'd change this
access-list no-nat extended permit ip any VpnIpPool 255.255.255.192  
to

access-list no-nat extended permit ip any 192.168.254.2 255.255.255.0 192.168.10.0 255.255.255.0
and
access-list Split_Tunnel_List standard permit 192.168.0.0 255.255.0.0  
to
 access-list Split_Tunnel_List standard permit 192.168.254.0 255.255.255.0
0
 
dacITAuthor Commented:
Thank so far. Still doesn't work. It doesn't work without the tunnel either so I'm thinking it's not a split tunnel problem, but something else.

Here's a dump with the existing config that connects to the vpn, but cannot access the LAN. I don't know how to provide routes to the LAN clients for the totally new VPN pool, so I've removed that for now.

PeteLong- I tried your commands above, and all worked accept the "access-list no-nat extended permit ip any 192.168.254.2 255.255.255.0 192.168.10.0 255.255.255.0". It said invalid hostname

I'm also going to post the PIX config with the same VPN type setup that works great. Maybe you guys that can read this stuff can help me find what I've forgotten in the new ASA setup by comparison.

0
 
dacITAuthor Commented:
New ASA config without tunnel assignments until we get the LAN resources accessible:

: Saved
:
ASA Version 8.2(1)
!
hostname asa
domain-name dac.dom
enable password *** encrypted
passwd *** encrypted
names
name 192.168.10.0 VpnIpPool description VPN pool
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.254.2 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.1.10.13 255.255.255.0
!
interface Vlan5
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address dhcp
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
 switchport access vlan 5
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name dac.dom
access-list no-nat extended permit ip any VpnIpPool 255.255.255.0
access-list Split_Tunnel_List standard permit 192.168.254.0 255.255.255.0
access-list Split_Tunnel_List remark LAN behind the ASA.
access-list outside_access_in extended permit ip VpnIpPool 255.255.255.0 any
access-list outside_inside extended permit ip 172.16.254.0 255.255.255.0 192.168.254.0 255.255.255.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip local pool VpnIpPool 192.168.10.1-192.168.10.50
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no-nat
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_inside in interface outside
route outside 0.0.0.0 0.0.0.0 10.1.10.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server AdRadiusGroup protocol radius
aaa-server AdRadiusGroup (inside) host 192.168.254.240
 timeout 5
 key ***
http server enable
http 192.168.254.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto isakmp nat-traversal 30
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable outside
 svc image disk0:/vpn/anyconnect-win-2.3.0254-k9.pkg 1 regex "Windows NT"
 svc enable
 tunnel-group-list enable
group-policy RadiusGrpPolicy internal
group-policy RadiusGrpPolicy attributes
 dns-server value 192.168.254.250 192.168.254.240
 vpn-tunnel-protocol svc
 default-domain value dac.dom
tunnel-group DomainAdmins type remote-access
tunnel-group DomainAdmins general-attributes
 address-pool VpnIpPool
 authentication-server-group AdRadiusGroup
 default-group-policy RadiusGrpPolicy
tunnel-group DomainAdmins webvpn-attributes
 group-alias DomainAdmins enable
 group-url https://10.1.10.13/DomainAdmins enable
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9ac6be3078730b929e2e5c4c557178af
: end
asdm location VpnIpPool 255.255.255.255 inside
no asdm history enable

0
 
dacITAuthor Commented:
Old PIX config that is working now with similar VPN address pool:

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password *** encrypted
passwd *** encrypted
hostname guardian
domain-name eugene.office
clock timezone PST -8
clock summer-time PDT recurring
no fixup protocol dns
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name *** EXCHANGE-OUT
name *** CITRIX-OUT
name 192.168.254.252 CITRIX-IN
name 192.168.254.27 VOICEMAIL-IN
name 255.255.255.0 CIDR-24
name 255.255.255.255 CIDR-32
name *** SMEED-ADMIN
name 192.168.254.251 DATA-IN
name 192.168.254.162 CODY-IN
name 192.168.254.129 BYODER-IN
name 192.168.254.127 SBENNETT-IN
name 192.168.254.249 EXCHANGE-IN
name 192.168.254.248 SQL-SERVER-IN
name 192.168.254.242 VPN-TS-IN
name 192.168.254.245 TERM-SVR-IN
name 192.168.254.250 MAIL01-IN
object-group service EXCHANGE-PORTS tcp
  port-object eq smtp
  port-object eq 3389
  port-object eq www
  port-object eq https
  port-object range 995 995
  port-object range 993 993
access-list outside_access_in permit icmp any any
access-list outside_access_in deny tcp host 66.135.195.166 any
access-list outside_access_in deny tcp host 66.135.192.87 any
access-list outside_access_in deny tcp host 66.135.192.88 any
access-list outside_access_in deny tcp host 66.135.208.88 any
access-list outside_access_in deny tcp host 66.135.208.101 any
access-list outside_access_in permit tcp any host CITRIX-OUT eq citrix-ica
access-list outside_access_in deny tcp any interface outside eq 3389
access-list outside_access_in permit tcp any interface outside range 8188 8189
access-list outside_access_in permit tcp host SMEED-ADMIN interface outside eq 8080
access-list outside_access_in permit tcp any host 69.88.126.62 eq 3389
access-list outside_access_in permit tcp any host 69.88.126.61 eq www
access-list outside_access_in permit tcp any host EXCHANGE-OUT object-group EXCHANGE-PORTS
access-list outside_access_in permit tcp any interface outside eq 3390
access-list outside_access_in permit tcp any interface outside eq 3391
access-list outside_access_in deny tcp any interface outside eq 1433
access-list outside_access_in permit ip 192.168.8.0 255.255.255.0 any
access-list inside_access_out deny ip host 192.168.254.111 any
access-list inside_access_out deny ip host 192.168.254.112 any
access-list inside_access_out deny ip host 192.168.254.121 any
access-list inside_access_out deny ip host 192.168.254.110 any
access-list inside_access_out deny ip host 192.168.254.113 any
access-list inside_access_out permit ip any any
access-list 100 permit ip 192.168.0.0 255.255.255.0 192.168.8.0 255.255.255.0
access-list 120 permit ip 192.168.0.0 255.255.255.0 192.168.8.0 255.255.255.0
access-list to-remote permit ip 192.168.254.0 255.255.255.0 192.168.30.0 255.255.255.0
access-list no-nat deny tcp any any eq www
access-list no-nat permit ip 192.168.254.0 255.255.255.0 192.168.30.0 255.255.255.0
access-list no-nat permit ip any 192.168.8.0 255.255.255.192
access-list outside_cryptomap_dyn_20 permit ip any 192.168.8.0 255.255.255.192
access-list dacvpn_splitTunnelAcl permit ip 192.168.0.0 255.255.0.0 any
access-list bmcproperties_splitTunnelAcl permit ip host CITRIX-IN any
access-list bmcproperties_splitTunnelAcl permit ip host TERM-SVR-IN any
access-list bmcproperties_splitTunnelAcl permit ip host MAIL01-IN any
access-list bmcproperties_splitTunnelAcl permit ip host 192.168.254.244 any
access-list bmcproperties_splitTunnelAcl permit ip host VPN-TS-IN any
access-list bmcproperties_splitTunnelAcl permit ip host 192.168.254.240 any
access-list smeed_splitTunnelAcl permit ip host VOICEMAIL-IN any
access-list smeed_splitTunnelAcl permit ip host 192.168.254.28 any
access-list feynman_splitTunnelAcl permit ip 192.168.254.0 255.255.255.0 any
access-list Maintenance_splitTunnelAcl permit ip host 192.168.254.106 any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside *** 255.255.255.248
ip address inside 192.168.254.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool 192-168-8-0 192.168.8.10-192.168.8.50
ip local pool InternalRange 192.168.254.30-192.168.254.50 mask CIDR-24
pdm location VOICEMAIL-IN 255.255.255.255 inside
pdm location SBENNETT-IN 255.255.255.255 inside
pdm location BYODER-IN 255.255.255.255 inside
pdm location CODY-IN 255.255.255.255 inside
pdm location DATA-IN 255.255.255.255 inside
pdm location CITRIX-IN 255.255.255.255 inside
pdm location 66.135.192.87 255.255.255.255 outside
pdm location 66.135.192.88 255.255.255.255 outside
pdm location 66.135.195.166 255.255.255.255 outside
pdm location 66.135.208.88 255.255.255.255 outside
pdm location 66.135.208.101 255.255.255.255 outside
pdm location SMEED-ADMIN 255.255.255.255 outside
pdm location 192.168.30.0 255.255.255.0 outside
pdm location 192.168.8.0 255.255.255.0 outside
pdm location 0.0.0.0 255.255.255.255 outside
pdm location EXCHANGE-IN 255.255.255.255 inside
pdm location SQL-SERVER-IN 255.255.255.255 inside
pdm location VPN-TS-IN 255.255.255.255 inside
pdm location TERM-SVR-IN 255.255.255.255 inside
pdm location MAIL01-IN 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no-nat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3389 DATA-IN 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 8189 CODY-IN https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3101 CODY-IN 3101 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 8188 CODY-IN www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 8080 VOICEMAIL-IN 8080 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3390 SBENNETT-IN 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3391 BYODER-IN 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 1433 SQL-SERVER-IN 1433 netmask 255.255.255.255 0 0
static (inside,outside) EXCHANGE-OUT EXCHANGE-IN netmask 255.255.255.255 0 0
static (inside,outside) CITRIX-OUT CITRIX-IN netmask 255.255.255.255 0 0
static (inside,outside) 69.88.126.61 MAIL01-IN netmask 255.255.255.255 0 0
static (inside,outside) 69.88.126.62 TERM-SVR-IN netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 69.88.126.57 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server RADIUS (inside) host TERM-SVR-IN waypoint timeout 10
aaa-server LOCAL protocol local
http server enable
http 192.168.254.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
auth-prompt prompt Windows user credentials.
auth-prompt accept You've been authenticated!
auth-prompt reject User not valid!
crypto ipsec transform-set highest esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map DYNMAP 1 set transform-set highest
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map mymap 10 ipsec-isakmp dynamic DYNMAP
crypto map map1 1 ipsec-isakmp
crypto map map1 1 set peer *** crypto map map1 1 set transform-set highest
! Incomplete
crypto map map1 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map map1 interface outside
isakmp enable outside
isakmp key secret address ***  netmask CIDR-32
isakmp identity address
isakmp nat-traversal 10
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption aes-256
isakmp policy 1 hash sha
isakmp policy 1 group 2
isakmp policy 1 lifetime 86400
isakmp policy 21 authentication pre-share
isakmp policy 21 encryption 3des
isakmp policy 21 hash md5
isakmp policy 21 group 2
isakmp policy 21 lifetime 86400
vpngroup remote address-pool 192-168-8-0
vpngroup remote dns-server MAIL01-IN
vpngroup remote default-domain dac.dom
vpngroup remote split-tunnel 120
vpngroup remote split-dns dac.dom
vpngroup remote idle-time 3600
vpngroup remote password ***
vpngroup dacvpn address-pool 192-168-8-0
vpngroup dacvpn dns-server MAIL01-IN
vpngroup dacvpn default-domain dac.dom
vpngroup dacvpn split-tunnel dacvpn_splitTunnelAcl
vpngroup dacvpn split-dns dac.dom
vpngroup dacvpn idle-time 1800
vpngroup dacvpn password ***
vpngroup bmcproperties address-pool 192-168-8-0
vpngroup bmcproperties dns-server MAIL01-IN 192.168.254.240
vpngroup bmcproperties default-domain dac.dom
vpngroup bmcproperties split-tunnel bmcproperties_splitTunnelAcl
vpngroup bmcproperties split-dns dac.dom
vpngroup bmcproperties idle-time 1800
vpngroup bmcproperties password ***
vpngroup smeed address-pool 192-168-8-0
vpngroup smeed split-tunnel smeed_splitTunnelAcl
vpngroup smeed idle-time 1800
vpngroup smeed password ***
vpngroup Maintenance address-pool 192-168-8-0
vpngroup Maintenance dns-server MAIL01-IN
vpngroup Maintenance split-tunnel Maintenance_splitTunnelAcl
vpngroup Maintenance split-dns dac.dom
vpngroup Maintenance idle-time 1800
vpngroup Maintenance password ***
vpngroup feynman address-pool 192-168-8-0
vpngroup feynman dns-server 192.168.254.50
vpngroup feynman split-tunnel feynman_splitTunnelAcl
vpngroup feynman idle-time 1800
vpngroup feynman password ***

telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 60
management-access inside
console timeout 0
vpdn group WINVPN accept dialin pptp
vpdn group WINVPN ppp authentication mschap
vpdn group WINVPN ppp encryption mppe 128 required
vpdn group WINVPN client configuration address local InternalRange
vpdn group WINVPN client configuration dns MAIL01-IN 192.168.254.240
vpdn group WINVPN client authentication aaa RADIUS
vpdn group WINVPN client accounting RADIUS
vpdn group WINVPN pptp echo 60
vpdn enable outside
vpdn enable inside
terminal width 80
Cryptochecksum:b1be7fead7d7ca5a7933b7fdd99c4ede
: end
[OK]

0
 
bignewfCommented:
looking at your config now, thanks for your patience
0
 
bignewfCommented:
Is the 192.168.254.0 your inside lan?
Also, syntax will be slightly different with interesting traffic lists in asa (outside-to-inside instead of access list # as in pix)
if so, then:

access-list outside_access_in permit ip 192.168.254.0 255.255.255.0 192.168.10.0 255.255.0.0
access-list no-nat permit ip 192.168.254.0 255.255.255.0 192.168.10.0 255.255.0.0

route inside  192.168.10.0. 255.255.0.0 192.168.254.2  (so the vpn remote hosts have  a route to the inside lan)

also check subnet mask on your remote vpn pool, I see a  /16 subnet mask and a  /26  mask
0
 
bignewfCommented:
forgot to add

sysopt connection permit vpn  (or permit ipsec)

this makes sure traffic bypasses all access lists
0
 
dacITAuthor Commented:
Cool. I appreciate your reply. I'll try it out this afternoon and let you know.
0
 
dacITAuthor Commented:
Still no joy. VPN connects fine, can't ping or access LAN at 192.168.254.0.

: Saved
:
ASA Version 8.2(1)
!
hostname asa
domain-name dac.dom
enable password ***encrypted
passwd ***encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.254.2 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.1.10.13 255.255.255.0
!
interface Vlan5
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address dhcp
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
 switchport access vlan 5
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns domain-lookup outside
dns domain-lookup inside
dns domain-lookup dmz
dns server-group DefaultDNS
 name-server 192.168.254.250
 name-server 192.168.254.240
 domain-name dac.dom
access-list outside-access-in extended permit ip 192.168.10.0 255.255.255.0 any
access-list Split_Tunnel_List extended permit ip 192.168.0.0 255.255.0.0 any
access-list no-nat extended permit ip any 192.168.10.0 255.255.255.192
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip local pool VpnIpPool 192.168.10.10-192.168.10.50
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no-nat
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 10.1.10.1 1
route inside 192.168.10.0 255.255.255.0 192.168.254.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server AdRadiusGroup protocol radius
aaa-server AdRadiusGroup (inside) host 192.168.254.240
 timeout 5
 key ***
http server enable
http 192.168.254.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto isakmp nat-traversal 30
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable outside
 svc image disk0:/vpn/anyconnect-win-2.3.0254-k9.pkg 1 regex "Windows NT"
 svc enable
 tunnel-group-list enable
group-policy RadiusGrpPolicy internal
group-policy RadiusGrpPolicy attributes
 dns-server value 192.168.254.250 192.168.254.240
 vpn-tunnel-protocol svc
 default-domain value dac.dom
tunnel-group DomainAdmins type remote-access
tunnel-group DomainAdmins general-attributes
 address-pool VpnIpPool
 authentication-server-group AdRadiusGroup
 default-group-policy RadiusGrpPolicy
tunnel-group DomainAdmins webvpn-attributes
 group-alias DomainAdmins enable
 group-url https://10.1.10.13/DomainAdmins enable
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:edf4095dc0fd1244e4874f577f4317af
: end
no asdm history enable

0
 
bignewfCommented:
the subnet mask for your vpn pool in one statement is 255.255.255.0:

access-list outside-access-in extended permit ip 192.168.10.0 255.255.255.0 any

but in you nat0 statement is this:

access-list no-nat extended permit ip any 192.168.10.0 255.255.255.192

correct the subnet masks so they match in both the nat0 and allowed inbound traffic rule ( I don't know which is your correct subnet mask from your config)
0
 
dacITAuthor Commented:
We never did get it to work. We've got our fee-based Cisco tech involved now. Thanks for everyone trying to help out. I'm sure I missed something obvious that is making this not work well. I will report back when I hear from the tech.
0
 
dacITAuthor Commented:
Turns out (I feel stupid) that since we had the network on gateway address 192.168.xxx.1 and the new ASA on 192.168.xxx.2 no network traffic was ever travelling through the .2 gateway. As soon as we made it the default gateway... worked like a charm.
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

  • 8
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now