• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 411
  • Last Modified:

WSUS problems

Hope everyone's had an enjoyable xmas:).

I installed WSUS last night on my server 2003 machine, by following the instructions on this link http://araihan.wordpress.com/2009/08/13/install-and-configure-wsus-3-0-sp2-step-by-step/ .

However, when I started it up none of the machines were seen and even though the synchronisations were successful I could see no updates at all of the 2400 which it claimed there were. So that was weird.

I tried all of the solutions on the internet, but nothing worked. I did select the database as SQL rather than Windows Internal one. I've uninstalled WSUS and am planning to reinstall. Is it worth me using the Windows Internal one this time? Are there advantages to using the SQL 2005 database instead?

Thanks
Y
0
Yashy
Asked:
Yashy
  • 4
  • 2
  • 2
  • +2
1 Solution
 
Vaidas911Commented:
Hi,
Windows Internal database works fine - I think there is no need for SQL in small/medium enterprise.
Updates are downloaded to server then you approve them, so check Updates (on the left) and filter unapproved - any. When no computer is connected to WSUS, unapprove and "needed or failed" will show none, because no computers need any updates.
On Unapproved -> any check all updates as approved or you can go one by one to look for superseeding or superseded updates - I just don't do so.
After approval server will dowload updates (if selected to do so). My last experience is not to download to server but to take updates directly from MS for small enterprise (up to 30 PC). I use WSUS just for monitoring that all computers are up to date and OK.
Regards,
Vaidas Paulaukis
0
 
beanrodCommented:
Vaidas is spot on.
Generally you create a Group Policy so that the computers are pointed to the WSUS Server.
0
 
YashyAuthor Commented:
Vaidas, thanks for your response. I've again reinstalled WSUS and the same problems are occuring.

I've attached picture files too of certain settings. I currently am using WIndows Internal Database and using port 80.

As you can see, the picture shows that there are updates but it says 0 of 728. So there are 728 updates it knows about and they're not showing! Plus, there's nothing in the computers section, there are no machines in there even though I've selected them in the actual GPO and linked it correctly.

What do you think is going wrong?
wsus1.JPG
wsus2.JPG
wsus3.JPG
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
essam_142Commented:

You need to further configure the GPO; you dont have much control from the WSUS server , all the needed features needs to be configured from the GPO : to do that you need to edit the GPO :
 
In the GPO console select Computer Configuration \ Administrative Templates \ Windows Update \
 
Enable the following according to you setup :
 
-         Configure Automatic Update  ( to schedule the update for the workstations )
-         Specify Intranet Microsoft update service location ( to force the workstations to use your server instead of Windows Update Internet site )  
-         Selected other features as required  
0
 
essam_142Commented:

Sorry I have put my reply before yours !
 
In your GPO it is showing that you are using port 8080 while your IIS is showing that you are using port 80 ; change that ( just remove the :8080 ) and try again
 
 
0
 
YashyAuthor Commented:
I went in and changed the GPO entry for 'Specify intranet Microsoft Update service location' so that it just says http://kyzenmain (without any port entries).

The updates are still increasing in numbers, but they're just not showing up. And still no computers either after doing a gpupdate /force.

So it evidently is updating right, because the Total number keeps going up however it just doesn't show them in the list and the computers well that's another story as it can't even see them.

0
 
YashyAuthor Commented:
It's WORKING now. Okay, basically the port changes worked. Also, what happened was that the drop down menu in WSUS for the 'Computers' and to be changed to 'ANY'. That then showed them. Same for the updates.

Thanks for the help.
0
 
Henrik JohanssonSystems engineerCommented:
In screenshot, you've filtered WSUS to only display unapproved updates that are neaded. Change the filter and click refresh to display the updates. As the number of total updates increases, it sounds like you've configured WSUS to auto-approve the updates (Options -> Automatic Approvals).
Is there any clients listed under computers section? If so, the clients find and connect to the WSUS server and makes the GPO ok.
0
 
Henrik JohanssonSystems engineerCommented:
I had the IE-window with the question open and didn't click submit before the question was closed...
Such happens :)
0
 
YashyAuthor Commented:
Hey henjoh, sorry about that one:(. I'll be posting more soon.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now