[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine.

Posted on 2009-12-27
16
Medium Priority
?
401 Views
Last Modified: 2013-12-17
I am trying to Open() a database with a different WinForms application than I typically use to open Access databases. But I am running it from the same machine where I do all my work.

I wonder what I may have done to get my primary WinForms app. to connect whereas the second WinForms application does not connect.

Any ideas??

Thanks,
newbieweb
0
Comment
Question by:newbieweb
  • 9
  • 7
16 Comments
 
LVL 42

Expert Comment

by:Meir Rivkin
ID: 26127484
try creating a new project, and add an oledbconnection object component to your form from the data tab in the toolbox.

in the properties window, click the dropdown for the ConnectionString property and select <new connection...>

When the data link properties come up, click on the first tab (provider) and select Jet 4.0 provider.. continue through the rest of the 4 tabs and see if you can establish a connection this way.

This will at least help to narrow down your problem.
0
 
LVL 42

Expert Comment

by:Meir Rivkin
ID: 26127487
do u work on 64bit OS?
0
 

Author Comment

by:newbieweb
ID: 26127568
I did not yet perform your test, but I do indeed work on Windows 7 64 bit.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 42

Expert Comment

by:Meir Rivkin
ID: 26127583
There is not a 64 bit version of jet that is why you get that error.  To force your app to use the 32 bit change the target cpu to x86 in the advanced compiler options.

0
 

Author Comment

by:newbieweb
ID: 26127609
Thanks. That looks like you found the problem. But how do I open IIS on my Windows 7 machine?
0
 
LVL 42

Expert Comment

by:Meir Rivkin
ID: 26127615
did u install IIS Manager?
0
 

Author Comment

by:newbieweb
ID: 26127654
No, I just checked and IIS is not installed.

Odd that my one WinForms application uses Access, but the new one fails. I think I created the project on Windows 7.

I probably could re-create the project on Windows XP and it would work...

0
 

Author Comment

by:newbieweb
ID: 26127669
I take that back. I'd created that project on Windows XP long before I bought the Windows 7 PC.
0
 
LVL 42

Expert Comment

by:Meir Rivkin
ID: 26127675
cool :)
0
 

Author Comment

by:newbieweb
ID: 26127895
So, should I install IIS? Is that going to solve this problem?

I use the exact same connection string from my original WinForms app. and open the database. I don't really get it...
0
 
LVL 42

Expert Comment

by:Meir Rivkin
ID: 26129724
why would u open the iis?
to target your app to run as 32bit u need to change the project properties.
0
 
LVL 42

Expert Comment

by:Meir Rivkin
ID: 26129808
Open the property pages for that project.
For .NET projects, make sure the Configuration Properties node, or one of its child nodes, is selected in the <Projectname> Property Pages dialog box. Otherwise, the Configuration Manager button remains disabled.
Click Configuration Manager to open the Configuration Manager Dialog Box.
Click the Active Solution Platform list, and then select the <New&> option to open the New Solution Platform Dialog Box.
Click the Type or select the new platform drop-down arrow, and then select a x86 platform.

Untitled.jpg
0
 

Author Comment

by:newbieweb
ID: 26130597
I think you are on to something. In fact, I now recall going through this when I first got my Windows 7 PC, getting my old project to work. But I'm confused by your instructions.

Is this on the Application panel?

If so, what do I click first? The Configuration drop down is disabled.

I don't see how to get the Configuration Manager to open nor do I see the disabled button for the Configuration Manager.

Please let me know.

newbieweb
0
 
LVL 42

Accepted Solution

by:
Meir Rivkin earned 2000 total points
ID: 26130623
in the visual studio menu -> Build -> Configuration Manager
the dialog contains 2 comboboxes and a listview.
in the upper right combobox (titled Active Solution Platform), choose <New...>
in the new dialog the 1st combobox select your target platform (should contains x64 and x86).
0
 

Author Closing Comment

by:newbieweb
ID: 31670200
Thanks!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Windows Phone Theme Colours is a tight, powerful, and well balanced palette. This tiny Access application makes it a snap to select and pick a value. And it doubles as an intro to implementing WithEvents, one of Access' hidden gems.
Microsoft Access is a place to store data within tables and represent this stored data using multiple database objects such as in form of macros, forms, reports, etc. After a MS Access database is created there is need to improve the performance and…
What’s inside an Access Desktop Database. Will look at the basic interface, Navigation Pane (Database Container), Tables, Queries, Forms, Report, Macro’s, and VBA code.
With just a little bit of  SQL and VBA, many doors open to cool things like synchronize a list box to display data relevant to other information on a form.  If you have never written code or looked at an SQL statement before, no problem! ...  give i…
Suggested Courses

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question