• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2506
  • Last Modified:

VPN gateway 0.0.0.0

Hi,
I have set up an IPSEC VPN through a Cisco ASA 5505.

When connecting from the remote computer, I get an IP address from the dhcp pool but the default gateway is 0.0.0.0 and i cannot ping the remote server or asa.

Also I cannot get webpages once connected to the VPN as the routing is through 0.0.0.0

I am using Shrewsoft VPN client due to a 64 bit machine.

The server is remote and I cannot access it or the ASA remotely due to this issue. It is probably related, but logmein is failing to connect to the machine although it is listed as online in lgmein control panel.

Any suggestions would be welcomed.
0
jerryhatt
Asked:
jerryhatt
  • 8
  • 5
  • 2
2 Solutions
 
giltjrCommented:
When you setup the DHCP pool, did you define the real IP address of what the default gateway should be?

Can you post the DHCP pool definition?
0
 
jerryhattAuthor Commented:
the dhcp pool used by the ipsec clients only has assignment for start & end ip address, nothing relating to gateway.
0
 
giltjrCommented:
O.K, if there is nothing related to a gateway/route, how do you expect the clients to get to anything via the VPN?

Obviously the DHCP server is sending a default gateway/route but is setting the IP address to 0.0.0.0, you need to add a default gateway/route to the DHCP setting.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
jerryhattAuthor Commented:
Sorry, I wasn't clear. The cisco ASA 5505 does not have an option under VPN DHCP Pools to add a gateway/route.
I do understand that the client needs to know how to route data but where would that be configured as the dhcp pool only allows for ip address.
0
 
giltjrCommented:
It looks like you are using ASDM to configure this.  If you go into CLI mode and you know the option number, you can add one.

http://www.cisco.com/en/US/docs/security/asa/asa82/configuration/guide/dhcp.html#wp1115467

You can search on "dhcpd option 3 ip".  It looks like if you do not code option 3 that the ASA will hand out the the managment IP address, however as you will read it seems that the managment interface will not route traffic.
0
 
jerryhattAuthor Commented:
I have added the option 3 gateway and this is now listed correctly on the client machine.

I still have no connectivity to the remote network and the client machine loses internet connectivity as it must be routing everything through the default gateway of the vpn.

I have now tried using cisco vpn client on 32bit machine and exactly the same problem occurs.
0
 
giltjrCommented:
Can you post the results of netstat -rn from before and after you connect to the VPN?

Can the default route get you to the IP  subnet's you need to get to internally?

Do you have all of the proper ACL's to allow the VPN IP subnet access to your internal subnet's and to the Internet?
0
 
arnoldCommented:
Does your VPN policy secureALL or securespecified networks?
I.e. do you have an ACL that you assign as part of the VPN configuration on the server that only has the LAN IP ranges accessible via the tunnel.
If you could post the configuration minus identifying information, public IPs, passphrases, preshared keys etc.
Since the VPN is established, those should match.

The ipsec IP assigned to the client should be the IP set in the clients routing tab as the gateway to the networks secured via the VPN.
There is no need to assign a gateway to the IPSEC pool dhcp configuration.


0
 
jerryhattAuthor Commented:
below is the truncated result from netstat -rn before and after connection to VPN
My local IP is 192.168.0.11
remote network is 192.168.3.x
The ASA device external IP is the 213.x.x.x

I Think that this shows the route to 192.168.3.x is going via 192.168.0.1 which is probably why this is not working.
When I try and ping the remote server I can see the ICMP request built on ASA log but I get request timed out. When I ping my local computer from remote server I get replies.

I will post the running config of the ASA next - just have to clean it up.

Please excuse misalignment  of table.

Before connection to VPN

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      192.168.0.1     192.168.0.11     25
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
      192.168.0.0    255.255.255.0         On-link      192.168.0.11    281
     192.168.0.11  255.255.255.255         On-link      192.168.0.11    281
    192.168.0.255  255.255.255.255         On-link      192.168.0.11    281
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link      192.168.0.11    281
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link      192.168.0.11    281
===========================================================================

After connection to VPN

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      192.168.0.1     192.168.0.11    125
          0.0.0.0          0.0.0.0         On-link      192.168.3.25     31
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
      192.168.0.0    255.255.255.0         On-link      192.168.0.11    281
     192.168.0.11  255.255.255.255         On-link      192.168.0.11    281
    192.168.0.255  255.255.255.255         On-link      192.168.0.11    281
      192.168.3.0    255.255.255.0         On-link      192.168.3.25    286
     192.168.3.25  255.255.255.255         On-link      192.168.3.25    286
    192.168.3.255  255.255.255.255         On-link      192.168.3.25    286
   213.xxx.xx.xxx  255.255.255.255      192.168.0.1     192.168.0.11     26
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link      192.168.0.11    281
        224.0.0.0        240.0.0.0         On-link      192.168.3.25    286
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link      192.168.0.11    281
  255.255.255.255  255.255.255.255         On-link      192.168.3.25    286
===========================================================================

0
 
jerryhattAuthor Commented:
Here is the running config.

hostname cisco
domain-name xxxxx.com
enable password xxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.3.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 213.xxx.xxx.xxx255.255.255.192
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone GMT 0
dns server-group DefaultDNS
 domain-name xxxxx.com
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit icmp any 192.168.3.0 255.255.255.0
access-list outside_access_in extended permit ip any any
access-list inside_nat0_outbound_1 extended permit ip any 192.168.3.0 255.255.255.192
access-list inside_nat0_outbound_1 extended permit ip 192.168.3.0 255.255.255.192 192.168.3.0 255.255.255.192
access-list inside_nat0_outbound_1 extended permit ip 192.168.3.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list groupname_splitTunnelAcl standard permit 192.168.3.0 255.255.255.192
access-list inside_access_in extended permit icmp 192.168.3.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list inside_access_in extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNpool 192.168.3.25-192.168.3.49 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound_1
nat (inside) 1 192.168.3.0 255.255.255.0
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 213.229.91.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map inside_map interface inside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
dhcpd option 3 ip 192.168.3.1
!
dhcpd address 192.168.3.5-192.168.3.24 inside
dhcpd option 3 ip 192.168.3.1 interface inside
!

threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy groupname internal
group-policy groupname attributes
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value groupname_splitTunnelAcl
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol IPSec webvpn
username namehere password xxxxxxxxxx encrypted privilege 15
username namehere attributes
 vpn-group-policy DfltGrpPolicy
tunnel-group groupname type remote-access
tunnel-group groupname general-attributes
 address-pool VPNpool
 default-group-policy groupname
tunnel-group groupname ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:xxxxxxxxxx
: end
no asdm history enable

0
 
arnoldCommented:
Why is your split tunnel policy groupname_splitTunnelAcl  only deals with a /26 255.255.255.192 while your LAN is 192.168.3.0/25 255.255.255.0?

Your other policys nonat are in error:
if you run :
show crypto isakmp sa
show crypto ipsec sa
You'll see that you do not allow 192.168.0.0/24 (VPN client side) access to the 192.168.3.0/24 Remote LAN side and the same applies to the traffic from 192.168.3.0/24 to 192.168.0.0/24.
access-list inside_nat0_outbound_1 extended permit ip any 192.168.3.0 255.255.255.192 
access-list inside_nat0_outbound_1 extended permit ip 192.168.3.0 255.255.255.192 192.168.3.0 255.255.255.192 
access-list inside_nat0_outbound_1 extended permit ip 192.168.3.0 255.255.255.0 192.168.3.0 255.255.255.0 
access-list groupname_splitTunnelAcl standard permit 192.168.3.0 255.255.255.192 
access-list inside_access_in extended permit icmp 192.168.3.0 255.255.255.0 192.168.3.0 255.255.255.0 
access-list inside_access_in extended permit ip any any 


You need to use the remote LAN and local LAN
i.e. access-list inside_nat0_outbound_1 extended permit ip any 192.168.3.0 255.255.255.192 
access-list inside_nat0_outbound_1 extended permit ip 192.168.3.0 255.255.255.192 192.168.0.0 255.255.255.0 
access-list inside_nat0_outbound_1 extended permit ip 192.168.3.0 255.255.255.0 192.168.0.0 255.255.255.0 
access-list groupname_splitTunnelAcl standard permit 192.168.3.0 255.255.255.0 
access-list inside_access_in extended permit icmp 192.168.3.0 255.255.255.0 192.168.0.0 255.255.255.0 
access-list inside_access_in extended permit ip any any

Open in new window

0
 
jerryhattAuthor Commented:
Thanks Arnold. running either 'show crypto isakmp sa' or 'show crypto ipsec sa' returns 'there are no *** sas'

The 192.168.0.0/24 domain is my home lan range which could be anything depending on who accesses the VPN.

How can I put in a rule that allows traffic from any remote lan if it is connecting via VPN?
0
 
giltjrCommented:
Unless you are doing site to site VPN, you need to account for your real home IP subnet.

I was under the impression that you are doing remote client access.  The only "remote" IP address you need to worry about is the IP subnet that is handed out by the DHCP server for remote access.  

The VPN server will only see the IP address it hands out via DHCP.  It will never see your real IP address.  That is the VPN server will only see 192.168.3.5-192.168.3.24.

The VPN server should never see 192.168.0.0/24.
0
 
jerryhattAuthor Commented:
Thankyou giltjr, that makes sense. I feel that there are so many possible causes for the problems I am experiencing it is going to be difficult to sort it out.

Inbetween posts I have now managed to connect to the VPN and ping the server behind the ASA. I still cannot browse on the remote machine or ping the ASA internal IP but I think this is down to the incorrectly set split tunnelling (which I believe is required).

I have stripped out the incorrect rules that I have found and will proceed to configure the split tunnel. I will close this question now and raise another if I have problems with the split tunnel.
Thanks everyone for your help - all the responses have been useful in sorting out this configuration and helping me learn the ASA a little better.
0
 
jerryhattAuthor Commented:
Follow-up - All working now.
Even though the tunnel was set to it's own group policy it required split tunnelling to be set under default group policy.
Thanks again for your help.
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

  • 8
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now