RIPng on 2620XM

I'm running RIP on two 2620XM routers connected via serial. I configured for IPv6, and RIPng, but the routing isn't there. Here's some R1 and R2 stuff:
=======================================
R1
=======================================

R1#
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.168.2.0/24 is directly connected, Serial0/0
R    192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:02, Serial0/0
R1#
R1#
R1#sh ipv6 route
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   2001:DB8:0:6::/64 [0/0]
     via ::, Serial0/0
L   2001:DB8:0:6::1/128 [0/0]
     via ::, Serial0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R1#
R1#
R1#sh ip int s0/0
Serial0/0 is up, line protocol is up
  Internet address is 192.168.2.1/24
  Broadcast address is 255.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.9
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is enabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
R1#
R1#
R1#sh ipv6 int s0/0
Serial0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::20A:8AFF:FE34:5DA0
  Global unicast address(es):
    2001:DB8:0:6::1, subnet is 2001:DB8:0:6::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::9
    FF02::1:FF00:1
    FF02::1:FF34:5DA0
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
R1#
R1#
R1#

=======================================
R2
=======================================

R2#
R2#
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:20, Serial0/0
C    192.168.2.0/24 is directly connected, Serial0/0
C    192.168.3.0/24 is directly connected, Loopback42
R2#
R2#
R2#sh ipv6 route
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   2001:DB8:0:6::/64 [0/0]
     via ::, Serial0/0
L   2001:DB8:0:6::2/128 [0/0]
     via ::, Serial0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R2#
R2#
R2#sh ip int s0/0
Serial0/0 is up, line protocol is up
  Internet address is 192.168.2.2/24
  Broadcast address is 255.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.9
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is enabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
R2#
R2#
R2#sh ipv6 int s0/0
Serial0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::20B:5FFF:FE63:28E0
  Global unicast address(es):
    2001:DB8:0:6::2, subnet is 2001:DB8:0:6::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::9
    FF02::1:FF00:2
    FF02::1:FF63:28E0
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds
  Hosts use stateless autoconfig for addresses.
R2#
R2#

Open in new window

LVL 9
GivenRandyAsked:
Who is Participating?
 
rochey2009Connect With a Mentor Commented:
Hi,

You need to enable ripng along with ipv6 addresses on your ethernet interfaces.
0
 
asdlkfCommented:
Upgrade your IOS to something that includes ADV.IPServices...


Can I see the output of "show ver"
0
 
rochey2009Commented:
Hi,

Please can you post you configuration.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
GivenRandyAuthor Commented:
Both have Advanced IP Services:
R1#
R1#
R1#sh ver
Cisco IOS Software, C2600 Software (C2600-ADVIPSERVICESK9-M), Version 12.4(1c), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Tue 25-Oct-05 20:56 by evmiller

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

R1 uptime is 5 minutes
System returned to ROM by power-on
System image file is "flash:c2600-advipservicesk9-mz.124-1c.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2620XM (MPC860P) processor (revision 0x100) with 127627K/3445K bytes of memory.
Processor board ID JAD062900NA (3806818723)
M860 processor: part number 5, mask 2
1 FastEthernet interface
1 Serial interface
32K bytes of NVRAM.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

R1#
R1#

========================================

R2#
R2#


R2#
R2#sh version
Cisco IOS Software, C2600 Software (C2600-ADVIPSERVICESK9-M), Version 12.4(1c), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Tue 25-Oct-05 20:56 by evmiller

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

R2 uptime is 3 minutes
System returned to ROM by power-on
System image file is "flash:c2600-advipservicesk9-mz.124-1c.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2620XM (MPC860P) processor (revision 0x100) with 127627K/3445K bytes of memory.
Processor board ID JAD06450C6L (124785105)
M860 processor: part number 5, mask 2
1 FastEthernet interface
1 Serial interface
32K bytes of NVRAM.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

R2#
R2#

Open in new window

0
 
GivenRandyAuthor Commented:
sh run:
0
 
GivenRandyAuthor Commented:
Hmm, "sh run" again:
R1#
R1#
R1#sh ver
Cisco IOS Software, C2600 Software (C2600-ADVIPSERVICESK9-M), Version 12.4(1c), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Tue 25-Oct-05 20:56 by evmiller

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

R1 uptime is 5 minutes
System returned to ROM by power-on
System image file is "flash:c2600-advipservicesk9-mz.124-1c.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2620XM (MPC860P) processor (revision 0x100) with 127627K/3445K bytes of memory.
Processor board ID JAD062900NA (3806818723)
M860 processor: part number 5, mask 2
1 FastEthernet interface
1 Serial interface
32K bytes of NVRAM.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

R1#
R1#

========================================

R2#
R2#


R2#
R2#sh version
Cisco IOS Software, C2600 Software (C2600-ADVIPSERVICESK9-M), Version 12.4(1c), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Tue 25-Oct-05 20:56 by evmiller

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

R2 uptime is 3 minutes
System returned to ROM by power-on
System image file is "flash:c2600-advipservicesk9-mz.124-1c.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2620XM (MPC860P) processor (revision 0x100) with 127627K/3445K bytes of memory.
Processor board ID JAD06450C6L (124785105)
M860 processor: part number 5, mask 2
1 FastEthernet interface
1 Serial interface
32K bytes of NVRAM.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

R2#
R2#

===============================

R2#
R2#
R2#
R2#sh run
Building configuration...

Current configuration : 1296 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$8oVy$WghYL1yLVvuCKdfo6RkXc0
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
!
!
no ip dhcp use vrf connected
!
!
ip cef
no ip ips deny-action ips-interface
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback42
 ip address 192.168.3.42 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.2.2 255.255.255.0
 ipv6 address 2001:DB8:0:6::2/64
 ipv6 rip myRip enable
 clockrate 1000000
 no dce-terminal-timing-enable
!
router rip
 version 2
 network 192.168.2.0
 network 192.168.3.0
 no auto-summary
!
ip classless
!
!
no ip http server
no ip http secure-server
!
ipv6 router rip myRip
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password 7 1306181C1F1E0B2638
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password 7 104D061711051D071F
 logging synchronous
 login
line vty 5 15
 exec-timeout 0 0
 password 7 094F41070D17181E18
 logging synchronous
 login
!
!
end

R2#
R2#
R2#

Open in new window

0
 
GivenRandyAuthor Commented:
Dang it. Let's try that one more time (why isn't there an "edit" or "delete"?):
R1#
R1#
R1#sh run
Building configuration...

Current configuration : 1500 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$IRYB$XbsxxPPW.vtF1FrMJ/SS1.
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.149
ip dhcp excluded-address 192.168.1.200 192.168.1.254
!
ip dhcp pool MyPool
   network 192.168.1.0 255.255.255.0
   domain-name MyDomain.com
   default-router 192.168.1.1
!
!
ip cef
no ip domain lookup
no ip ips deny-action ips-interface
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.2.1 255.255.255.0
 ipv6 address 2001:DB8:0:6::1/64
 ipv6 rip myRip enable
 no dce-terminal-timing-enable
!
router rip
 version 2
 network 192.168.1.0
 network 192.168.2.0
!
ip classless
!
!
ip http server
no ip http secure-server
!
ipv6 router rip myRip
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password 7 104D061711051D071F
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password 7 070C2E425A1B160904
 logging synchronous
 login
line vty 5 15
 exec-timeout 0 0
 privilege level 15
 password 7 082243401D0B0A1B01
 logging synchronous
 login
!
!
end

R1#
R1#

===============================================

R2#
R2#sh run
Building configuration...

Current configuration : 1296 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$8oVy$WghYL1yLVvuCKdfo6RkXc0
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
!
!
no ip dhcp use vrf connected
!
!
ip cef
no ip ips deny-action ips-interface
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback42
 ip address 192.168.3.42 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.2.2 255.255.255.0
 ipv6 address 2001:DB8:0:6::2/64
 ipv6 rip myRip enable
 clockrate 1000000
 no dce-terminal-timing-enable
!
router rip
 version 2
 network 192.168.2.0
 network 192.168.3.0
 no auto-summary
!
ip classless
!
!
no ip http server
no ip http secure-server
!
ipv6 router rip myRip
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password 7 1306181C1F1E0B2638
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password 7 104D061711051D071F
 logging synchronous
 login
line vty 5 15
 exec-timeout 0 0
 password 7 094F41070D17181E18
 logging synchronous
 login
!
!
end

R2#
R2#

Open in new window

0
 
GivenRandyAuthor Commented:
Okay, I just did that. Did it for the one loopback on R2 as well:
R1#
FastEthernet0/0            [up/up]
    FE80::20A:8AFF:FE34:5DA0
    2001:DB8:0:18::1
Serial0/0                  [up/up]
    FE80::20A:8AFF:FE34:5DA0
    2001:DB8:0:6::1
R1#
R1#
R1#sh ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   2001:DB8:0:6::/64 [0/0]
     via ::, Serial0/0
L   2001:DB8:0:6::1/128 [0/0]
     via ::, Serial0/0
C   2001:DB8:0:18::/64 [0/0]
     via ::, FastEthernet0/0
L   2001:DB8:0:18::1/128 [0/0]
     via ::, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R1#
R1#
R1#sh ipv6 int br


=============================================

R2#
R2#
R2#sh ipv6 int br
FastEthernet0/0            [up/down]
    FE80::20B:5FFF:FE63:28E0
    2001:DB8:0:18::2
Serial0/0                  [up/up]
    FE80::20B:5FFF:FE63:28E0
    2001:DB8:0:6::2
Loopback42                 [up/up]
    FE80::20B:5FFF:FE63:28E0
    2001:DB8:0:3::42
R2#
R2#
R2#sh ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   2001:DB8:0:3::/64 [0/0]
     via ::, Loopback42
L   2001:DB8:0:3::42/128 [0/0]
     via ::, Loopback42
C   2001:DB8:0:6::/64 [0/0]
     via ::, Serial0/0
L   2001:DB8:0:6::2/128 [0/0]
     via ::, Serial0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R2#
R2#

Open in new window

0
 
GivenRandyAuthor Commented:
Okay, got it now. After double-checking everything and using your last comment, success. Points are on there way!
0
 
GivenRandyAuthor Commented:
Thank you!
0
 
rochey2009Commented:
please can you post

show ipv6 rip myRip database

and

show ipv6 rip

0
 
GivenRandyAuthor Commented:
Sure. I think we're good.
R2#
R2#
R2#sh ipv6 rip
RIP process "MyRip", port 521, multicast-group FF02::9, pid 209
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 6, trigger updates 1
  Interfaces:
    Serial0/0
    FastEthernet0/0
    Loopback42
  Redistribution:
    None
R2#
R2#

============================

R2#show ipv6 rip MyRip database
RIP process "MyRip", local RIB
 2001:DB8:0:6::/64, metric 2
     Serial0/0/FE80::20A:8AFF:FE34:5DA0, expires in 164 secs
 2001:DB8:0:18::/64, metric 2, installed
     Serial0/0/FE80::20A:8AFF:FE34:5DA0, expires in 164 secs
R2#

Open in new window

0
All Courses

From novice to tech pro — start learning today.