• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2227
  • Last Modified:

Links don't work in IE8 / Win7

I have a computer that is running Windows 7 (64-bit).

When running the default version of IE8 (32-bit), links that should open in a new window do not work.

Links that open in the same window work just fine.

For example, loading a page with the following links:
This will work: <a href="http://www.google.com">Google</a>
This one will NOT work: <a href="http://www.google.com" target="_blank">Google</a>

I've already tried disabling all the add-ons when running IE. Makes no difference.
If I run the 64-bit version of IE, either of the links work.

The links work fine for Google Chrome or Firefox.

How do I get these links to work properly in the default (32-bit) version of Internet Explorer?

Thanks.
0
msambhu
Asked:
msambhu
1 Solution
 
Ravi AgrawalCommented:
Did you check your Pop-up Blocker setttings in IE. Is it mistakenly set to "HIGH: Block all Pop-ups? Ctrl to override"

Path to Pop-up blocker settings- IE >> Tools >> options >> Privacy Tab >> Settings Button.

Image attached.

Ravi.

popup-blocker.PNG
0
 
senadCommented:
Turn off protected mode.
0
 
msambhuAuthor Commented:
grtraders:
Pop up blocker level was set to medium. Turned off pop-up blocker. No change.

senad:
Turned off Protected Mode. No change.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
senadCommented:
reset internet explorer settings to their default condition (Internet options - Advanced)
0
 
msambhuAuthor Commented:
Senad:
IE settings have been reset. No change.
0
 
senadCommented:
I can not reproduce your error on W7 x64.
So I am inclined to think that this is something
that has to do with Google Chrome.
As you probably know,there's a war between
M$ and Google in which the later uses all sort's of filthy
trick's (just like M$ used to).It is rumored that Chrome
purposely disables some IE functions to push it out of
the picture....Don't really know....
You can try removing Chrome (and later do a nice registry clean),
and defaulting IE once again....
0
 
msambhuAuthor Commented:
Actually ended up opening a ticket with Microsoft on this one.
The tech went through a bunch of things and still couldn't get it resolved.

Finally, doing an in-place upgrade (Win7 on top of Win7) fixed the problem.
0
 
mtpitCommented:
Did this computer happen to be a HP?
0
 
msambhuAuthor Commented:
No. It's a Dell Laptop D830.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now