Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 362
  • Last Modified:

Losing Production Network Connection with Dual Nics on different subnets

I have a Systems Center Operations Manger R2 RMS server running Windows Server 2003 x64.  The server is an HP BL460c G1 blade with latest firmware/drivers.  

My network configuration is as follows:
2 Internal Nics
NIC 1: Prod network with 172.17.*.* IP
NIC 2: DISABLED in windows

2 Nics from Mezzanine card
NIC 3: GPRS Modem attached via Network with 192.168.2.1 IP
NIC 4: DISABLED in windows

So in total, I have 4 NICs, 2 of which are in use.  NIC 3 is attached to a cellular modem to perform paging from SCOM.  

The configuration works.  My production network works fine and the paging works fine.  The issue that I have is that after a few days, my production network just stops functioning.  The NIC itself is connected, but I cannot ping the server what-so-ever.  If I connect via the iLO (remote interface) on the server, the server will be up and running.  As soon as I disable NIC 3 with the modem, my production network instantly comes back!

It seems like the production traffic gets confused and no longer tries to go through NIC1.  I can immediatley re-enable NIC3 (modem) and everything works fine again for a few days.  NOTHING is logged in the application or system log stating what happened.  There will eventually be events stating that the server can't communicate with a DC and you can tell when SCOM stops working, but no events state why the traffic stops communicating via NIC1.  

My Binding order is set in the following order:
1. Production Network
2. GPRSModem
3. Disabled NIC
4. Disabled Nic

Note: If I leave the modem NIC disabled, it will function fine and I have not experienced the issue.  

Other note: I completely removed the HP teaming software hoping that it might be it, but that didn't help either.  

Does anyone have a clue why this might be happening?  Please let me know if you need any additional information.  
0
STEHelp
Asked:
STEHelp
  • 2
1 Solution
 
STEHelpAuthor Commented:
I think I might have answered my own question, but I'd like someone to confirm.

I just double checked my NIC configuration.  Here is the full config for each active NIC.  I had two different gateways specified!

Production NIC:
IP: 172.17.89.*
Subnet: 255.255.255.0
Gateway: 172.17.89.1

Modem NIC:
IP 192.168.2.1
Subnet: 255.255.255.0
Default Gateway: 192.168.2.1

I just cleared the default gateway on the modem NIC and I can still communicate with it just fine.  Could that have been the issue?  
0
 
Justin OwensITIL Problem ManagerCommented:
STEHelp,

It shouldn't be an issue, but it can be an issue.  While I am sure you would do this anyway, your best bet a this time is to monitor the machine now that you have made this change and see what happens.

Justin
0
 
magicdlfCommented:
Hello STEHelp,

Yes it's the default gateway causing the issue. When you are visiting an IP that your computer doesn't know where, it will be sent to the Default Gateway, which in your case is your localmachine. That's why you have the network issue. When you have 2 NICs, a best practice is to define the IPTables to make sure your computer know when to use the correct NICs to visit different networks. Your guess is correct. : )

Regards,
magicdlf
0
 
STEHelpAuthor Commented:
That makes sense.  I will close this for now and monitor.  
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now