?
Solved

ASA VPN Access to Internet

Posted on 2009-12-28
5
Medium Priority
?
364 Views
Last Modified: 2012-05-08
I have gone through several config edits in order to get access to my local network from the VPN network.  In doing so, I lost access to the internet.  All internet traffic for VPN users should traverse the tunnel and go out the ASA outsi9de interface.  I know it is something simple I am missing, but I am not sure what that "something" is.

Config is attached.  I am guessing I have a NAT problem...

Thanks for all the help in advance.

Chris


hostname sun
domain-name guestnet
enable password *************************
passwd *********** encrypted
names
!
interface Vlan1
 nameif outside
 security-level 0
 ip address 71.60.101.28 255.255.255.248
!
interface Vlan4
 no nameif
 security-level 50
 ip address pppoe
!
interface Vlan11
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/0
!
interface Ethernet0/1
 switchport access vlan 11
 shutdown
!
interface Ethernet0/2
 switchport access vlan 11
!
interface Ethernet0/3
 switchport access vlan 11
!
interface Ethernet0/4
 switchport access vlan 11
!
interface Ethernet0/5
 switchport access vlan 11
!
interface Ethernet0/6
 switchport access vlan 11
!
interface Ethernet0/7
 switchport access vlan 11
!
boot system disk0:/asa821-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
 domain-name hexnet
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list inbound extended permit icmp any any
access-list inbound extended permit ip 192.168.10.0 255.255.255.0 any inactive
access-list inbound extended permit ip any 192.168.10.0 255.255.255.0 inactive
access-list inbound extended permit ip any host 23.185.208.113
access-list nonat extended permit ip any 192.168.10.0 255.255.255.0
pager lines 24
logging enable
logging console critical
logging asdm critical
logging mail alerts
logging from-address CiscoWarning@*****.com
logging recipient-address ****@****.com level alerts
no logging message 106015
no logging message 313001
no logging message 313008
no logging message 106023
no logging message 710003
no logging message 106100
no logging message 302015
no logging message 302014
no logging message 302013
no logging message 302018
no logging message 302017
no logging message 302016
no logging message 302021
no logging message 302020
mtu outside 1500
mtu inside 1500
ip local pool vpnpool 192.168.10.5-192.168.10.25
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-621(2).bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 23.185.208.113 192.168.1.203 netmask 255.255.255.255
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 71.60.101.31 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal 30
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 10
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 60
console timeout 0
management-access inside
dhcpd dns *.*.*.*  
dhcpd lease 14400
dhcpd ping_timeout 300
dhcpd domain hexnet
!
dhcpd address 192.168.1.200-192.168.1.210 inside
dhcpd dns *.*.*.* interface inside
dhcpd lease 14400 interface inside
dhcpd ping_timeout 300 interface inside
dhcpd domain geeknet interface inside
dhcpd update dns both interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection scanning-threat shun duration 3600
threat-detection statistics
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn
group-policy hexvpn internal
group-policy hexvpn attributes
 dns-server value 24.25.5.61 24.25.5.60
 vpn-tunnel-protocol IPSec svc
 split-tunnel-policy tunnelall
 default-domain value hexnet
username fakeuser password ********************** encrypted privilege 15
tunnel-group guestvpn type remote-access
tunnel-group guestvpn general-attributes
 address-pool vpnpool
 default-group-policy guestvpn
tunnel-group guestvpn ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:099c7f04894a9b8ae738ad0b65ecce43
: end
sun#

Open in new window

0
Comment
Question by:TheHexzero
  • 3
5 Comments
 
LVL 57

Expert Comment

by:Pete Long
ID: 26131721
If you wanted your remote VPN clients to get internet access FROM the network behind the ASA then you need a proxy server on that site and the clients browsers need to be configured to use that proxy?
Unless you are saying you want split tunneling enabling so they can browse the internet while connected to the VPN? if so add the following
 access-list Split-Tunnel standard permit 192.168.1.0 255.255.255.0
  group-policy guestvpn attributes
 dns-server value {dnsserver1} {dnsserver2}
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Split-Tunnel
 default-domain value yourdomain.com
0
 
LVL 4

Expert Comment

by:periferral
ID: 26135040
which tunnel group are your vpn users accessing?
0
 
LVL 4

Accepted Solution

by:
periferral earned 1000 total points
ID: 26135076
im guessing you are using guestvpn
if so enable
' split-tunnel-policy tunnelall'
for guestvpn

looking at the nat configuration, everything seems okay.
you seem to have same-security-traffic permit intra-interface which would be needed to doing the hairpin route you want to take to sending internet traffic out.

here is the config guide to what you want to do.

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00805734ae.shtml

if it helps any but Im thinking you've already looked at it
0
 
LVL 4

Expert Comment

by:periferral
ID: 26135081
i presume from what you are saying that the vpn clients are able to connect and access the inside network just fine. is this right?
0
 

Author Closing Comment

by:TheHexzero
ID: 31675211
A victim of my own circumstance.  The policy was set to the default instead of the custom policy i set with the tunnelall option set.  Thanks!
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Powerful tools can do wonders, but only in the right hands.  Nowhere is this more obvious than with the cloud.
Considering cloud tradeoffs and determining the right mix for your organization.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question