Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 477
  • Last Modified:

RAID 0 on Clevo D900f - Odd noise from HDD - system pauses momentarily - what could be the cause?

I have a recently purchased Clevo D900F with the following specs:

Core i7 - 960
12GB 1333mhz RAM
3 x 500GB - Seagate ST9500420AS in RAID-0
Intel ICH10R Raid Controller
GeForce GTX 280M (1GB)

I am running Windows 7 Ultimate as well as Fedora 12 (Dual boot) - The problem exhibits itself in both operating systems

The issue is as follows:

While I am working on the system (MAINLY when I am using desktop apps - rarely does this occur in games, but it does from time to time) the drive will make a noise (and also show steady activity) and sometimes the system will pause when it does.  The behavior is sporadic, and usually abates after happening a few times.  As I write this it is happening regularly, maybe ~30 second intervals.

The noise is not harsh like a "click", rather like a drive coming out of idle... almost like a gear shift noise with an almost liquid sound to it.  Immediately following that is a light "click" for lack of a better term.  It's not a hard, sharp click... quite soft.

I have been in touch with Malibal (the vendor) tech support, and they had me run some diagnostics (out of the Intel RAID manager) most of the tests aren't available, but I did the short and the long with 0 issues.  

I have turned write-back caching on to see if that would help, no dice.    I have run several other health checks in Linux as well as Windows, and nothing shows up as problematic at all.  Drive performance is phenomenal.  I have DD'd each partition off (~1.3TB) to an E-SATA drive, etc...  this is not an issue when the drives are actually being used (no clicky).

So, this leads me to believe that perhaps because there is so much RAM that nothing ever gets paged and something weird is happening.  I have set the drives to never spin down in Linux with hdparm, to no avail. I have set swappiness to 10, etc.

I am attaching a screenshot of my current system utilization.  When I run multiple VMs with a lot of things going on, it will page a tad.  This is usual running state.



kinfo.jpeg
0
rxfoster
Asked:
rxfoster
  • 12
  • 4
  • 4
  • +1
2 Solutions
 
souquetbressandCommented:
"So, this leads me to believe that perhaps because there is so much RAM that nothing ever gets paged and something weird is happening."

Have you attempted removing some of the modules to confirm or deny this theory?
0
 
rxfosterAuthor Commented:
Hmmm... good point.  I can definitely try that.
0
 
_Commented:
Also check that Power Management for the drives is turned off in the bios.
It kind of sounds like two PM settings are conflicting. One is trying to turn them off, and the other is turning them back on.
0
[Video] Oticon Case Study

Open office environments can create the dynamics for innovation, but they also bring some challenges. With over 1,000 employees in an open office, Oticon needed a solution that would preserve the environment while mitigating disruptive background noises.

Watch how they did it.

 
souquetbressandCommented:
Any news on this?
0
 
rxfosterAuthor Commented:
Hi gents, thanks for taking a look at this!

I have shut off the paging file completely in Windows, as I am not at a point where I can take out the RAM (my tools are at the office... yes, I know... idiocy.)

I did get into the BIOS and the only power settings relating to the drives are "AHCI" and "RAID" and I cannot change that and still boot, of course.

It's Phoenix BIOS, the options seem pretty sparse.  I checked the pre-boot RAID utility, and it doesn't have anything relating to power either.

I am going to check again for driver updates, and see if the intel config program in windows has any power options.

0
 
_Commented:
>> ...the options seem pretty sparse...

Yeah, Phoenix is good at that.   : /

As well as the drivers, see if there is a Firmware update for those drives and any mention of this issue.
0
 
rxfosterAuthor Commented:
Okay, well the removal of the pagefile, and the RAM changes haven't fixed the issue... I have installed some beta drivers... 9.5.x (up from 8.9.x).

I found some other people having the same issues, which put me onto this... as I had the most recent driver (there doesn't appear to be a separate firmware package).

So, hopefully this fixes it, or at least doesn't think pummel the whole system.  Will try to update tonight.
0
 
rxfosterAuthor Commented:
I did not notice the issue last night in Windows, but I have had it occur twice today in Fedora.

I will be running Windows for 4 or so hours on the train tonight, so I will keep an eye on that.

If it happens twice in a day, I am not too concerned.  It was happening 10+ times per minute previously.
0
 
_Commented:
OK. It's also possible it is some kind of mobo hardware issue.
Since it is a notebook, is there any difference between running on battery and being plugged in?
0
 
rxfosterAuthor Commented:
Because of the major power draw of the components in this beast, battery doesn't last a very long time, but I will try that tonight!

I am still getting the issue, but it is definitely less pronounced so far!

Both frequency and severity.
0
 
rxfosterAuthor Commented:
Well, happens on battery as well as AC.

I believe the issue has subsided, but there was a 20-30 minute bout this morning - pretty obnoxious... the actual pause doesn't seem as bad (which is good) and the "click/clunk" sound seems a little more subdued as well.

I will leave this open for a bit just to see if there are any more suggestions.
0
 
ByrneITCommented:
Sounds to me like the click of death that many of the 7200.11 drives experience before they brick themselves. I'd run Seatools on the drives stat.
0
 
rxfosterAuthor Commented:
I've run every test I can get my hands on, in Linux and in Windows.... all come back clean.
0
 
ByrneITCommented:
Since it's a 7200.4, I don't know what the issue is, but I will tell you that I have had horrible problems with 7200.11 drives in all manner of RAID, and I am not alone.
0
 
rxfosterAuthor Commented:
Okay, heading down that path, there are quite a few tests that I cannot run in the Seatools app - because the disks are in an array.

I am sure I could boot to a FreeDOS or similar utility and run the command line utility on the drives from there, and I am pretty sure that would be fine but I don't want to do that if there is a chance I could bork my data... it takes me forever to back it up, so before I do that and proceed with the test, does anyone have any advise either way regarding testing individual drives from a RAID-0 set?

I imagine if the tests are run without some auto-fix options turned on that it wouldn't be an issue, I would love to hear any of your opinions on the matter!
0
 
rxfosterAuthor Commented:
Okay, I am trying hdparm again... I had done it once before, but I think it reset itself... I am not sure if this is every boot cycle or what, but I need to find a way to make it persistent.

I will monitor it today and see if it fixes the issue, and if it does not I can at least re-check the setting to see if it reset itself...
0
 
rxfosterAuthor Commented:
I did not have the issue after disabling APM through hdparm... after bringing the machine up today, however, the problem was back.  I checked hdparm, and the setting was back to 128 (instead of 255 which is disabled).  I have manually re-disabled and if the problem does not appear through the rest of the day, I will set it persistently and close this as solved.
0
 
rxfosterAuthor Commented:
Alright, same thing happened this morning... was fine all day, then clicky-slurp noise immediately.

So, it is that the drives themselves are set with an APM value of 128.... and I think it is so noticeable because of the amount of RAM and the fact that there are 3 disks in RAID, but I don't know that for sure.

For reference, the command to set the drives APM level is:

hdparm -B -255 /dev/sdx

the levels are 1-254 (1 being the most aggressive power save, and 254 being the most aggressive IO - 255 disables)  I am setting mine to 254 to see if that alleviates the problem enough to be bearable while not completely disabling APM.

(Note: hdparm can be very dangerous depending on the switch used)

0
 
ByrneITCommented:
If I were you, I'd replace these drives before you lose your data. I'd recommend Hitachi, and a server class drive.
0
 
_Commented:
Thank you much.    : )
0
 
rxfosterAuthor Commented:
"If I were you, I'd replace these drives before you lose your data. I'd recommend Hitachi, and a server class drive."

Nothing wrong with the drives, and this is a laptop... can you put server class drives in a laptop?
0
 
ByrneITCommented:
No, but Hitachi makes some very good laptop drives that offer high performance and low power consumption.

I just had yet another Seagate 7200.11 drive die on me last week.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 12
  • 4
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now