• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2993
  • Last Modified:

Cannot join Windows 7 64 bits to SBS 2003 domain

Hello,
I am trying to join a Windows 7 64 bits machine to my SBS 2003 using the SBS Network Configuration Wizard but I keep getting and error saying:
An error ocurred when configuring network settings. See your network administrator.
I already joined a Windows 7 32 bits to my network without problems and compared the TCP/IP properties of both computers and they look the same. I installed the Update for Windows Small Business Server 2003: Windows Vista and Outlook 2007 compatibility (KB 926505) on my server but no luck. Then I tried to install service pack 3 of ISA server 2004 standard but I got an error telling me the installation source for this product is not available. So I canot install ISA server SP3. I wonder if this has something to do with the network configuration wizard not running. Any help will be really appreciated.
0
ocortes
Asked:
ocortes
  • 5
  • 4
  • 2
1 Solution
 
Rob WilliamsCommented:
You need to have SBS full patched, i.e. up to date.
Then make sure DNS points ONLY to the SBS, and if there is more than one network adapter such as a wired and wireless adapter, disable all but the wireless adapter. You should be then be able to joint the domain with the   http://SBSname/connectcomputer wizard. Once complete you can re-enable other network adapters and they will work fine.
Where 32 bit WINS worked I suspect it is due to multiple NIC's.
0
 
ocortesAuthor Commented:
Hello,
I have just the Local area connection enabled, wireless disabled. I went to the Properties of Internet Protocol Version 4 and changed to use the following DNS server addresses to point to my SBS server and I get the same error. It looks like it is going to work and even creates the _sbs_netsetup_ user but it just doesn't finish. I just get the same error.
0
 
Rob WilliamsCommented:
Have you installed the following updates:
http://support.microsoft.com/kb/926505
When you configured DNS, make sure you didn't just add the SBS, it must point only to the SBS and not an ISP or router, even as an alternate.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Vaidas911Commented:
Do you have DNS server configured properly? Enter command prompt and type nslookup - does your server respond without errors? Can you ping your domain controler by domain, e.g. ping mydomain.local ?
Also, I read your question: "and compared the TCP/IP properties of both computers and they look the same" - I hope they does not look exactly the same :) I mean IP address is different?
0
 
ocortesAuthor Commented:
Yes I installed the update for kb 926505 but I couldn't install the ISA server SP3 that was suggested on the website because I get the error mentioned on the original post. I entered nslookup on the command prompt of the Win7 machine and I get:
Default server: server.mydomain.local
Then I clicked exit and typed: ping server.mydomain.local and I got 4 replies with 0 lost.
But I keep getting the same error
0
 
Vaidas911Commented:
Could you please post here ipconfig /all of your server and those two Windows 7 computers?
0
 
ocortesAuthor Commented:
Here is for the Windows 7 64 bits:
C:\Users\User>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : User-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Broadcast
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : LoneStarMilkProducers.local

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : LoneStarMilkProducers.local
   Description . . . . . . . . . . . : Intel(R) 82567LM Gigabit Network Connecti
on
   Physical Address. . . . . . . . . : 00-24-E8-FA-AE-14
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::f083:c096:e438:c7dd%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.16.30(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Monday, December 28, 2009 12:25:34 PM
   Lease Expires . . . . . . . . . . : Tuesday, January 05, 2010 2:08:31 PM
   Default Gateway . . . . . . . . . : 192.168.16.2
   DHCP Server . . . . . . . . . . . : 192.168.16.2
   DHCPv6 IAID . . . . . . . . . . . : 234890472
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-BC-15-86-00-24-E8-FA-AE-14

   DNS Servers . . . . . . . . . . . : 192.168.16.2
   Primary WINS Server . . . . . . . : 192.168.16.2
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.LoneStarMilkProducers.local:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

And here is for the server:

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : lsmserver
   Primary Dns Suffix  . . . . . . . : LoneStarMilkProducers.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : Yes
   DNS Suffix Search List. . . . . . : LoneStarMilkProducers.local

Ethernet adapter Network Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection #
2
   Physical Address. . . . . . . . . : 00-13-72-F6-2C-03
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 204.118.30.95
   Subnet Mask . . . . . . . . . . . : 255.255.255.192
   Default Gateway . . . . . . . . . : 204.118.30.65
   DNS Servers . . . . . . . . . . . : 192.168.16.2
   Primary WINS Server . . . . . . . : 192.168.16.2
   NetBIOS over Tcpip. . . . . . . . : Disabled

Ethernet adapter Server Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-13-72-F6-2C-02
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.16.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : 192.168.16.2
   Primary WINS Server . . . . . . . : 192.168.16.2

PPP adapter RAS Server (Dial In) Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
   Physical Address. . . . . . . . . : 00-53-45-00-00-00
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.16.26
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Disabled

0
 
Vaidas911Commented:
Your network configuration seems to be ok, you should be able to join domain if AD and DNS works correctly.
Now try to go to Win7 64 computers system properties (control panel->system->change settings of computer name, domain etc) and try to swith from workgroup to domain LoneStarMilkProducers.local - does it prompt for administrators credentials?
Make sure that there is no computer in AD with same computer name.
0
 
ocortesAuthor Commented:
I changed the domain and first I got a window saying welcome to the domain but then I got an error:
Computer Name/Domain Changes
Changing the Primary Domain DNS name of this computer to "" failed. The name will remain "LoneStarMilkProducers.local"
The error was:
The remote procedure call failed and did not execute

Any ideas?
0
 
Vaidas911Commented:
Look what i found in mighty google:
I have had the same problem and it is the same with Windows Server 2008 R2 and other 64bit version Windows.
I suggest the problem is with the ISA server that I am sure you have on your domain controller.
You need to go to ISA Server Management --> Add-ins --> Application Filters --> RPC Filter, right click the filter and disable it - select to stop and restart the ISA server service option when disabling the RPC filter.
In my case I also had to create a Firewall Policy to temporarily allow everything from all networks to all networks, effectively opening up the ISA firewall completely.
Make sure the Remote Proceedure Call services are running and then you should be able to join the domain.
Finally restore the ISA Server to its previous configuration.
0
 
ocortesAuthor Commented:
You were right the problem was ISA server after I followed your steps I was able to join the computer without any problems. I am still wondering why this is just a problem with 64 bits, but anyway it is working.
Thank you very much for all your help
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 5
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now