?
Solved

Need help configuring Cisco 2650XM with AT&T ADSL

Posted on 2009-12-28
4
Medium Priority
?
792 Views
Last Modified: 2012-05-08
I have a Cisco 2650XM Router with a WIC-1ADSL.  I need assistance with the configuration.  We are using AT&T Business DSL.  I have gone thru it several times and can't figure out why it will not connect.  The show config is as follows:

 CISCOROUTER# show config
Using 1703 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CISCOROUTER
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Oq5H$f/qcc/C6/R0YmQZHagll01
enable password XXXX
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
no ip routing
no ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface ATM0/0
 no ip address
 no ip route-cache
 atm restart timer 300
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/0.1 point-to-point
 no ip route-cache
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.0.0.0
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
 ip tcp adjust-mss 1412
 speed auto
 half-duplex
 no mop enabled
!
interface Dialer0
 ip address dhcp
 ip mtu 1452
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname genesisrealtygroup@att.net
 ppp chap password 0 XXXX
 ppp pap sent-username genesisrealtygroup@att.net password 0 XXXX
!
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 remark INSIDE_IF=FastEthernet0/0
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.0.0.0 0.255.255.255
dialer-list 1 protocol ip permit
snmp-server community public RO
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password XXX
 login
!
!
end
0
Comment
Question by:bkwatts
4 Comments
 
LVL 13

Expert Comment

by:GuruChiu
ID: 26136134
can you pls post the output of:
show ip interface brief
0
 
LVL 15

Accepted Solution

by:
greg ward earned 2000 total points
ID: 26136351
for this to work you need a routing protocol enabled.
router rip

Also you might need to put an access-list on the dialer interface, i have this.
interface Dialer1
 ip address negotiated
 ip access-group 1 in
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname user
 ppp chap password 7 pass
 ppp multilink
0
 
LVL 3

Expert Comment

by:Greg_Arnold
ID: 26138414
Here's my config from a 3640 over AT&T's ADSL.  It works fine.  You don't need RIP or an access list.  I would recommend some sort of access list but RIP is completely unnecessary.

interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in
!
interface ATM0/0.1 point-to-point
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
!
interface Dialer1
 ip address negotiated
 ip access-group 110 in
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp authentication pap callin
 ppp pap sent-username <me>@att.net password 7 <PASSWORD>
!
0
 

Author Closing Comment

by:bkwatts
ID: 31670622
Thanks for the assistance!  It worked like a charm.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question