Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Configure my wireless (Belkin) router to work with Remote desktop and a comcast fixed IP?

Posted on 2009-12-28
14
Medium Priority
?
912 Views
Last Modified: 2013-12-14
Hi -
I am getting desperate!  I have comcast cable with a fixed ip.  
I have an XP Pro box that I need to remote desktop into (it has to be RDP, not logmein, etc.).
On the comcast router I have port 3389 forwarded to the ip address of the XP box.  
in that configuration it all works like a dream.  I can remote in no problem.
now, when I plug in my belkin wireless, it still works fine.
but, when any computer connects to the beklin and gets a dynamic address, the remote desktop no longer works.  I can remove the computers from the belin and then RDP starts working again no problem.  
something is going on...

anyone have any ideas?

thanks!
0
Comment
Question by:hsitner
  • 6
  • 4
  • 4
14 Comments
 
LVL 16

Expert Comment

by:Jon Brelie
ID: 26135491
did you exclude the static IP you setup for your pc from the DHCP on the belkin?  or did you disable DHCP on the belkin and just use the comcast router?  Make sure there aren't duplicate dhcp servers.
0
 

Author Comment

by:hsitner
ID: 26135822
thanks!
I disabled DHCP on the comcast, but I still have the same issues.
Basically, if I disconnect all the computers in the house from the belkin (but it is still on) I can hop on my ATT network and remote in.  As soon as another computer gets online via the belkin, I can no longer remote in on the ATT connection.

the comcast router doesn't have wireless, that's why I have the belkin.

any ideas?

0
 
LVL 16

Expert Comment

by:Jon Brelie
ID: 26135834
From your posts, I am making the following assumtions:

 - The computer you want to RDP to is not connected to the Belkin
 - You only have one dhcp server enabled on your network.

Does your belkin have your RDPbox's IP excluded from it's dhcp range?  You aren't getting any IP conflict messages are you?

Are you certain you forwarded port 3389 from your comcast router directly to the RDPbox?  Does RDP work when you have the belkin turned off?
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 

Author Comment

by:hsitner
ID: 26135848
Thanks!
Yes - the XP Pro box is hardwired into the comcast router
and yes, the only enabled DHCP is on the belkin.

I'm getting no conflicts.  the RDP box has the internal IP address 10.1.10.21, I use port forwarding (3389) to forward from the IP to that box.

RDP works fine when the belkin is on or off.  it only stops working when another computer hops onto it.

it's quite perplexing to me.
0
 
LVL 16

Expert Comment

by:Jon Brelie
ID: 26135893
are your systems on the belkin on a different network than your RDPbox?  IE, different subnet?
0
 

Author Comment

by:hsitner
ID: 26135910
slightly over my head - subnets.  the subent masks on both of them are the same (255.255.255.0)
the IP addresses are different though (10.1.10.1 for the comcast) and 192.168.2.1 for the belkin.

0
 
LVL 16

Expert Comment

by:Jon Brelie
ID: 26138952
Okay.  When you have systems connected to the Belkin router, is it only rdp to the other system that doesn't work?  It can still access the internet just fine?
0
 
LVL 7

Expert Comment

by:thegof
ID: 26140568

Is sounds like you have a combination Comcast Modem+Router (CRM), and then are connecting another Belkin Wireless Router (BWR) down the line.  I'll use RDP to refer to the RDP XP Box.
(1) Cable -> CRM -> RDP (works)
(2) Cable -> CRM -> BWR -> RDP (doesn't work)
(3) Cable -> CRM -> BWR -> (other wireless computers)
                            +----> RDP (wired via CRM)
 
Now, do you have config (2) or config (3) as the config with the Belkin involved?  If you're trying config (2), then you'll have to ensure the CRM forwards port 3389 to the BWR, and then the BWR forwards that port the the RDP.  
Another way to handle this config that is (IMHO) easier, is to connect the BWR to the CRM via the LAB side of the BWR.  Disable DHCP on the BWR, and it will just serve as an access point and switch (not a router). This would remove one router hop complication.
If this doesn't help, post the model number of the CRM as well as more specifics on how you have the RDP box wired in each case.  It will let the rest of us more easily diagnose the problem (since we can't see your wiring).
0
 

Author Comment

by:hsitner
ID: 26143521
Thanks.
let's see if I can give back some data for you.
(1) does work (I read this as:  cable line goes into the SRC brand CRM, RDP is connected to CRM, I can RDP in)
(2) does work (I read this as the above, but now the BWR is plugged into the CRM)
(3) does not work (I read this as the (2) but now there are computers getting dynamic addresses from the BWR)

Both 2 and 3 have the BWR.  the configuration works fine (port forwarding, etc.) until another computer attaches to the BWR.

What is the "LAB side of the BWR"?  I don't think I can do this as I want the DHCP on the BWR - I have several computers in the house that need to access the wireless connection.

the CRM is an SMC not sure of the model #, I can get that later.
on the RDP box, it's network adapter is hardwired to grab the IP 10.2.1.21, and on the CRM I have port 3389 forwarded to that.  that's what works like a charm.  
The BWR gives out DHCP addresses starting at 192.168.2.26

thanks
0
 
LVL 7

Expert Comment

by:thegof
ID: 26144480
Oops.  LAN, not LAB.  Connect the output from the CRM directly to a LAN port (not the WAN port) of the BWR.  Before you do this, disable the DHCP service on the BWR.  Now, by connecting it to the LAN side, the CRM serves as the DHCP server and port forwarder.  The BWR is simply acting as a 4-port switch (one port of which is connected to the CRM, another to your RDP.  Finally, the wireless section of the BWR acts as an access point.  The "router" function of the BWR is left unused since you didn't connect to the WAN port.
Give it a try.  Since (1) works, using the BWR as an access port + switch should keep that functionality.
0
 

Author Comment

by:hsitner
ID: 26146186
Thanks.  the problem with this is the CRM doesn't have wireless capabilty, that the was the whole reason I bough the BWR.  Maybe I can get Comcast to supply a CRM with wireless abilities
0
 
LVL 7

Expert Comment

by:thegof
ID: 26148705
I think you're missing the point.  If you connect the BWR on the LAN side, you can still use the wireless capabilities.  The only thing is the router functionality is bypassed since you don't really need it.  So, the config is:
cable -> CRM ----(ethernet)---> (LAN side of) BWR --(ethernet connected to LAN on BWR) --> RDP.
You have the CRM set up exactly as you had it in (1) above, with it forwarding to the RDP and serving as the DHCP server.  The BWR has it's own DHCP server turned off (you only want one per subnet) and effectively serves as a network switch (the four wired lan ports) and an access point (the wireless function).  The router functionality (WAN port) is left unused as you don't need it and it simply adds more complication.
I've set networks up this way before and it greatly simplifies the forwarding issues.  Give it a quick try.
0
 

Author Comment

by:hsitner
ID: 26149454
Thanks again.  we might be getting closer, but a side effect has caused me not be able to duplicate a scenario.  basically, I have everything configured as described.  my vista/thinkpad laptop is attaching wireless to the belkin.  I went to use my wife's mac to attempt the RDP with the thinkpad on the network, but her laptop wouldn't connect to the BWR.  I took it downstairs and hardwired in, it won't connect either.  Interestingly, the thinkpad laptop connects wirelessly but not via the cord (tried with two seperate ethernet cables).  both computers can connect when hardwired into the CRM.
so without a second computer to throw onto the network (one to RDP into the RDP box, and one to be on the network) I can't test the scenario.

any idea why a mac might not be able to connect wirelessly or wired to the BWR?
0
 
LVL 7

Accepted Solution

by:
thegof earned 2000 total points
ID: 26151607
Make sure the wireless computers are using DHCP, or have static addresses on the CRM subnet (looks like 10.1.10.* from above).  None should be on the "old" BWR subnet of 192.168.2.*.  I believe you also need to set a static address for the Belkin box to also be on the 10.1.10.* subnet.  If you list the model number I could see if the on-line docs will let me know exactly what screen it's on, but it's likely on the same screen you currently are setting the 192.168.2.* address scheme.  Just don't set it as 10.1.10.1 since that is the CRM :)
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes you have to pull out old tricks to get a new firewall to work… While we were installing a new Sonicwall at a customers site we found that sites they were able to visit before were not working.  It seemed random and we could not understa…
Why do some people recommend buying business VoIP from an ISP? What are the benefits to my company? What are the costs?
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Suggested Courses

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question