SLES 10 Startup/Driver Problem

Hi,
I have installed SLES 10-SP2 on my Lenovo Thinkcenter Desktop having config of Core 2 2.40GHZ and 4GB Ram
Model: MT-M 7298-AF5
The thing is i have installed SLES 10 successfully and it detects network, CD/DVD Rom, USB Drive and can install 3rd party software on 1st automatic restart after installation.. After this when i restart the comp again none of the Drivers are detected like when i put in a pendrive it doesn't show up nor does any CD and not even network, also when i try to install any software it doesn't happen...  I tried restarting several time but still same problem...

Please help me... I have tried installing SLES 10 on 5 different comp of same Model and still facing the same problem...

Regards...
CCBRONETAsked:
Who is Participating?
 
nociConnect With a Mentor Software EngineerCommented:
if there are no messages then they at least didn't fail (they might not get started or they are running).

to check the last:

ps ax  | egrep '(hald|udevd|dbus)'

Which should at least show a udev-daemon process
several hald-... processes.
various dbus-... processes.

0
 
nociSoftware EngineerCommented:
What if you don't install the extra software after 1st boot?   (and what software is installed, if it only doesn't start correctly after installing software).
what is the output of dmesg when you insert a usb device or remove it?
anthing in /var/log in the most recent file after inserting/removing a device?
0
 
CCBRONETAuthor Commented:
the software runs correctly after every boot... the software are mysql, java, glassfish, basically a server setup...
I also tried not installing software after 1st boot.. but still when i restart i get the same prob.. so basically its not the 3rd party software fault
I dont get any msg on insert of the usb drive or cd or anything......  
it just dont detect any network nor any external drive like usb or CD/DVD....
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
nociSoftware EngineerCommented:
Do the hal, udev and or dbus subsystem actualy start, those are the components involved in device management.
0
 
CCBRONETAuthor Commented:
how do i check if hal, udev and or dbus subsystem starts or no????
0
 
nociSoftware EngineerCommented:
There are various ways:
- During boot there are messages on the screen (maybe you need to push a key to drop the fancy curtain....)  
- in /var/log check the various logfiles for messages from these processes,
- if they are running there are processes called hald, dbus-daemon, udevd

most problems leave there traces in a log file in /var/log...
0
 
CCBRONETAuthor Commented:
nope there is no error message for dbus, hald udevd
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.