Virtual PC Intergration Components Installation interupted

Posted on 2009-12-29
Last Modified: 2013-11-23
I have converted my Windows XP SP3 partition into a VHD
Loaded this into Win 7 64bit host Virtual PC
I repaired the client OS and it now boots okay
(some further alterations were made to resolve WGA issues and main drive letter back to C: but I don't believe this is related)
I also removed the VMWare installation on the virtual XP to avoid conflicts

I run the install for "Virtual PC Intergration Components" and near the end it fails and does a rollback and shows a screen "Setup Interupted" Setup was interupted before Virtual PC intergration Components could be completely installed."

" Virtual PC intergration Components was not installed. To Install the Virtual PC Inergration Compnents, run setup again"
"Click Finish to exit setup"

I have attached the VPCICInstallLog.txt

Virtual PC Intergration Components
"Virtual PC Intergration ComponentsVirtual PC Intergration Components
Question by:Damester
    LVL 41

    Accepted Solution

    The key line in the log is

    VPCBUS: UpdateDriverForPlugAndPlayDevices using C:\Program Files\Virtual PC Integration Components\VPCGBus.inf
    VPCBUS: UpdateDriverForPlugAndPlayDevices failed with 1603

    Don't bother looking up error code 1603... that just means "installation failed"
    Here is something to try (just guessing, really)...   try it again with all of your non-crtical USB devices unplugged.
    LVL 22

    Expert Comment

    are you sure you are using x64 edition of virtual pc ?

    Author Comment

    Yes, I am running X64 edition of Virtual PC

    In device manager I can see an Unknown device listed in Other Devices
    And another in System Device calleds "Unknown device"

    I have no mention of "Universal Serial Bus Controllers"

    I compared it with a fresh Virtual XP enviroment and see that it has
    a "Univiersal Serial Bus Controllers"

    Looks like this could be my issue

    I therefore cannot disable USB to try the suggestion above
    Although my mouse and keyboard are working

    What type of drivers can I install to get this working
    (I assume my motherboard USB drivers are not relevant)

    Author Comment

    I googled VPCGBus.inf and found this solution

    It states:

    Just delete %windir%\system32\drivers\wdf01000.sys  and retry the installation.

    This worked for me

     I then had in Device Manager a "Universal Serial Bus Controller" heading, within is "USB Virtualization Bus Driver" with exclamation stating "the drivers for this device is not installed"
    I reinstalled and pointed to the program files virtual pc folder and it installed correctly

    I now just need to work out why a Virtual PC Intergration device is stuck in "other devices" and still alongside it, is an "Unknow device"
    Maybe I will start a new post for this if I get stuck,

    Thanks very much for your help
    LVL 41

    Expert Comment

    Well, at least we're on the right track...
    Ya know... I'm not sure if the physical USB drivers have anything to do with this... I suspect not.
    Here is a crazy idea...  if you already have a "fresh" and working image, you should be able to mount that images' VHD file as a second drive on the non-working image.   Then start the non-working image up, go to the device manager, click on "update driver", when it asks for the location of the driver, point it to the D:\Windows\Infi directory (on the other VHD).  If that works, then you can again point to the D:\Windows\Drivers directory for the actual driver.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Enabling OSINT in Activity Based Intelligence

    Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

    I recently purchased an HP EliteBook 2540p notebook/laptop. It has two video ports on it – VGA and DisplayPort. HP offers an optional docking station for the 2540p that also has both a VGA port and a DisplayPort. There are numerous online reports do…
    Article by: Lee
    Windows 7 Ultimate and Enterprise (and 2008 R2) introduced a new feature you may not be aware of - Boot from VHD.   Boot from VHD (or what Microsoft refers to asNative Boot allows you to install Windows to a VHD (Virtual Hard Disk) file that is t…
    This Micro Tutorial will teach you how to the overview of Microsoft Security Essentials. This is a free anti-virus software that guards your PC against viruses, spyware, worms, and other malicious software. This will be demonstrated using Windows…
    This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    9 Experts available now in Live!

    Get 1:1 Help Now