• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1029
  • Last Modified:

Windows 7 login does not stay on domain

Here's a better explaination:

I have a win 7 workstation (that has the Local Administrator Enabled)  I have joined it to a domain.  The login box defaults to my domain (shows it under the login boxes.  However, when I start typing in "administrator"  (which I want to be the Domain admin)  the login switches back to the machine name.  Thus to login to the domain, I have to enter Domain\Administrator

The point being, I want it to stay logging into the domain.  In any previous windows version, once you choose your domain login, it stays.  Windows 7 seems to be defaulting back to the machine, if an ID with the same name resides locally as well.

Any thoughts or answers as to have it be locked on the domain (or whichever) once I start logging in and not swap back?
0
dbonis77
Asked:
dbonis77
  • 6
  • 2
  • 2
  • +2
1 Solution
 
AncientFribCommented:
I have the same problem with my Windows 7 workstations.  Although there may be a way around it I am not aware of one.  Have you considered renaming your local administrator account?  Something like "localadmin"?
0
 
KieranFootCommented:
You need to set the default login domain using the Group Policy Editor tool.
Run: gpedit.msc from a command line to access this tool.

Im just finding the location of this entry for you.
0
 
KieranFootCommented:
Its in:

Computer Configuration, Administrative Templates, System, Logon

The Setting is:

Assign a default domain for logon
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
akhafafCommented:
    Hi there dbonis77,,,,

Do you have the same problem when attempting to access the domain with any other user a part from the Local Administrator ?????

If you dont have it  I recommend you to create a new local user and add it to the administrators group then disable the local Administrator , try and see if you get the same problem
http://windows7news.com/2009/01/30/windows-7-uac-security-flaw/

By the way what edition of win7 do you have .???

Best Wishes
0
 
KieranFootCommented:
akhafaf, this problem is with all editions of windows 7 and accurs any time you attempt to logon to a domain with an account that also exists on the local system. The logon app (by default) prefers the logon of local users to domain ones and changing the stated setting will correct this.
0
 
dbonis77Author Commented:
Does anyone know if this is something that can be configure in a SysPrep answer file?
0
 
KieranFootCommented:
Im sorry, I have no idea, I know you can joing a domain using sysprep, but im not sure about setting GP settings.
0
 
dbonis77Author Commented:
regardless about Sysprep, and going back to the real issue.  Is there a way to pick the domain on the fly without having to key in the full domain\username?  Ie:  as the drop down box in XP and prior?
0
 
KieranFootCommented:
Can you add registry entries using the sysprep tool?

If so, add this:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"DefaultLogonDomain"="test-domain"
0
 
KieranFootCommented:
As far as I know, there is no way to get a dropdown list of domain on windows 7
0
 
Todd GerbertIT ConsultantCommented:
A quick test tells me what you're describing is only applicable to "Administrator", and not every local user (I have created a local user with the same name as my domain user, when logging on the system still assumes I'm logging onto the domain), and that the settings described above have no effect.

I believe that if you wish to logon as a DOMAIN\Administrator then you must always type the domain name.

If you wish to log onto the local computer instead of the domain, you can use ".\username" instead of typing out the computer name, though I also am not aware of any way to get a drop-down list of domains.

Theoretically you should rarely be logging on as a domain admin anyway.
0
 
Todd GerbertIT ConsultantCommented:
To my knowledge, after testing and perusing documentation, http:#a26138916 is correct.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 6
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now