PHP 5.3.1 installation on IIS6

hello, I am trying to enable PHP script execution on IIS6 and its not working, I am getting an error that the specified module could not be found. I have tried both the installer and the zip package. Right now I have the installer version with a mapping to php5isapi.dll which i loaded additionally as it was not in the current php package. I am not sure which PECL modules I have to load maybe that is the issue. I have a mapping in the IIS for php extentions and these are allowed too.
Appreciate some assistance, tnx
nevyana2006Asked:
Who is Participating?
 
nevyana2006Connect With a Mentor Author Commented:
i am sorry i have missed your response. usually get an e-mail when there is an update to the question. i didn't see your response until today when i was abt to delete the question. in the mean time found this article:http://learn.iis.net/page.aspx/247/using-fastcgi-to-host-php-applications-on-iis-60/
which worked for me.. if someone takes that road - make sure you read the wgiz comments following the article. thank you very much.
0
 
Tray896Commented:
It could be an issue with the spaces in your path.  Try this.

If the path to your PHP directory has spaces (e.g. "C:\\Program Files\\PHP") and IIS gives a 500+ error or responds with "The specified module could not be found." when you try to run a PHP script, try changing the ISAPI DLL's path in IIS (in the "Home Directory" tab, under "Configuration...") to the 8.3-equivalent path.
 
That is, use C:\\PROGRA~1\\PHP\\php5isapi.dll instead of "C:\\Program Files\\PHP\\php5isapi.dll".
0
 
Thinker07Commented:
1)First download the Php5.1.2 in to ur harddisk
2) Rename the Php5.1.2 to PhP
3)copy this Php folder in C:\PHP\
4) go to control panel and select IIS and click on Handler Settings  on right side there is a hyperlink
5) ADD SCRIPT TAG click
6) in ReQUEST PATH textbox: *.php
7) Executable:  click browse button C:\php\php5isapi.dll
8) Name: PHP
9) create one demo.php page and run

U r Ready to Run,,,,
0
 
nevyana2006Author Commented:
In IIS6 I have the extentions path to C:\PHP\php5isapi.dll - with one forward slash - the other enrties are with one forward slash. I have restarted the service after the update and the server was rebooted too.

Not sure abt item 4) - handler settings - not seem to find these...

0
 
Thinker07Commented:
I am sending you a link in which stepwise given

http://www.visualwin.com/PHP-ISAPI/

http://www.iisadmin.co.uk/?p=4

I hope this will help out Dude..

I hope you will run the PHP page
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.