?
Solved

Problems after migration to Exchange 2007 - Out of Office/Sync Issues

Posted on 2009-12-29
17
Medium Priority
?
629 Views
Last Modified: 2012-05-08
Trying to finish up migrating from Exchange 2003 on one server to Exchange 2007 on another.  After migrating the mailboxes we are having a couple issues on Outlook 2007 clients.  One, the Out of Office doesnt work, when you try to open it you get the following error:
"Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later." - works fine from owa and from Outlook 2003.
Also, 2007 clients keep getting the following error in the Sync Issues folder:
"Not downloading Offline address book files. A server (URL) could not be located"
There may be other issues that I haven't noticed yet, but this is all I'm aware of so far.  I tried running the test from Ctrl/Right clicking the outlook icon in the system tray, but that just fails saying "Autoconfiguration was unable to determine your settings!"
Thanks in advance for your suggestions!
0
Comment
Question by:PJBluske
  • 9
  • 4
  • 3
  • +1
17 Comments
 
LVL 31

Accepted Solution

by:
Justin Owens earned 1000 total points
ID: 26138379
Try going through the troubleshooting steps on this link.  It directly addresses your issue:

http://www.pro-exchange.eu/modules.php?$1&name=News&file=article&sid=686

Justin
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26138427
With Exchange 2007 you need to setup an antodiscover A Record pointing to your IP address in your domain's DNS as the Offline Address Book for Outlook 2007 & above uses Autodiscover for location.
If you have not set this up, then this will explain the Offline Address Book problems.
You also need to buy and install a 3rd Party SSL SAN certificate if you want to use all the features of Exchange 2007:
Self-Signed Certificate issues: http://technet.microsoft.com/en-us/library/bb851554(EXCHG.80).aspx 
Names to use in 3rd Party SSL SAN Certificate: http://blog.sembee.co.uk/archive/2008/05/30/78.aspx
The Out of office can also be upset by incorrect autodiscover settings:
http://www.petri.co.il/forums/archive/index.php/t-19944.html 
0
 

Author Comment

by:PJBluske
ID: 26138582
DrUltima,
I actually had looked at that article already and didnt really get anywhere with it - that first reason I coudln't run the test because of the autodiscover not detecting my settings, 2nd reason i don't really understand, 3 and 4 i ruled out by checking the security on the EWS dir and being logged into the pc as myself.
alanhardisty,
On the cert thing, we do have a ssl cert for the owa address, but we need some SAN cert?  Would not having this cause it to not work completely?  or just to complain about not having a cert?  I cant imagine we would need to purchase another cert just ot use out of office...

Thanks much for both of your comments.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 1000 total points
ID: 26138671
Please run through the following thread:
http://forums.msexchange.org/m_1800435908/mpage_1/key_/tm.htm#1800459243
Are your clients conected to the domain or are they accessing the server remotely?
Have you setup an Autodiscover A Record in your Domains DNS records pointing to your IP Address?
0
 

Author Comment

by:PJBluske
ID: 26138767
I'll have to look over that thread this afternoon but wanted to comment on your other questions quick.
Clients are connected to the domain, and i did create a DNS entry pointing to the Exchange server - hopefully i didnt it correctly:  Host: autodiscover, FQDN: autodiscover.domain.com, and the Exchange servers IP address.  Is that the right way to do it?  Thanks again, and i'll comment back after i get through the link...
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26138790
Sounds about right.  How long ago did you create the DNS record?
 
0
 

Author Comment

by:PJBluske
ID: 26139331
Created the dns entry 6 days ago...
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 26139354
Well that should have replicated by now!
Let me know once you have gone through the thread if you need more info.
0
 

Author Comment

by:PJBluske
ID: 26140660
One would certainly hope so...  I do get a reply when pinging 'autodiscover' so that should be good.

Still unsure where i need to go from here - I'm seeing some references to outlook anywhere... i dont need that enabled, do i?  Also, i'm not sure that thread applies since they seem to be talking mostly about trying to access OOF from non-domain pc's.  Then again, I could be totally missing something - having a really hard time with this.  Why couldn't they just make it behave like it does in Outlook 2003? :p
0
 

Author Comment

by:PJBluske
ID: 26153385
Still struggling with this... any suggestions would be greatly appreciated.  Thanks!
0
 
LVL 31

Expert Comment

by:Justin Owens
ID: 26153442
Right-click the Outlook icon in the System Tray and select Test E-mail AutoConfiguration.   When Clicking Test E-mail AutoConfiguration in the context menu, a set of tests are executed against the Client Access Server as well as Active Directory.  Please post your results.

Justin
0
 

Author Comment

by:PJBluske
ID: 26153463
Fire up the test, click test - after about 45 seconds i get this under results:
Autoconfiguration has started, this make take up to a minute
Autoconfiguration was unable to determine your settings!

I assume this is part of the problem, but haven't had any luck correcting it... obviously...
0
 
LVL 31

Expert Comment

by:Justin Owens
ID: 26153506
From the Exchange 2007 console, type this command:

get-webservicesvirtualdirectory | Set-WebServicesVirtualDirectory -WindowsAuthentication:$true

Let me know if it works after that.

Justin
0
 

Author Comment

by:PJBluske
ID: 26153589
Ran the command without getting any errors.  Still seeing all the same issues though - cant run the test, sync issues and unable to open out of office :(
Anything else i should do along with running that command?  I did try an iisreset, but that made no difference.
0
 

Author Comment

by:PJBluske
ID: 26170524
Any other thoughts?
0
 
LVL 3

Expert Comment

by:tusharnextgen
ID: 26170663
0
 

Author Closing Comment

by:PJBluske
ID: 31670787
Issue ended up being a couple different things.  Permissions on the Autodiscover virtual site were dorked - needed to uncheck anonymous and check integrated windows auth.  That fixed my autodiscover issues.  Then needed to set EWS the same.  After that things fell together.  Thanks alanhardisty and DrUltima, i wouldn't have stumbled on the solution without your suggestions.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Steps to fix “Unable to mount database. (hr=0x80004005, ec=1108)”.
If you have come across a situation where you need to find some EDB mailbox recovery techniques, then here you will find the same. In this article, we will take you through three techniques using which you will be able to perform EDB recovery. You …
how to add IIS SMTP to handle application/Scanner relays into office 365.
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Suggested Courses
Course of the Month16 days, 2 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question