• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 672
  • Last Modified:

Macbook keeps loosing D-Link wireless connection if using WAP security

My MacBook Pro (running Snow Leopard) keeps dropping its wireless connection to my D-Link RangeBooster G" Wireless Router (WBR-2310) when using WAP security (Cipher type = TKIP).  I can get it to connect, but minutes later it's no longer connected & I have to reboot the MacBook.  It did seem to work fine if I used WEP security.  I do have the latest updates to the router.

Is it possible to make my MacBook stop dropping the connection when I use WAP security?
0
leslieinva
Asked:
leslieinva
  • 5
  • 3
  • 3
  • +1
1 Solution
 
cenocreCommented:
Snow Leopard has a lot of issues. Since you can connect it is probably not your firewall, but often times the firewall can cause problems on connections that used to work as it blocks just some of the connections. You can test by temporarily turning the firewall off. If that works then delete the firewall preferences and reset the firewall.

Otherwise, try deleting
  • com.apple.airport.preferences.plist
  • NetworkInterfaces.plist
  • preferences.plist form /Library/Preferences/SystemConfiguration
Then empty trash and restart
In the Network Preference Pane, choose Advanced and go to the TCP/IP tab and Renew the DHCP Lease

Also use Onyx ( http://www.macupdate.com/info.php/id/11582/onyx ) to delete caches as they are possibly a factor. Might as well have Onyx do other maintenance as well.
0
 
jhyieslaCommented:
Do you happen to have a cordless phone system in your house or office that might be on the same  bandwidth as your wireless device.  This could potentially cause interference.
0
 
leslieinvaAuthor Commented:
cenocre,

What do you mean by "turn off my firewall?"  Is this on my Mac or on the router?  My router has some firewall settings related to DMZ & VPN, but no way to turn it off.


jhyiesla,

I do have a cordless phone, but it's a 5.8 GHz phone, which was not the kind the Apple rep I spoke with said was likely to cause problems.  What's the likelihood that at cordless phone would interfer with WAP security versus WEP security?


0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
jhyieslaCommented:
I think that typically wireless devices still run at 2.4, but some are dual band and it would be worth checking the router. You'd think that interference would be interference and WEP or WPA would not make a difference, except that WEP is a lot less robust so I suppose it's possible.

Personally I have stopped using the "cheaper" routers because of all sorts of issues that I've had over the years.  I use the Apple Airport Extreme exclusively.  Do you have a friend who might let you borrow one or who would let you hook your MB to it to test?
0
 
leslieinvaAuthor Commented:
jhyiesla,

I don't want to buy another router as my D-link has worked fine with the other 4 PCs in my home.  Can Airport extreme work with Windows PCs?
0
 
jhyieslaCommented:
Yes. I have two at work that mostly connect Windows-based PCs.  I have two at home that connect my Macs and a Wii.

Something else to think about, although it too should not make any difference between WEP and WPA is distance of the MB from the router.  What kind of signal strength do you get?  Have you taken on all of the Apple software updates?
0
 
cenocreCommented:
leslieinva:

"What do you mean by "turn off my firewall?"  Is this on my Mac or on the router? "

On your Mac in the Sharing Preference Pane. There are some known issues with connectivity that can be resolved by resetting the firewall (delete the prefs), but you can simply test it first by turning it off.
0
 
leslieinvaAuthor Commented:
Cenocre,

I found the firewall in the security pane.  It was turned off.  

On the router, I've tried turning off the Super G with Turbo (now just using Super G without Turbo) so I can enable auto channel scan.  I'll see how that works.
0
 
cenocreCommented:
Did you do the other steps suggested in my first post?
0
 
leslieinvaAuthor Commented:
cenocre,

I'm sorry, I forgot to tell you that yes I have tried those other steps, but it's still dropping off.
0
 
dwow132000Commented:
My D-link router started flaking out on on me in a similar way a few months ago but without the WAP. Try resetting the the router back to defaults and setting up the WAP again.  Resetting did the trick for me
0
 
leslieinvaAuthor Commented:
I finally bought an apply time machine & it works great as a wireless router.
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

  • 5
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now