Iphone/mobile problem

I had my exchange 2003 server working beautifully with my ipod and mobile (ipod on exchange and mobile as imap,but then i broke it :-( i wanted my webmail to have the outlook splash page for a login instead of the user/password box coming up so like a fool i started playing with the directory security on all sites exchange/oma related an broke the lot. Ive re-run the connect to the internet wizard but to no avail. Oma in a browser says there is a server error. The logs complain of active sync not having negotiation enabled on the directory, the ipod says it cant connect and my mobile says communication interupted and fails. Lmao. Epic fail eh? Help please
LVL 1
McSnooginsAsked:
Who is Participating?
 
McSnooginsConnect With a Mentor Author Commented:
Cheers for the help folks but i've just reinstalled windows and it's sorted it
0
 
MiniDevoCommented:
If it were me, I'd just reset/restore the phone to factory settings as long as you have your data/apps backed up.
0
 
McSnooginsAuthor Commented:
I tried that with the ipod but it didnt help
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
MiniDevoCommented:
As per Apple's support guide?
http://support.apple.com/kb/HT1414

I would try and connect via activesync without resorting the info on your iPhone and see if that works first.
0
 
McSnooginsAuthor Commented:
I think if i can get oma working and my mobile, the ipod will likely kick in to. Or not. Anyways the mobile is my main priority. Any ideas with it? Thanks so far
0
 
MesthaCommented:
Turning on forms based authentication will break ActiveSync if it isn't done correctly.
You need to turn it off and then follow the instructions in MSKB 817379 to have both FBA and ActiveSync enabled at the same time.

Simon.
0
 
McSnooginsAuthor Commented:
Hi simon, how do i turn it off?
0
 
McSnooginsAuthor Commented:
OK I've turned forms based authentication off. I'm not fussed about using SSL as it's only my home emails. Just want it working again first. I've set all the authentication to annonymous, integrated and basic in the exchange, exchange-oma, OMA. exchweb, rpc and rpcwithcert websites. Still not working though. Are the settings i put in for authentication right? I'm still getting Event ID 3031 "The mailbox server does not allow "Negotiate" for its exchange-oma directory, in the application logs. Mobile phone still says communication interupted when i try to update my email :(
0
 
McSnooginsAuthor Commented:
Also set the same authentication on the activesync website. I have no idea what i'm doing here :(
0
 
MesthaCommented:
Reset the virtual directories as per this article at Microsoft.
http://support.microsoft.com/default.aspx?kbid=883380

That will get you back to the default configuration. DO NOT enable FBA.
Then you can complete the steps in 817379 again.

Confirm that works and then FBA can be enabled .

Simon.
0
 
McSnooginsAuthor Commented:
Okay dokay. I'll get that done in the next couple of hours and let you know how i get on. What does FBA being enabled do for me? Is that part of the setup full stop or is it for the outlook splash screen for webmail? I'm not fussed about the splash screen anymore (just in case it has nothing to do with it)
0
 
MesthaCommented:
Forms Based Authentication provides the web page for login. It also changes the authentication to cookie based, so when you logout of the session it is closed. Without FBA enabled someone can press back and get in to the mailbox.

Simon.
0
 
McSnooginsAuthor Commented:
Right, i've done all the steps from both KB's.  I got no errors at all throughout the process and the webmail works fine. I don't want to enable FBA now, i didn't realise it required SSL. I don't want to use SSL as i don't know how for one and it's only my home emails that are mainly banter and spam so it's not a problem if someone gets in to them.
Anyways the short story is after doing all that my phone still says "Session failed Communication interupted" (it's setup with IMAP) and my ipod (Set up for exchange) still says can't connect to server. Any further ideas? Cheers for help so far.
0
 
Alan HardistyCo-OwnerCommented:
Please have a run through my FAQ for Activesync and Exchange 2003 which should provide you the IIS settings and tests to perform to work out what is wrong and solutions that should get you going again:
http://www.it-eye.co.uk/faqs/readQuestion.php?qid=1 
0
 
McSnooginsAuthor Commented:
Update for you, my phone works fine it's just the ipod through exchange that isn't working. Which is a pain cause i'm also missing my contacts etc.
0
 
Alan HardistyCo-OwnerCommented:
My FAQ will hopefully get you sorted.
0
 
McSnooginsAuthor Commented:
kk. i'll work through it and let you know.
0
 
McSnooginsAuthor Commented:
still working on this. mobile still works iphone doesnt. will let you know when i've gone through the whole faqs
0
 
McSnooginsAuthor Commented:
KK i've followed the FAQ and after running the active sync tester it says it is not available and points towards forms based authentication being on. But it isnt. What should i do next?
0
 
Alan HardistyCo-OwnerCommented:
Are you talking about Error 500?
When you say the mobile is working - are you talking about IMAP still or is it setup for Exchange using Activesync?  I am assuming it is IMAP as if the iPhone does not work, then Activesync on the mobile should not either!
0
 
McSnooginsAuthor Commented:
yeah i should stop talking about the mobile. it is imap. both weren't working at the start of this though. the error is 500
0
 
Alan HardistyCo-OwnerCommented:
Okay - please refer back to my FAQ at the part starting:
Ensure that Forms Based Authentication is NOT turned on under Exchange Virtual Server
Then continue to work down the FAQ from there - please read carefully and if that fails, then it is a call to Microsoft I am afraid.
0
 
McSnooginsAuthor Commented:
it's dawned on me just now,in the faq it tells me to rebuild the virual directories from a back up of the exchange directory the original problem was caused because id messed up the settings for the exchange directory. Surely recreating a new directory from the messed up one will just be exactly the same and thats why it's no different?
0
 
Alan HardistyCo-OwnerCommented:
Yes, you are right.  In that case please follow method 2 of kb883380
http://support.microsoft.com/kb/883380
0
 
McSnooginsAuthor Commented:
done that, same thing. the faq isnt clear on how i should be setting the exchange-oma directory security settings. I think that might be my stumbling block. What should the settings be?
0
 
Alan HardistyCo-OwnerCommented:
The exchame-oma uses the exact same settings as the exchange directory minus the ssl.

If you follow method 2 of kb883380 then the last part of my FAQ, that should set the right settings for you, but the beginning of my FAQ posts the correct IIS settings required on the Exchange virtual directory.
0
 
McSnooginsAuthor Commented:
i've followed method 2 with no errors. After doing the following : Disable Forms Based Authentication - Exchange HTTP Protocol (if enabled)
" Remove SSL settings from the Exchange IIS virtual directory
" Run iisreset
" Test activesync without SSL selected - hopefully this should work or give the OK result
i get the same 500 forms based error.
Forms based authentication is definitely off as is ssl.
I imagine this is becoming a bit of a struggle but i appreciate the help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.