Windows 7 Switches Programs

i'm having a weird problem that I have been unsuccessful finding answers for in the Internet. I'm using Windows 7 Professional 64-bit edition on a Toshiba laptop. I typically use the laptop on a stand with a Logitech DiNovo wireless keyboard.

Ocassionally, the PC switches from one open program to another, usually when I am clicking something. Here's an example:

I have Microsoft Outlook 2007 open. There are four columns. The right is Mail. The next is Inbox. Then Reading Pane. The last is To-do. Typically, I'll single click on an e-mail in the Inbox column to have it display in the Reading Pane. Usually, everything works the way it should. But sometimes I'll click on an e-mail in the Inbox column and suddenly it switches to an open Internet Exlplorer Window. This doesn't only happen with IE, it also happens with other programs, but less frequently. I'd say it happens about 10 times a day.

This behavior didn't happen when I first started using Windows 7, leading me to believe that something that I installed may be the culprit. But there isn't any way for me to know what could be causing the problem and the only remedy would seem to be to reinstall Windows, which I would like to avoid having to do.

Does anyone have any ideas about a solution?
Who is Participating?
RickConnect With a Mentor Commented:
It could be that your mouse pointer is bringing background windows to focus when your hand goes over the mouse pad.

Try checking your mouse pad sensitivity.
Check the mouse and keyboard to see if there are any gummed up keys. Hardware is also possibly the culprit.
arixsinConnect With a Mentor Commented:
Do you use an external mouse?

Some have application switching shortcut buttons on them that you might be accidentally pressing.
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

Very probably your touchpad is working at the same time as your mouse and
your click other options without knowing...
mlibrescuAuthor Commented:
I will check the settings of the keyboard and report back. The keyboard has a trackpad and I use that to click...I used to use the left and right mouse buttons on the keyboard but with time, they have become increasingly unresponsive.

The first thing I'll do is to use the laptop for a day without the wireless keyboard and see if the problem still exists. If it does, I can eliminate the wireless keyboard as the source of the problem.
mlibrescuAuthor Commented:
The solutions were pretty good. Apparently, the mouse buttons have a chording (if both buttoms are pressed at once) setting that was set to "flip," which must mean change open windows. Apparently, clicking the DiNovo's trackpad a certain way replicated the button chording. I set the chording feature to "do nothing" and that seemed to solve the problem.
milbrescu, thanks for the points, but please make sure in the future that you are giving points and accepted solution to the person that answered it best.  My answer was a lot more precise than rick_gwu's (no offense Rick).
mlibrescuAuthor Commented:
Your answer mentioned an external mouse and switching buttons, which I don't have. Both answers pointed me to what I think was in the right direction, but neither technically answered the question. As a matter of fact, the problem ocurred once since I closed the question, so they may not even be the correct solutions.
Well, an interesting question so far I encountered.
Could you capture the behaviour as a video file and upload it somewhere so that I can check the issue?
mlibrescuAuthor Commented:
No, I don't have any capture software. It might take a recording of 1-2 hours before the problem showed up, and that would create a very large file. By the way, it just happened about 5 minutes ago.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.