Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1767
  • Last Modified:

Create a shared folder with a Hyper-v session

I am installing company software onto a Hyper-V server.  The client installs require access to SQL and/or Folder shares.  How can I make these available for clients on the network?

I am running Windows 2008 Server standard 64 bit as the host and 2008 sever standard 32 bit as the hyper-v.
0
jamiebehl
Asked:
jamiebehl
  • 7
  • 7
1 Solution
 
Syed Mutahir AliTechnology ConsultantCommented:
When you are configuring your Hyper-V Virtual Network , make sure that you select the type as "External" this way all your virtual machines / servers will be the part of the same physical LAN (Subnet) and then file sharing etc will be achieved.

http://blogs.msdn.com/virtual_pc_guy/archive/2008/01/08/understanding-networking-with-hyper-v.aspx
Once you have your Hyper-V Network setup as external, check the IP Address of your Virtual Machine / Server to make sure its the same as your LAN ; then you can create a shared folder on any machine on your lan and provided you have the permissions setup properly they will be accessible and visible.
Hope this Helps.
PS : If your host server has 2 NICs or more, you can dedicate the 2nd nic for your Hyper-v virtual machines, the rule is the same its only to manage the traffic and load and the recommended way ; just make sure when you select the 2nd nic that it is connected to your lan switch exactly the same way as your host server's 1st nic and the hyper-v network type is "External"
0
 
jamiebehlAuthor Commented:
I have done this and joined the vs to the domain and created a share but when I try to connect from a machine on the network I get an access denied
0
 
Syed Mutahir AliTechnology ConsultantCommented:
If you are getting access denied and the machine joined to the domain successfully ; it is related to permissions ;
create a new shared folder on your virtual server, give everyone full access to it and then see what happens ?
are you tryin to access the shared folder from a domain joined client ?

if you are being prompted for a username / password, try to input the domain name \ username and the password, or try the local machine name\administrator and the password
I don't see this as a hyper-v issue, as the VS is joining to the domain properly
check the shared folder with everyone full access to test ;
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
jamiebehlAuthor Commented:
I have done research online and have seen nothing about creating a shared folder on the virtual machine.  I know you can create one on the host and the virtual machine can connect to it.  Are you sure this is even possible?  I thought it would be pretty cut and dry but now I'm questioning it.  

I have joined the Hyper-V server to the network.  I can browse shared folders on the old servers.  I have joined the domain.  But when I attempt to create a share on the Hyper-V server it will not allow me to access it from any other computer on the network.  It does not prompt me for credentials it just gives me a access denied.  
0
 
jamiebehlAuthor Commented:
I have another network with Hyper-V setup and created a shared folder just fine and accessed it from the host server.  Is there anything specific that I need to do?  This is a brand new install of 2008 on Hyper-V.  All I have done was run Windows Updates and install the integration services setup disk.  I have attempted to create a share multiple ways and have given everyone access with no success.
0
 
Syed Mutahir AliTechnology ConsultantCommented:
The Hyper-V Server in question :

I assume is the Role of Hyper-V you are using, Host OS Windows Server x64 BIT with Hyper-V Role ?

How many NICs do you have in this Hyper-v Host server ?

Virtual network you are using, make sure the type is set to External

can you rdp to this hyper-v virtual machine (not the host server) from your LAN computers ?

The virtual server can have shared folders or anything you want just like the physical server.


0
 
Syed Mutahir AliTechnology ConsultantCommented:
disable windows firewall on the hyper-v host and on the virtual server as well, disable any AV / FW you may have on the host or on the virtual server itself and see ;


0
 
jamiebehlAuthor Commented:
The Host server has 2 NIC cards.  I attempted to remote into the virtual machine and it failed.  I disabled the firewall on the host and virtual machine and remote desktop worked.  I looked at the network adapter and my options are 1. Not Connected 2. Guest Virtual Network 3. Virtual Network.  That seems to be the difference on the other network that I have no problem with.  The Network Card on it shows an actual broadcom nic card.  Is that the problem?  How do I resolve this?
0
 
jamiebehlAuthor Commented:
If I just try to go to \\servername which is my virtual server name it gives me this error:


""\\192.*.*.* is not accessible.  You might not have permission to use this network resource.  Contact the administrator of this server to find out if you have access permissions.

Logon failure: the user has not been granted the requested logon type at this computer.""

I have plugged in the second NIC card and using the Virtual Netwokr Manager changed to this NIC with still no success.  I am on location attempting to get this setup ASAP.  Please someone help.
0
 
Syed Mutahir AliTechnology ConsultantCommented:
Disable the AV and firewall on your Virtual server ; that is what it looks to be causing this and test

make sure its on the same ip subnet as all your other client pc's / servers

on your virtual server, check in security policy for the box itself :

Look in the local security policy and make sure "access this computer from the network" is set correctly.
0
 
Syed Mutahir AliTechnology ConsultantCommented:
start > administrative tools > local security policy

in the local sec policy snap-in "local policies > user rights assignment > "

there you will see "access this computer from the network"
0
 
jamiebehlAuthor Commented:
Ok I think you have found it.  There is only one name listed in here but the add/remove buttons are greyed out.  How do I add/remove people?
0
 
jamiebehlAuthor Commented:
Well I have no idea who would create a Default Domain Policy that would only allow a user that is not even being used be the only one with access to machines.  I had to go in to the default domain policy and modify this rule.  I just removed the rule all together.  Thanks for all the help.  I was in the wrong place the entire time.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now