• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 672
  • Last Modified:

Accessing locally jboss web app from other intranet

Hi,

I am telecommuting and I want one of my co-wokers access my jboss web app that locally runs. Since I use VPN, my co-worker can ping my local machine, but adding 8080 doesn't bring up jboss on the browser.

Is this possible?

p.s.
I run windows xp pro and I use time warner cable and I don't think there is firewall.
0
dkim18
Asked:
dkim18
  • 9
  • 5
  • 4
2 Solutions
 
govindarajan78Commented:
check your windows firewall; you may need to open the port 8080
0
 
dkim18Author Commented:
I set off windows firewall and opened windows port 8080, but still can't be connected.

I followed these steps:

To manually open a port, follow these steps:

   1. Click Start, and then click My Network Places.
   2. Under Network Tasks, click View Network Connections. (Or, right-click My Network Places on the desktop, and then click Properties.)
   3. Right-click the connection that you use for the Internet, and then click Properties.
   4. Click the Advanced tab, and then click Settings.

      Note If the Settings button is unavailable, ICF is not enabled on this connection, and you do not have to open any ports (because they are all already open).
   5. Click Add to open a new port.
   6. In the Description box, type a friendly name. For example, type File Sharing : Port 445.
   7. In the Name or IP address of the computer hosting this service on your network box, type 127.0.0.1.

      Note You can specify the IP address of an internal computer. But you typically will use 127.0.0.1.
   8. In the External port and Internal port boxes, type the port number. Generally, this number is the same.
   9. Click either TCP or UDP, and then click OK.
  10. Repeat steps 1 through 9 for each port that you want to open.

0
 
a_bCommented:
Can you ask your co-worker to type your ip address in his browser

http://<ipaddress>
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
dkim18Author Commented:
He got this message by using FF.

Under Construction
The site you were trying to reach does not currently have a default page. It may be in the process of being upgraded and configured.
0
 
dkim18Author Commented:
BTW, In Network connections, I am not sure which one I need to pick. I chose Local area connection 4(Cisco system VPN Adapter) and tried the above steps. I entered the IP address that my co-worker was able to ping, but I got the following error message.

untitled.bmp
0
 
govindarajan78Commented:
go to control panel-> windows firewall

in the exceptions tab - > click add port and add 8080 into it;

after that people from your network can access ur site by

http://<ur comp name>:8080
or
http://<ur comp ip>:8080
0
 
govindarajan78Commented:
you do not need to enable ICS or any other thing
0
 
dkim18Author Commented:
He got failed to connect error message.

http://<ipaddress> doesn't even work at this point.
0
 
dkim18Author Commented:
Hm...he can ping my ipaddress, but when he tried same ip address on web browser, it doesn't work.
0
 
govindarajan78Commented:
"@dkim18: He got this message by using FF.

Under Construction
The site you were trying to reach does not currently have a default page. It may be in the process of being upgraded and configured. "

coming from port 80, the default port
0
 
dkim18Author Commented:
If I use <ipaddress> that he successfully ping in my PC, I get the following result:

ping <ipaddress> --> successful

http://<ipaddress>:8080 -->unable to connect

http://127.0.0.1:8080/ -->brings up jboss server

Can I set localhost to <ipaddress> instead of 127.0.0.1?

My purpose here is to show my jboss running web app to my co-worker remotely.
0
 
a_bCommented:
"Can I set localhost to <ipaddress> instead of 127.0.0.1?"

Yes that can be done. What version of jboss are you using. You need to edit one of the xml files in the deploy directory of jboss. or you can edit run.bat to achieve that. I need to know the version of jboss to give you the right instructions.
0
 
a_bCommented:
Can you try starting the application through the command line - run.bat -b 0.0.0.0 and then try and have your colleague connect through the ip address?
0
 
dkim18Author Commented:
I run jboss 4.2.3 inside of eclipse ganymede. I selected jboss server view tab and clicked 'open launch configuration' then I tried to change 'localhost' to '0.0.0.0' in arguments tab, but it doesn't like that. Plz see the below image. How do I do that in run.bat file?

After that, do I need to set off firewall?
jboss.bmp
0
 
a_bCommented:
add -b 0.0.0.0 not localhost
0
 
dkim18Author Commented:
the problem is that I can' edit the argument. plz see the error message. if i change localhost to 0.0.0.0 and click apply and hit ok. Next time when I open again, it reads localhost again.
0
 
dkim18Author Commented:
if I do this outside of eclipse, how do I do that?
0
 
a_bCommented:
Go to the jboss bin folder and type run -b 0.0.0.0
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 9
  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now