[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

website on iis 7 is not coming up

Posted on 2009-12-29
52
Medium Priority
?
783 Views
Last Modified: 2012-05-08
Hi,
I created a website on IIS 7, but its not coming up when I browse from my local computer. What is the thing I am missing? Please help me.
Thanks in advance.
0
Comment
Question by:CPSRI
  • 24
  • 22
  • 3
49 Comments
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26143651
Are you getting any error mesdsages ? What is the url you are trying to browse to ? (are you using localhost  or computer name or other DNS name) ?
First off things I would check are: Is your default document set correctly ? can you open the default document by double clicking on it ?
 
0
 

Author Comment

by:CPSRI
ID: 26143720
i am getting the error like 'Internet Explorer cannot display the webpage', i am using domain name to browse.
regarding first off things :
yes, default document set correctly
yes, I can open the default document by double clicking on it.
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26143724
Can you view the deault IIS website?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:CPSRI
ID: 26143766
yes, i can
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26143790
and the site you are trying to access :  is it a new website or a virtual directory of the default site ?
0
 
LVL 17

Expert Comment

by:Rovastar
ID: 26144391
Can you access via localhost on the web server?
Can you access via the IP on the web server?

What is occurring in the IIS logs?
0
 

Author Comment

by:CPSRI
ID: 26145524
zadeveloper, it is a new website .
Rovastar: no, i cannot access via localhost. and yes, i can access via IP
0
 
LVL 17

Expert Comment

by:Rovastar
ID: 26145571
You cannot via localhost but can via IP? ummh That doesn't make sense.

How many websites have you configured on your server?
What do the IIS logs say?
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26145581
is the host header name correctly pointing to the iis ser (ie: if the host header is www.mycompany.com - pinging that address should give you the local ip address of the server running IIS) - also is the website running on port 80  or is ssl setup / other port configured ?
0
 

Author Comment

by:CPSRI
ID: 26147465
Rovastar: i configured 2 websites on my server, and to be frank i dont know how to read and understand the logs, could you help me in that?

zadeveloper: when i ping the domain it is giving me the ip address of the server, and the website is running on port 80 only
0
 

Author Comment

by:CPSRI
ID: 26147509
zadeveloper: its giving the ip address of the server but the result is Request timed out.
0
 
LVL 17

Expert Comment

by:Rovastar
ID: 26148775
That is fine to post the logs we can go through them.

Do you use the 2 websites? Only one of them will (attempt to)  respond to localhost and/or the IP.
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26149354
Just thinking about it : are you running a .net  Website/ standard html site / PHP for Windows ?
 
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26149360
Whats the file name of your default page ?
0
 

Author Comment

by:CPSRI
ID: 26153007
it is a basic html web site, the default page name is index.htm.
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26153027
what is the URL you are using from your workstation to try and access the site?
0
 

Author Comment

by:CPSRI
ID: 26153353
0
 

Author Comment

by:CPSRI
ID: 26160277
zadeveloper and rovastar, did you find any solution for my problem?
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26160784
Will send you some screen shots today
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26160855
Hi CPSRI
Check the bindings on your website - they should look like the screenshot shown. Also check the application pool that is running the website and ensure the .NET Version is 2.0. Right click on the application pool and go to advanced settings - check the identity there - that is has permissions to the local folder where your website is stored.
Go to: Default Document and ensure that index.htm is the only Document in there.
If it is still not working please post a screen shot of the advanced settings + application pool that its running on +  the advanced settings of the application pool. Also post the contents of : %SystemDrive%\inetpub\logs\LogFiles (check your logging settings for the correct path)
Also I would suggest deleteing your website from IIS and recreating it (without modifiying any settings). Also try add the website as a virtual directory your your root site (which you say is working) and see if you can browse to the virtual directory.
Also ping www.xxxxxxxxxxxxx.com from your pc and ensure that you get a reply from the loal IP address (not the public one)
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26160862
Sorry, also check that you have no firewalls blocking port 80.
I cannot view the default website at 75.xx.xxx.xx (which www.xxxxxxxxxxxxxxxx.com resolves to)
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26170081
Any success?
0
 

Author Comment

by:CPSRI
ID: 26171278
I did check the bindings on my website - it looks like the screenshot attached. And I attached the screenshot of the application pool to give you a clear picture of it.
Reg. default document index.htm is the only document there.
And I attached the log file. And if add the website as a virtual directory it is working fine.
when i ping the website i am getting replies from the public one only that is 75.xx.xxx.xx but not from the local one that is 192.168.1.3.
and the ftp I created on the same server with same ip it is working fine.
Is it possible to post a screen shot for default web site? I just wanted to know how it should be.

0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26171338
if it works fine as a virtual directory try this:
go to Windows\System32\drivers\etc  and open the hosts file with notepad (on the server running iis)
add  the following line to the bottom of the file:
 127.0.0.1       www.xxxxxxxxxxxxxxx.com
 
save the file and try the website again
0
 

Author Comment

by:CPSRI
ID: 26171347
r u sure, is it exact 127.0.0.1?
0
 

Author Comment

by:CPSRI
ID: 26171352
or the IP address that is 75.xx.xxx.xx?
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26171363
yea, sure it should be 127.0.0.1 (this is because it is the local server which must run the web site)
0
 

Author Comment

by:CPSRI
ID: 26171470
ya..its working on the server only, when I browse it from my local computer same thing happening to it.
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26171495
ok, when you browse from your local computer you need to resolve www.xxxxxxxxxxxxxx.com to: 192.168.1.3
The best way to do this would be to add a "a record" dns entry in your dns server which points www.xxxxxxxxxxxxxx.com  to 192.168.1.3 (this way all the computers on the domain / making use of the dns server will be able to view the site locally) alternativly you can add:
192.168.1.3       www.xxxxxxxxxxt.com 
to your local hosts file ( as described above for the server)
- notice you will be using the internal ip this time, not the local ip
0
 

Author Comment

by:CPSRI
ID: 26172236
I added
192.168.1.3           www.xxxxxxxxxxxxx.com 
on the server it is working fine..but from my local computer it is same.
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26172353
Ok,
from your computer - if you ping www.xxxxxxxxxxxxxxxxxxx.com you should get : 192.168.1.3  is this correct ?
0
 

Author Comment

by:CPSRI
ID: 26172877
on the server i am getting 192.168.1.3, but from my local computer i am getting 75.xx.xxxx.xx
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26174049
On your local computer:

go to Windows\System32\drivers\etc  and open the hosts file with notepad
add  the following line to the bottom of the file:

 192.168.1.3       www.xxxxxxxxxxxxx.com
 
save the file and try the website again
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26174053
It should now work from your server and local computer.
0
 

Author Comment

by:CPSRI
ID: 26177251
I did the same but it is as it was
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26177781
So now if you ping http://www.rxxxxxxxxxxxxxxxxxxxxx.com/ from your local pc you get the internal address?
0
 

Author Comment

by:CPSRI
ID: 26187639
no, i am getting the same ip that is 75.xx.xxx.xx.
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26187704
Please attach your local host file here. You have not modified it properly
0
 

Author Comment

by:CPSRI
ID: 26187956
Here I attached the hosts file, thank you so much for baring with me :-)

hosts
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26188094
Hi CPSRI
The file looks correct, however there is a ".txt" at the end of the file. Please remove that.
The file should be saved as:
%system32 Directory%\drivers\etc\hosts
(this is usually: c:\Windows\System32\drivers\etc\hosts)
Please ensure there is no extention to the file.
0
 

Author Comment

by:CPSRI
ID: 26202069
zadeveloper, still its not working, but i am facing a problem, that is i mentioned the domain name here in my comments, when I search for it in google it is showing this link as search results, as this is my client's website, this is not good for me and for them too. So I want to be free from it first. How can I do that? I know only way is deleting the question. is there any other way?
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26202090
Yes - you can click the "requestion attention" button to ask a medator for help.
0
 

Author Comment

by:CPSRI
ID: 26280416
Thanks modus_operandi, thanks for changes -
In http:#a26171495, please obfuscate the url, and in http:#a26171352 and http:#a26187639 please obfuscate the IP.
From now on Ill take care of the data which I am giving here.
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26281156
Hi CPSRI
After all of that ... is the solution working ? If not make sure that when you are pinging the website address from you box that you get back the internal address.
0
 

Author Comment

by:CPSRI
ID: 26296513
no zadeveloper, its not getting to the internal address when i ping the website from my local computer.
0
 

Author Comment

by:CPSRI
ID: 26301074
zadeveloper, i think i am missing some thing here http:#a26171495, could you please explain it clearly?
0
 
LVL 13

Accepted Solution

by:
zadeveloper earned 1000 total points
ID: 26301283
ok,
First off lets confirm a few things
1. From the sever you can now vrowse to the webitesite address and the site displays correctly.
2. If you ping the address: www.domain.com from the server you get the internal address back or 127.0.0.1
3. When placed in the root website as a virtual directory you can browse and view the site
Assuming this is still the case we can confirm that everything on the server and you IIS configuration is 100% correct. (please confirm points 1, 2, and 3 for me)
Now. when you browse to www.domain.com from your local computer you cannot view the site. The following happens when you browse to a web site (any site) - and Im going to try explain using a real life example (so bare with me :) ).
1. The first this your computer needs to do is resolve the www.domain.com to an ip address (although we work with friendly names the computers do not). This is likened unto you going to an interview. The people from the company tell you go to their office. Like the computer asking for an IP address you also will ask for a physical address.
However when windows asks for an address the first thing it does is to check if you already have it written down some where. So assuming you go the interview request on email the first thing you will do is look to see if the address is on the email ssomewhere. If it is you will not bother asking the person over the phone. In the same way windows first checks its "hosts" file. which is usually located in:
c:\Windows\System32\drivers\etc\hosts
(please note that there is not file extention ... this is very important)
If windows find the address in the hosts file it also will not bother asking anyone else for the address, it will simply go there.
If the address name is not found in the hosts file windows will then ask the authoritive DNS (Domain Name Server) for the address. Like wise if there were no address on the email, you to would phone the office and ask for the address.
Now more than likly when you do this you will be given a street address (or in the computers case a public IP address .. which is accesable from the entire web.)
But what happens when you are inside the building and it has 30 floors each having 200 offices. this leaves you with 6000 offices to try and visit. (not very efficient ... and in the case of the computer .. it will not even try)
So the question is how then from internal (inside the building) do we get the correct office. There are 2 options. 1 put up a sign in the front lobby ... this would be to ask the network administrator to add a local DNS record for the server when querying from the LAN/ WAN.
The other option you have is to ask someone and write it down.  where do we write it ? - in the hosts file ... Now you have the address (www.domain.com) and you have the floor/ office (192.168.1.3).
Option 1 (adding the record to the internal dns servers is not possible) so we have to do option 2. If option 2 is done correctly then windows will ping / browse to the correct location.
So what you need to do it:
Go to: c:\Windows\System32\drivers\etc and check first of all that the hosts file has no extention - editing and saving from notepad may have created a extention - in which case you would have 2 host files there.
(Ensure that windows is not hiding the extention ... by going to control panel->Folder Option then using the view tab -> find the advanced setting called: Hide extentions for known file types and make sure it is not ticked)
Open the hosts file in notepad and add the record
192.168.1.3    www.domain.com
please ensure that there is only 1 record here for that file.
 
P.S the hosts file you have attached here has an extention of .txt - this could be the problem.
 
Hope this helps :)
0
 
LVL 13

Expert Comment

by:zadeveloper
ID: 26347864
any update on this one?
0
 

Author Comment

by:CPSRI
ID: 26462869
i need some more time to go through it, that to you posted a long comment, but not a problem. and thanks a lot.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today I came across an interesting issue that had me pulling my hair out.  I was troubleshooting a new internal web site which uses integrated security instead of anonymous.  When browsing the site from my laptop, I was able to access it with no iss…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…
Suggested Courses
Course of the Month18 days, 19 hours left to enroll

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question