[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1126
  • Last Modified:

ISA 2000 Specified service does not exist as an installed service

I had a virus on this server, now ISA server control will not start.  It is ISA 2000, SBS 2000, when i try to start the service it says "Could not start the Microsoft ISA Server Control service on Local Computer.  Error 2147943460: The specified service does not exist as an installed service."

I tried reinstalling ISA, i checked the registry key against a similar server.  Everything looks right, but it will not start and users can't access the internet.  Any ideas?
0
computrex
Asked:
computrex
1 Solution
 
farazhkhanCommented:
Hi,

First of all make sure that you have got all latest patches/service packs installed from Microsoft update site, since there were some issues like you are facing have been reported before!

Now once you update the updates then restart the server and if you again face the same issue let me know what errors been reported under event viewer.

Regards,
Faraz H. Khan
0
 
computrexAuthor Commented:
I was able to fix the problem.  I found that there was a missing registry key under HKLM\System\CurrentControlSet\Services called SharedAccess.  I exported it from a similar 2000 server and imported it onto this one, and rebooted.  Everything started up normally then.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now