Server 2003 X64 Permissions

I just started having an issue with one folder on my 2003R2 X64 file server. I can not access one particular folder - just keeps saying access denied. I am logged into the file server as the domain admin. When I right click on the folder in question and go to properties, I only see the the general and customize tabs. I have gone into the parent folder (main project folder) and the normal tabs are there. I have clicked on the security tab and tried to take ownership, but when I select the check box to replace ownership on all subcontainer objects, I am presented with the access denied message. Additionally, I can not delete the folder which is no surprise as I apparently have no rights and can not seem to get the rights to said subfolder.  Any help is greatly appreciated
manocardsAsked:
Who is Participating?
 
gtworekCommented:
CI(F) means administrators should have access.... but chkdsk is always good idea.

Try to run it in readonly mode (without /F) - just for checking. Of course if your server is busy it may affect performance.

If you have a lot of files (several millions and total size is not important) on volume - it's faster to boot your server from Windows 2008R2 DVD and do chkdsk from installer command line. Chkdsk changed slightly in 2008R2 and can be 20-30 times faster if you have a lot of files and huge amount of RAM.
0
 
gtworekCommented:
try to run "psexec -s cmd.exe" and look for folder properties from commandline.
psexec is downloadable from http://technet.microsoft.com/en-us/sysinternals/bb897553.aspx
for folder rigths management use cacls - http://technet.microsoft.com/en-us/library/bb490872.aspx
0
 
manocardsAuthor Commented:
Downloaded and ran psexec as you suggest, but not sure I really need to as I am sitting in front of the server with console access. However, I ran psexec as you suggest so that we were in the system account. From the console, I am still unable to change to the directory in question, and cacls did not list the folder rights. Perhaps I did not use the correct syntax. Could you please follow up with the cacls switches that I should run with the command. I am thinking it should be something like d:>cacls folder in question /g Administrator:f

This would give the administrator Full permission, but I am not sure how to list the existing permissions with cacls. Thanks in advance for your help.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
gtworekCommented:
Start with listing permissions.

calcs.exe "folder in question"

Maybe this shows us correct way. use quotes if your folder has spaces in his name.
If you can grant rights, give ACLs for Administrators (not only administrator) and system.

you  can also try with "chkdsk X:" - without /F parameter it will not change anything. Maybe your error is related to corrupt data?
0
 
manocardsAuthor Commented:
gtworek - Thanks for the quick reply. Adding the double quotes did the trick. The Administrators group lists the following: (OI )(CI)F

Looks like the administrators group has full control (which it should). I am thinking that you are correct in suggesting a chkdsk, I just wanted to see if there were any other possible ways to fix is this as this is the main dc for the office and I am not sure I want to run this during the day while activity is high. I will try a chkdsk tonight and post back results. Thanks again for the help. Just noticed that the volume is fairly heavily fragmented. I see a chkdsk and defrag in the near future.
0
 
manocardsAuthor Commented:
CHKDSK was the key here. Once I ran it, I saw there was corrupt info. Then ran chkdsk /f /r - it took a while, but was able to repair the volume and I could then delete the folder.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.