• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 486
  • Last Modified:

VLAN doesnt work after replacing core switch and router

We hired a consultant to replace PIX (default gateway) with ASA and 3650 switch (core) with 3570. The VLAN 1/private network works fine. However, all VLANs such as vlan 100, 200, and 300 and 400 dont work. Then the consultant tried many hours to make another switches to work. He said he didnt make any changed on the working switch. So he suggested us to reboot all switches.  We have tried to reboot the other switches, but that doesnt fix the problem. The consultant is out of ideas.
For a test, I configure a port in working switch to use vlan 300, my laptop get good IP from the DHCP server that is located in the VLAN 200. If I use the same port configuration in the problematic switch, my laptop doesnt receive IP from the DHCP server. From the problematic switch, I can ping the DHCP server. The show vlan displays all VLAN in the problematic switch. What could be the problem?
0
blin2000
Asked:
blin2000
  • 6
  • 4
  • 2
1 Solution
 
rochey2009Commented:
Hi,

Does the PC communicate with other vlans when you manually define an IP address on it?
0
 
rochey2009Commented:
Also, please post

show interface trunk

on the switch that doesn't work.
0
 
blin2000Author Commented:
Yes, good question. I have tried to assign teh static IP addres, DG, but I can't ping the DHCP server or DG.

Here are the result of show int trunk

PSC_3560_3#sh int trunk

Port        Mode         Encapsulation  Status        Native vlan
Gi0/2       on           802.1q         trunking      1
Gi0/6       on           802.1q         trunking      1
Gi0/16      on           802.1q         trunking      1
Gi0/48      on           802.1q         trunking      1
Gi0/51      on           802.1q         trunking      1
Gi0/52      on           802.1q         trunking      1
Po1         on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gi0/2       1-4094
Gi0/6       1-4094
Gi0/16      1-4094
Gi0/48      1-4094
Gi0/51      1-4094
Gi0/52      1-4094
Po1         1-4094

Port        Vlans allowed and active in management domain
Gi0/2       1,4,100,200,254-256,300,400,500,600,700,800,900
Gi0/6       1,4,100,200,254-256,300,400,500,600,700,800,900
Gi0/16      1,4,100,200,254-256,300,400,500,600,700,800,900
Gi0/48      1,4,100,200,254-256,300,400,500,600,700,800,900

Port        Vlans allowed and active in management domain
Gi0/51      1,4,100,200,254-256,300,400,500,600,700,800,900
Gi0/52      1,4,100,200,254-256,300,400,500,600,700,800,900
Po1         1,4,100,200,254-256,300,400,500,600,700,800,900

Port        Vlans in spanning tree forwarding state and not pruned
Gi0/2       1,4,100,200,254-256,300,400,500,600,700,800,900
Gi0/6       1,4,100,200,254-256,300,400,500,600,700,800,900
Gi0/16      1,4,100,200,254-256,300,400,500,600,700,800,900
Gi0/48      1,4,100,200,254-256,300,400,500,600,700,800,900
Gi0/51      none
Gi0/52      1,4,100,200,254-256,300,400,500,600,700,800,900
Po1         1,900
PSC_3560_3#
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Don JohnstonInstructorCommented:
>However, all VLANs such as vlan 100, 200, and 300 and 400 dont work

Please define "don't work".

Are there devices on VLAN 100 that can't communicate with other VLAN 100 devices?

Or is the problem communicating with devices on different VLANs?

Is the problem isolated to one switch or does the problem extend beyond the 3750?

0
 
blin2000Author Commented:
Also, if I setup two computers in the VLAN 200 or 300, they can ping each other, but not DHCP server and default gateway.

More information. The default gateway is core switch and ip is 10.0.0.2 (used to be PIX IP). The Core switch points to ASA that IP is 10.0.20.1 (used to be the core switch that has been removed).

Thanks.
0
 
Don JohnstonInstructorCommented:
Please post a diagram of your topology and the running-config of the switch.
0
 
blin2000Author Commented:
Attached is problematic switch running-config. We have over 30 switches. We haven't got a chance to update the diagram since the upgrade. I will post it when I have it.

Also, the VLAN 200/300 clients work if I assign static IP, DG and DNS. It can ping every thing including Internet DHCP. I just need to be patient.
ip62.log
0
 
blin2000Author Commented:
OK, let's keep simple and focus on two switches only.

Core 3750 switch 10.0.0.2
|                                      |
non-work switch        work switch
10.0.20.12                  10.0.20.13
int G1/0/13                  int G3/0/11

Both ports are configured as shown below.
 switchport access vlan 300
 switchport mode access
 no ip address
 no mdix auto
 spanning-tree portfast
 spanning-tree bpdufilter enable
 spanning-tree bpduguard enable

10.0.20.13 port int G3/0/11works and 10.0.20.12 port int G1/0/13 doesn't. I also attached both running-config files.


workingswitch.log
non-workswitch.log
0
 
rochey2009Commented:
Hi,

Please can you post

show spanning-tree root

on the switch that isn't working.
0
 
blin2000Author Commented:

ADM_TELE_BASE_3750#show spanning-tree root

                                        Root Hello Max Fwd
Vlan                   Root ID          Cost  Time Age Dly  Root Port
---------------- -------------------- ------ ----- --- ---  ----------------
VLAN0001          8193 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

VLAN0004          8196 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

VLAN0100          8292 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

VLAN0200          8392 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

VLAN0254          8446 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

VLAN0255          8447 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

VLAN0256          8448 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

VLAN0300          8492 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

VLAN0400         33168 0013.1935.bf00      0    2   20  15

VLAN0500         33268 0013.1935.bf00      0    2   20  15


                                        Root Hello Max Fwd
Vlan                   Root ID          Cost  Time Age Dly  Root Port
---------------- -------------------- ------ ----- --- ---  ----------------
VLAN0600          8792 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

VLAN0700         33468 0013.1935.bf00      0    2   20  15

VLAN0800          8992 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

VLAN0900          9092 f4ac.c1e9.9180      4    2   20  15  Gi1/0/25

ADM_TELE_BASE_3750#
0
 
rochey2009Commented:
Can you do the same on the 3560 this isn't working?

Thanks.
0
 
blin2000Author Commented:
I am not sure how I fixed the problem, but I think rebooting all switches makes it work.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 6
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now