Messages getting stuck in outbound queue on my SBS 2003 server

Hello Experts,

I have been experiencing an issue on my SBS 2003 server of messages getting stuck in the queues.  When users send email to someone@hotmail.com, someone@msn.com, or someone@ntdcc.com, the messages get stuck in the queue.  If they send email to anyone else, it is delivered just fine.  If I reboot the SBS server, these queues are cleared out and the messages in them are delivered without any issues.

Any ideas on what may be causing this?

Regards and Happy New Year,
Nick
LVL 1
ndalmolin_13Asked:
Who is Participating?
 
Glen KnightCommented:
More often than not this is caused by antivirus/spam software please remove any you have on the server, reboot and then see if it goes away.

Disabling te software won't help it must be removed
0
 
overdrive79Commented:
The recipient domains that you are sending to are likely blocking your messages.  You will either need to set up an SMTP relay or remove your IP from any blacklists, provided that you are using a static IP that is classified as a "business" account, otherwise removing the IP may prove to be near impossible.  If it is in fact a business IP, you may also want to make sure your IP has a reverse DNS entry.  If you need help with any of this please let me know.

J
0
 
Glen KnightCommented:
If uninstalling the virus/spam software doesn't help and you send out via DNS rather than smarthost have a look at this FAQ from EE member alanhardisty: http://www.it-eye.co.uk/faqs/readQuestion.php?qid=2
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
ndalmolin_13Author Commented:
If this is anti-virus related, what can I do?  I can't have my server without AV?
0
 
Glen KnightCommented:
Just uninstall it temporarily to see if it fixes it.

If it does then re-install the AV software this normally fixes it.
0
 
ndalmolin_13Author Commented:
I will have to do the uninstall and reinstall during off hours.  I will keep you posted.  Thanks for your help.
0
 
overdrive79Commented:
AV would stop mail going to all domains, the likely cuplprit is your need to smarthost/relay the mail.  keep us posted!
0
 
Glen KnightCommented:
The fact that a reboot resolves it suggests it's something in the server causing the problem.

0
 
Glen KnightCommented:
Also did you check the link I posted?
0
 
Glen KnightCommented:
There should also be no need to use a smarthost/relay if the server is configured properly.

The domains you mention do check for a SPF record but they would still check for the SPF even if the server gets rebooted.
0
 
ndalmolin_13Author Commented:
I checked the link you provided and we look good.  I used spamhaus.org to check for blacklistings as well and we are not listed.

We have installed a new AV recently, so I'm suspecting that has something to do with the issue.

Nick
0
 
Glen KnightCommented:
More than likely!

99.9% of the time I see this problem it's caused by virus/spam software.
0
 
Rob WilliamsCommented:
Might you have a dynamic IP?
Recently ran into issues sending to hotmail, and AOL who will not accept e-mail from a site that is part of a dynamic IP range. The site I was dealing with had a static IP, but was on a list that said it was dynamic. Had to resort to smarthost.
Apparently a few companies use the same block lists. AOL has some test tools that may be of some help, but not the Dynamic IP issue.
http://postmaster.aol.com/trouble/

However, if this were the case it is very odd the messages would be delivered upon reboot. That sounds more like some form of malware as suggested by others.
0
 
ndalmolin_13Author Commented:
Hello All,
I uninstalled the AV software today and everything worked as expected.  When I reinstalled the AV software, I ran into the same issue.  I'm using Avast SBS.  Any ideas.

Thanks for your help.
Nick
0
 
Glen KnightCommented:
Are you running the latest Avast software?
If not make sure you are.  Also try re-applying SP2 for Exchange 2003 after installing Avast.

Is mail getting stuck in the queu and saying something about maximum concurrent connections?
0
 
Rob WilliamsCommented:
You can increase the maximum number of concurrent connections in Exchange System Manager under servers | protocols | SMTP | default SMTP virtual server | properties.
This is not necessary most of the time though I had to do so on a client using a smart host (SMTP relay) with a slower connection. It can also be due to your server being affected by malware or used as an open relay.
0
 
Glen KnightCommented:
There is a setting in Avast that causes this as well, it needs to be set to 0 in the avast4.ini file.

Find the following key:
[MailScanner]
MaxConnections=20

and change the 20 to 0

it's quite a common problem with Avast on an exchange server.
0
 
Rob WilliamsCommented:
Sounds like the connections in Avast would more likely be the problem then as your problem only exists with Avast installed.
0
 
overdrive79Commented:
Make sure that Avast is not scanning the C:\Program Files\Exchsrvr folder and all subfolders.  It could essentially be holding itself up if it is scanning at the file level and the queue level at the same time.
0
 
ndalmolin_13Author Commented:
I'm running the latest Avast.  I have found the MailScanner key, but there is no MaxConnections setting.
0
 
Glen KnightCommented:
Check in the user interface under the options tree you should be able to find it there.
0
 
Glen KnightCommented:
0
 
ndalmolin_13Author Commented:
Avast support never could figure out what was going on.  We had to uninstall the AV and install the AV we used to use.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.