stsadm.exe not found with WSS 3.0 installation

Posted on 2009-12-30
Last Modified: 2012-05-08
I have installed sql 2008, WSS 3.0, and Search Server Express on a new windows installation of Server 2008 x64.
I have backed up a site with stsadm on the old server, and then when trying to restore it on the new server, ran into this issue.   " 'stsadm' is not recognized as an internal or external command, operable program or batch file." stsadm.exe is nowhere to be found on the system.
I've not found alot online to assist in the installation of this util. I've re-installed wss, and I've tried to just downloaded stsadm.exe and place it in the : E:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\bin  I've added the environment variable, and then tried running it, but get a "Microsoft Windows" error dialog box " stsadm.exe has stopped working  Windows can check for a solution to the problem" with the options to check online and close, or just close.  In the problem details I get this:  
  Problem Event Name:      APPCRASH
  Application Name:      STSADM.EXE
  Application Version:      11.0.5510.0
  Application Timestamp:      3f0fde60
  Fault Module Name:      KERNEL32.dll
  Fault Module Version:      6.0.6002.18005
  Fault Module Timestamp:      49e038c0
  Exception Code:      e0434f4d
  Exception Offset:      0001e124
  OS Version:      6.0.6002.
  Locale ID:      1033

Is there a solution to installing stsadm properly? Since it doesn't seem wss 3.0 is installing it?
Is this a compatibility issue with server 2008 x64? I'm at a loss, and need to get this project moving.
Question by:m-h
    LVL 42

    Accepted Solution

    if stsadm is not present in your new wss 3.0 installation, something is wrong.

    it should be in Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN

    is this a standalone installation?  if not, please explain how you did your install.

    if this is a new wss 3.0 installation and it's not some kind of unique install scenario, it may be best to just uninstall and reinstall the binaries.  because if stsadm is missing, who knows what else is wrong.
    LVL 19

    Expert Comment

    I had the same problem on one of my dev machines. In my case STSADM just stopped working one day. I just copied the stsadm from another SharePoint install to my dev machine and it did the trick. If it is a new production environment, I would follow up on Zephyr's advise and just reinstall the whole thing. As you are on a x64 environment make sure that you are also installing the x64 version of SharePoint 2007 :p

    Author Comment

    Ok, did the reinstall, thanks Zephyr. Now I'm getting an access denied error when trying to restore....  Completely different problem...  But this Question is resolved.

    Expert Comment

    I had the same problem.
    Solution :
    - Using Explorer, do not search "STSADM.EXE" at : C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\BIN.

    - The file is located at :
    C:\Programmes\Common Files\Microsoft Shared\Web Server Extensions\12\BIN.

    C:\Programs\Common Files\Microsoft Shared\Web Server Extensions\12\BIN.

    - Register the Path in GAC :
    Using cmd windows to open DOS, execute :
    Set Path=Path;C:\Programs\Common Files\Microsoft Shared\Web Server Extensions\12\BIN.
    Set Path=Path;C:\Programmes\Common Files\Microsoft Shared\Web Server Extensions\12\BIN.

    Now you can use STSADM.EXE.

    In DOS mode, you can also go to the path, using :
    CD "C:\Programs\Common Files\Microsoft Shared\Web Server Extensions\12\BIN"
    CD "C:\Programmes\Common Files\Microsoft Shared\Web Server Extensions\12\BIN"

    Now you can use STSADM.EXE.

    Featured Post

    Why You Should Analyze Threat Actor TTPs

    After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

    Join & Write a Comment

    Summary In SharePoint 2010 it is easy to create custom color themes to jazz up a site. Theme colors can also be created in PowerPoint 2010 with a few clicks. But how do the chosen colors actually look in the SharePoint site? The attached PowerPoint…
    Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
    This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
    This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now