• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6450
  • Last Modified:

Visio 2007: Can't access UML diagram properties

I am using Visio 2007 and Vista Home Premium SP1.
I open "UML Model Diagram" template, drag the class diagram icon to my page. I want to add attributes and behaviors to my class diagram, but can't do so. If I double click on the class diagram box, I can enter a class name, but I can't add anything else.

I recall that in the past (a year ago with possibly an older OS?) I was able to enter attributes and behaviors by right clicking and choosing properties. Now, none of my right click menu options do anything. I am able to use the right-click menu for other templates - just not the UML diagram template.

I've spent 2 hours looking for help on the Internet, but nothing works. I followed a suggestion to start with a UML "package," but I can't do anything with the package after I drag it onto my page.

I have uninstalled Visio and reinstalled and have the same problem.
0
jdean4
Asked:
jdean4
  • 6
  • 4
  • 2
  • +1
1 Solution
 
marklorenzCommented:
You should create a new UML Model diagram.  This will open the palettes for UML diagrams.  Just use as you normally would (drag and drop onto drawing page).  Double click a class to add operations and attributes.   The key is to start w/UML Model from the start.

HTH, Mark
0
 
jdean4Author Commented:
Mark,
Thanks for the feedback. I think you are suggesting what I've already been doing. I start by opening Visio, then do File/New/Software and Database/UML Model Diagram (U.S. units). then I successfully drag icons from the left-side UML Static Structure shape group (or any other UML shape group). The shape picture appears on the page. I can do some things to it (like enter a class name for a class diagram), but can't enter anything else. When a click any of the right-click menu options (like properties), nothing happens. When I double click on the shape picture (on the page), nothing happens. Like I said, I can do things normally (like open the properties dialog box) for non-UML shapes. I used my Visio 2007 installation CD and ran the repair option, and that didn't help. I then used it to remove and reinstall. None of that changed anything.

Please help,
John
0
 
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperCommented:
The software engineering features are only in Visio 2007 Professional. Consequently, it almost sounds like you have Visio 2007 Standard and not Professional... although, in theory you shouldn't even have the UML template if you don't have PRO. (Note: there's a feature comparison on STD vs. PRO here: http://office.microsoft.com/en-us/visio/FX101757911033.aspxhttp://office.microsoft.com/en-us/visio/FX101757911033.aspx)

Microsoft doesn't make it easy to tell which edition you have (Help/About doesn't tell you). The easiest way to check is to open any drawing then click on the Data menu -- if most of the entries are grayed out (especially Link Data to Shapes and Display Data on Shapes), you probably have STD not PRO.

If you do in fact have PRO, I would suggest reinstalling or repairing the Visio installation. The UML templates use extra code outside the Visio.exe file and it may not have been installed properly or may have been removed somewhere along the way.

Scott
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
jdean4Author Commented:
Scott,
Thanks for the feedback. As you suggested, I clicked my Data menu. The Link Data to Shapes and Display Data on Shapes options are not grayed out. When I click them, they do appear to work. As I said in my prior post, "I already used my Visio 2007 installation CD and ran the repair option, and that didn't help. I then used it to remove and reinstall. None of that changed anything.I have already used my installation CD to run the repair."

Does anyone have any other suggestions?

Thanks,
John
0
 
marklorenzCommented:
Does this answer your question?

In Visio 2007, Microsoft has disables styles, unless you run a developer mode. How to enable developer mode, please read a help item in Visio 2007 "What happened to styles?"

 http://softwarestencils.com/tips/index.html
0
 
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperCommented:
John,

Sorry -- I missed your comment in your reply to Mark.about having already reinstalled.

If you open the shapesheet for a class object, do you see the entries I've highlighted below? These are the entries that launch the UML add-on for specific commands -- I'm trying to determine whether the problem is a bad shape or missing code.

Scott

UML-screen-shot.jpg
0
 
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperCommented:
Whoops -- posted the one without highlights. See below.

uml-screen-shot.jpg
0
 
jdean4Author Commented:
Scott,
I very much appreciate your attentiveness! Sorry it took me so long to get back to you. I was on a phone call for several hours. I don't use Visio all that often, so it takes me a while to do things. After 15 minutes, I figured out how to open the Shapesheet, and my values match your highlighted values. If you'd like to verify, see the attached shapesheet for a UML class diagram shape.

What's next?

John


shapesheetForAUmlClass.jpg
0
 
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperCommented:
Happy New Year, John. Back at this after a couple of days off...

Let's check a couple of relatively obscure Visio settings:
  1. Visio add-ins: let's make sure that operation of add-ins isn't restricted in your copy of Visio for some reason. Select Tools/Trust Center from the Visio main menu, then click Add-ins in the left navigation pane. There should *not* be a checkmark next to "Disable..." as shown in the first image below. If there happens to be one there, remove it, then stop and restart Visio.
  2. Automation: Select Tools/Options from the Visio main menu, then click the Advanced tab. Ensure that there *is* a checkmark next to Enable Automation events. Refer to second image below.
Let me know if either of these solves the problem.



trust-center.jpg
automation-events.jpg
0
 
jdean4Author Commented:
Scott,
Happy New Year to you, too!
You really do know your Visio! I found that my Disable Add-ins box was indeed checked. I've cleared it and now I can open up UML shape properties, etc.

1. Any idea how/why that box was checked even after I re-installed?

2. On the Options window shown above, I noticed that my Run in Developer Mode box is unchecked and it's checked for you. The Visio help for that box says "Enables certain user interface functions for the development environment. If this option is selected, the Show ShapeSheet command is added to a shape's shortcut (right-click) menu." Do you recommend that I check it?

Thanks,
John
0
 
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperCommented:
I don't have any idea why that option was set to disable... the Visio default is to allow add-ins.

You don't need to run Visio in developer mode for normal operation. However, it does make a few things more convenient, for example, it adds Show Shapesheet to the right-click menu for any shape -- something that might have saved you a few minutes the other day! Rather than list other reasons for turning developer mode on, let me refer you to the best Visio website on the planet -- no, it's not mine :-)> -- it's written by fellow Visio MVP, Chris Roth:
http://www.visguy.com/2008/08/04/top-9-reasons-for-turning-on-developer-mode/http://www.visguy.com/2008/08/04/top-9-reasons-for-turning-on-developer-mode/

Scott
0
 
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperCommented:
Um, the URL above appears to have been pasted twice, although it still works correctly...
0
 
nivinismCommented:
thaaaaanks alot guyz that was my problem too!!!
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now