• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2920
  • Last Modified:

EchoLife HG520b router is blocking remote desktop connection - How can I allow it?

EchoLife HG520b router is blocking remote desktop connection - How can I allow it? I know it is definately the router since when I connect up my old sky router I am instantly able to remote desktop onto all pc's in network.

Some of the advice online points to port forwarding but I have tried following the intructions but with no success as yet. At least I know it is definately my router. I would be grateful for a network specialists help on this matter.

Thanks..
0
jazz__man
Asked:
jazz__man
  • 9
  • 8
1 Solution
 
Rick_O_ShayCommented:
I don't know that model. Did you take a look at the port forwarding page for this router?
http://www.portforward.com/english/routers/port_forwarding/Huawei/EchoLife-HG520b/PalTalk.htm
0
 
jazz__manAuthor Commented:
Yes, I have already been down that road, it dosent work. But thanks anyway.
0
 
Rick_O_ShayCommented:
I assume you used port 3389 and not the ones in the example.
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
jazz__manAuthor Commented:
Yes thats correct. I used Port 3389. I read somewhere that to have port forwarding work you must use static ip addresses for your local network ...does this help? Mine is set up just with the router default settings at the moment which uses DHCP to automatically assign addresses. Hope this helps somewhat.

Didn't think this was going to be so difficult but obviously its not that straight forward.

cheers
0
 
Rick_O_ShayCommented:
Can you set up the DHCP services to give the PC you are trying to get to the same address all the time? Then point the forwarding to that address.
0
 
jazz__manAuthor Commented:
Hi, I tried setting up DHCP but because I dont really know what I am doing I lost both internet and LAN connections and ended up having to reset the router back to factory defaults.

cheers
0
 
Rick_O_ShayCommented:
So are the PC's now getting IP automatically from the router or are they manually coded?
0
 
jazz__manAuthor Commented:
The IP addresses are dynamically being assigned from the router, as I reverted back to DHCP after I lost all connectivity.

What I noticed was when I typed in the IP address I temporarily got access but then after rebooting the pc's I lost it again. Now even if I type in the IP address I still cannot get access. I have tried doing this with all firewalls deactivated but no success. When I change over to my old sky router everything works even with DHCP enabled and my pc firewalls enabled which makes me think the problem can't be that difficult, if only I knew what section of the router config to edit.

In the router there are settings for LAN, WAN NAT etc but cos I havent studied networking I don't know what section applies in my situation.

0
 
Rick_O_ShayCommented:
What is the model of the old router? I'll take a look at both and see if I can find somehting that may not be set by default on the EchoLife.

Right now all the LAN addresses are being assigned by DHCP from the router and everything works out to the internet etc. but RDP inbound is the only issue correct?

When you use the other router what addresses do you use when you RDP from outside? That will help me determine how NAT is set up on it. You don't have to give me the actual ones used for security purposes just a representation of what you are doing.
0
 
jazz__manAuthor Commented:
"Right now all the LAN addresses are being assigned by DHCP from the router and everything works out to the internet etc. but RDP inbound is the only issue correct?"  

Yes, this is correct.

Just so that we are clear, I only need RD to work within my home LAN, I dont need to access via the internet etc.

Unfortunately I am not at home at the moment so I don't have the sky router at hand, however I will post the model later on. I can tell you its a white Netgear router which is about 3 years old. Sky only do 2 routers, a white one and a gray/black one so the exact one that sky do will probably be easy enough to track down.

So what do I do when accessing pc's via RD?

I open RD and type in the IP Address that I know is currently assigned to the remote computer on my local network.  However with the sky router it can handle you just typing in the name of a computer or the IP address.

Please note, after rebooting both client and remote pc's, neither 'IP address' or 'comp name' works with the echolife router.

Let me know if you need anymore info.

Thanks

0
 
Rick_O_ShayCommented:
I am glad you clarified that. So you are just trying to RDP inside to inside. On most routers that requires no work on your part. Just knowing the name or address of the PC you are trying to get to.
Can you confirm with the ipconfig command that the PC's are on the addresses you expect and in the same subnet?
0
 
jazz__manAuthor Commented:
Yes, using ipconfig command works and pc's are on the same subnet. The ip's are all being set by the same router and the router is just using the factory default settings.

Thanks

0
 
Rick_O_ShayCommented:
I looked back through this post and I don't see if you can even ping PC 1 to PC 2 and vice versa. Can each PC ping its default gateway? Can PC1 ping PC 2?

A couple things to try:
Go into Advanced/port mapping and set active to yes and check all 4 ethernet ports.
In advanced/ACL try disabling that.
In Tool/system log check what is happening when you are testing.
0
 
jazz__manAuthor Commented:
Hi

It would appear that I can ping the pc's.

Thanks
0
 
jazz__manAuthor Commented:
Hi

I have moved on from talktalk and signed up with another provider who are sending me a brand new router, so I am hoping that this will automatically fix the problem.

Since you have contributed substantially to this question I will give you the points.

Thanks

Paul
0
 
jazz__manAuthor Commented:
Thanks
0
 
Rick_O_ShayCommented:
Thanks Paul. Good Luck.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 9
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now