• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1784
  • Last Modified:

Cisco Catalyst 6500 GVRP

Trying to enable GVRP on a Cisco 6500.  Cisco docs say just type "set gvrp enable".  "set" is not a command available.  Also, it says to run this command from "Console> (enable)" mode.  As far as I can tell this is not the same as "Router#" mode.  Any help would be appreciated.   Here are the module and software versions:

Router#show module
Mod Ports Card Type                              Model              Serial No.
--- ----- -------------------------------------- ------------------ -----------
  1    2  Catalyst 6000 supervisor 2 (Active)    WS-X6K-S2U-MSFC2   SAL0711A81A
  2   48  48 port 10/100/1000mb EtherModule      WS-X6148-GE-TX     SAD082306NC
  3   48  48 port 10/100/1000mb EtherModule      WS-X6148-GE-TX     SAD07490884
  4   48  48 port 10/100 mb RJ45                 WS-X6348-RJ-45     SAL05084QTX
  5   48  48 port 10/100 mb RJ45                 WS-X6348-RJ-45     SAL0545E5JQ
  6   48  48 port 10/100 mb RJ45                 WS-X6348-RJ-45     SAL0545E3TN
  7   48  48 port 10/100 mb RJ45                 WS-X6348-RJ-45     SAL06131VTA
  8   48  48 port 10/100 mb RJ45                 WS-X6348-RJ-45     SAL0546E9RT
  9   48  48 port 10/100 mb RJ45                 WS-X6348-RJ-45     SAL0546E9QB

Mod MAC addresses                       Hw    Fw           Sw           Status
--- ---------------------------------- ------ ------------ ------------ -------
  1  0009.1245.c2a8 to 0009.1245.c2a9   4.2   7.1(1)       12.2(18)SXF1 Ok
  2  0011.21ed.1b10 to 0011.21ed.1b3f   6.1   7.2(1)       8.5(0.46)RFW Ok
  3  000e.8361.b400 to 000e.8361.b42f   5.0   7.2(1)       8.5(0.46)RFW Ok
  4  0004.de85.1240 to 0004.de85.126f   2.0   5.4(2)       8.5(0.46)RFW Ok
  5  0005.7464.7b20 to 0005.7464.7b4f   5.0   5.4(2)       8.5(0.46)RFW Ok
  6  0005.7464.6f60 to 0005.7464.6f8f   5.0   5.4(2)       8.5(0.46)RFW Ok
  7  0008.a4f7.df9c to 0008.a4f7.dfcb   6.1   5.4(2)       8.5(0.46)RFW Ok
  8  0005.7408.9af0 to 0005.7408.9b1f   5.0   5.4(2)       8.5(0.46)RFW Ok
  9  0005.7408.8400 to 0005.7408.842f   5.0   5.4(2)       8.5(0.46)RFW Ok

Mod  Sub-Module                  Model              Serial       Hw     Status
---- --------------------------- ------------------ ----------- ------- -------
  1  Policy Feature Card 2       WS-F6K-PFC2        SAL0711AADL  3.3    Ok
  1  Cat6k MSFC 2 daughterboard  WS-F6K-MSFC2       SAL071004PA  2.5    Ok
  7  Inline Power Module         WS-F6K-PWR                      1.0    Ok

Mod  Online Diag Status
---- -------------------
  1  Pass
  2  Pass
  3  Pass
  4  Pass
  5  Pass
  6  Pass
  7  Pass
  8  Pass
  9  Pass
Router#

Router#show version
Cisco Internetwork Operating System Software
IOS (tm) s222_rp Software (s222_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF16
, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by cisco Systems, Inc.
Compiled Tue 03-Mar-09 14:13 by kellythw
Image text-base: 0x40101040, data-base: 0x42C76190

ROM: System Bootstrap, Version 12.1(11r)E1, RELEASE SOFTWARE (fc1)
BOOTLDR: s222_rp Software (s222_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF16
, RELEASE SOFTWARE (fc2)

Router uptime is 13 weeks, 5 hours, 26 minutes
Time since Router switched to active is 13 weeks, 5 hours, 25 minutes
System returned to ROM by  power cycle (SP by power-on)
System image file is "disk0:s222-adventerprisek9_wan-mz.122-18.SXF16.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C6509 (R7000) processor (revision 2.0) with 227328K/34816K bytes of mem
ory.
Processor board ID SCA044001JV
R7000 CPU at 300Mhz, Implementation 0x27, Rev 3.3, 256KB L2, 1024KB L3 Cache
Last reset from power-on
SuperLAT software (copyright 1990 by Meridian Technology Corp).
X.25 software, Version 3.0.0.
Bridging software.
TN3270 Emulation software.
11 Virtual Ethernet/IEEE 802.3 interfaces
288 FastEthernet/IEEE 802.3 interfaces
98 Gigabit Ethernet/IEEE 802.3 interfaces
381K bytes of non-volatile configuration memory.

32768K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102

Router#
0
hbrumfield
Asked:
hbrumfield
  • 6
  • 3
  • 2
  • +1
2 Solutions
 
Rick_O_ShayCommented:
GVRP is a Layer2 protocol so you probably need to be in the switch part of the box and not the router mode.  You should be able to type "enable" to get to that level.
0
 
hbrumfieldAuthor Commented:
Not sure what you mean.  When I login (either telnet or console), the prompt says Router>
Then I type enable, enter enable password and the prompt changes to Router#

Thanks in advance for help.
0
 
Rick_O_ShayCommented:
I was thinking this worked like all the other L2/3 switches I have used that have a command level for switch commands and another, with the router prompt, for router commands. It looks like Catalysts with IOS don't use the set and clear commands like the CatOS. They might not support GVRP either.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
hbrumfieldAuthor Commented:
Do you know of it is possible to boot the Cat 6500 from either the cisco IOS or CatOS?
0
 
hbrumfieldAuthor Commented:
Do you know of it is possible to boot the Cat 6500 from either the cisco IOS or CatOS?
0
 
Don JohnstonInstructorCommented:
GVRP is only available on 6500s if they're running CatOS. Your switch is running IOS so you can't run GVRP.

Since CatOS is being depreciated (nice way of saying abandoned), I wouldn't change your operating system just to get GVRP.
 
0
 
hbrumfieldAuthor Commented:
Thanks for the info.  Basically I am trying to get a Dell Powerconnect 6248 trunk port to work with our Cisco 6500.  I found this posting below which led me to think that I needed to enable GVRP.  Any thoughts?

 http://mobile.experts-exchange.com/Q_22592006.html
0
 
Don JohnstonInstructorCommented:
GVRP is designed to automatically remove unneeded VLANs from trunks.

What is the config for the 6500 port going to the Dell?

Should be something along the lines of:

int g3/5
 switchport
 switchport trunk encap dot1q
 switchport mode trunk

0
 
Rick_O_ShayCommented:
You should be able to easily configure both switches to tag the common connection for the VLANs you want shared between them.
0
 
hbrumfieldAuthor Commented:
Thanks for the help.  I will try it tonight or tomorrow and let you know if it works.
0
 
bsohn417Commented:
u need to been privilaged mode.

router> (enable mode)
router#   <<<<<<<<<<<<<<<<<<<<<< u need to be in here to make any changes.
router(config)# configuration mode


Please follow this doc is for GVRP for IOS
http://www.cisco.com/en/US/docs/ios/12_2sr/12_2srb/feature/guide/srbcgvrp.html
0
 
hbrumfieldAuthor Commented:
Unfortunately, the 6500 is running IOS, not CatOS which is required to use GVRP.  Following "donjohnson's" commands allowed the Dell to talk to the cisco.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 6
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now