?
Solved

Exchange 2010 UM voice mail not hearing voice input, however AA hears voice input perfectly

Posted on 2009-12-31
10
Medium Priority
?
1,386 Views
Last Modified: 2012-05-08
Exchange 2010 UM voice mail not hearing voice input, however AA hears voice input perfectly.

We are running Exchange 2010 UM with a Cisco UC540 w/ CME 8 IOS 15.

Our auto attendant works fine, as you can tell it what menu option and who to call.

However, dialing into our voice mail, it doesn't hear "our voice" for options.

Here is s code snip from our UC540:

dial-peer voice 2000 voip
 description *** Exchange 2010 UM - VoiceMail ***
 destination-pattern 3099
 session protocol sipv2
 session target ipv4:x.x.x.x
 session transport tcp
 no voice-class sip outbound-proxy  
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad


dial-peer voice 2010 voip
 description *** Exchange UM - AA ***
 destination-pattern 3090
 session protocol sipv2
 session target ipv4:x.x.x.x
 session transport tcp
 no voice-class sip outbound-proxy  
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad



This is the guide I followed for configuration of 2010 UM for voicemail:

http://itsworking.co.uk/blog/index.php/2008/09/27/cisco-call-manager-express-with-exchange-2007-unified-messaging-part-2/

At one time it "was" working, however no sure what might have broke it or where to even look?

Any assistance/help would be great.

Thanks!
0
Comment
Question by:shaunbender
  • 5
  • 5
10 Comments
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 26156192
Hi,

It seems there is asymetric routing, please fix it, and it will be working...

Best regards,
Istvan
0
 

Author Comment

by:shaunbender
ID: 26156203
How does that explain the AA working and not VM? Also, could you give more detail on your solution?

Thanks.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 26156209
simple IP routing problem.... the return path is not same....
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 

Author Comment

by:shaunbender
ID: 26156239
Here's snip of Cisco switch setup for the Exchange servers, they're running on a VMware Host v4u1a:


port-channel load-balance src-dst-ip

interface Port-channel20
 description *** EC to ESX02 ***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
!
interface GigabitEthernet0/1
 description *** EC to ESX02 ***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
 channel-group 20 mode on
 spanning-tree portfast
!
interface GigabitEthernet0/2
 description *** EC to ESX02 ***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
 channel-group 20 mode on
 spanning-tree portfast
!
interface GigabitEthernet0/3
 description *** EC to ESX02 ***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
 channel-group 20 mode on
 spanning-tree portfast
!
interface GigabitEthernet0/4
 description *** EC to ESX02 ***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
 channel-group 20 mode on
 spanning-tree portfast
!
interface GigabitEthernet0/5
 description *** EC to ESX02 ***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
 channel-group 20 mode on
 spanning-tree portfast
!
interface GigabitEthernet0/6
 description *** EC to ESX02 ***
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 100
 switchport mode trunk
 channel-group 20 mode on
 spanning-tree portfast
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 26156272
The ESX is on same VLAN?
0
 

Author Comment

by:shaunbender
ID: 26156279
yes, all on the same vlan.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 26156284
did you tried it witout port channel?
0
 

Author Comment

by:shaunbender
ID: 26156330
strange thing is ... it's always been on a port channel.

0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 26156383
please try it without...
0
 

Accepted Solution

by:
shaunbender earned 0 total points
ID: 26173475
Issue turned out to be with the UC540 running IOS 15/CME 8 ... switched back to IOS 12.x / CME 713... once on the older code base, things worked.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
If something goes wrong with Exchange, your IT resources are in trouble.All Exchange server migration processes are not designed to be identical and though migrating email from on-premises Exchange mailbox to Cloud’s Office 365 is relatively simple…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question