[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1116
  • Last Modified:

Installing Exchange2007 SP1 on WinServer 2008 STD member server

I am trying to install exchange 2007 on win 2008 std which is not a DC but a member server. I am receiving the following eror message upon installing. Can someone pls tell me what is missing. I do not have AD installed as this is running on the DC not the member server.

Summary: 4 item(s). 0 succeeded, 4 failed.
Elapsed time: 00:07:36


Organization Prerequisites
Failed

Error:
The Exchange organization does not support this version of Exchange Server.

Elapsed Time: 00:07:25


Hub Transport Role Prerequisites
Failed

Error:
The Exchange organization does not support this version of Exchange Server.

Error:
Setup cannot continue because one or more SMTP/Send connectors have invalid settings: Could not find the Organization Container.

Elapsed Time: 00:00:03


Client Access Role Prerequisites
Failed

Error:
The 'IIS 7 Dynamic Content Compression' component is required. Install the component via Server Manager.
Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.3&id=41a25c5e-0d39-4e55-a1f0-7be885982236

Error:
The Exchange organization does not support this version of Exchange Server.

Elapsed Time: 00:00:03


Mailbox Role Prerequisites
Failed

Error:
The Exchange organization does not support this version of Exchange Server.

Elapsed Time: 00:00:03

0
BMSupport
Asked:
BMSupport
  • 8
  • 4
1 Solution
 
Glen KnightCommented:
It's OK, it doesn't have to be installed on a DC as long as the server you are installing on is a member of the domain.

Do you have Exchange already installed?

Have you run all the pre-requisites?

There is a good guide here on installing Exchange 2007: http://www.msexchange.org/tutorials/Installing-Exchange-2007-Part1.html

also please note currently there is no support for Windows 2008 R2 this will change in the future and is supported by Exchange 2010 but not 2007.
0
 
eddie_86Commented:
Are you installing Exchange 2007 on 32 bit version. check that. Or the CD which you are using might not be the right version.

And for CAS role Prerequisites. When you install the IIS 7 manually from server manager there is an option to Check Dynamic Content Compression. Seems like that is not installed. Install it and then run the set up
0
 
Glen KnightCommented:
Hi Eddie, that's a good point! Not sure it will bring this error up though but well worth mentioning!

Happy New Year!
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
BMSupportAuthor Commented:
Thanks Guys for the tips.

A little more info:-

I have exchange 2010 installed on the DC but this was only for testing.
I  have exchange 2007 64 bit so thats not the issue.
Another thing i have read is that I need to raise that doamin function level which is currently windows server 2008 R2 on the DC. I believe i can roll back to windows server 2008 STD. Possibly this is why its failing because the member server is only 2008 STD. If so how do I roll back to server 2008 STD?

Lastly I possibly need to uninstall 2010 first on the DC but the role based access control specific to exchange 2010 will not let me remove mailboxes. How do i set "administrator" full access? I have read but cannot find a solution.

Thanks
0
 
Glen KnightCommented:
The Exchange 2007 install MUST be the SP2 install if your using Exchange 2010

if your not using the 2010 I would suggest you uninstall it but I would personally recommend using 2010 instead of 2007
0
 
BMSupportAuthor Commented:
ok ill do that

can tell me more about the permission for exchange 2010. i need to know how to grant permissions so i can remove mailboxes
0
 
Glen KnightCommented:
By default if you login as the administrator user you should be able to do this?
0
 
BMSupportAuthor Commented:
i know. Whem i first installed it i could but now I cant. there is not option to remove or add mailboxes. I cant even view storage groups. I a, logged in as administrator. Any ideas?

Im just about to install 2010 on the member server.
0
 
BMSupportAuthor Commented:
Do i have to install IIS on the member server? I have IIS on the DC.
0
 
Glen KnightCommented:
Yes all the prerequisites will be needed.

Check the guide I posted in my first post!
0
 
Glen KnightCommented:
Sorry 2010 pre-requisites here: http://technet.microsoft.com/en-us/library/bb691354.aspx

note the different scripts to run for 2008 R2
0
 
Glen KnightCommented:
If your having problems seeing everyhting on the other server create a new administrative account and login to that server using that account.
0
 
Glen KnightCommented:
question was answered with Comment ID: http:#26157458
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 8
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now