[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

All mailboxes in mailbox store in exchange have disapeared

Posted on 2010-01-01
38
Medium Priority
?
1,437 Views
Last Modified: 2012-05-08
I have an old and a new exchange server that I have been slowly migrating over time. I attempted to move a users large mailbox last night and noticed that only part moved. So now this user has a mailbox store on the old and new exchange server. After another attempt to move the remaining mailbox store the new exchange server wen't down and I noticed that all the mailboxes in the new exchange servers mailbox store are now missing (panic). Here are some of the event log errors that followed the move:

Event ID:      445
Information Store (1620) First Storage Group: The database C:\Program Files\Exchsrvr\mdbdata\priv1.edb has reached its maximum size of 16383 MB. If the database cannot be restarted, an offline defragmentation may be performed to reduce its size.

Event ID:      1112
The database "First Storage Group\Mailbox Store (GW-EXCH)" has reached the maximum allowed size. Attempting to unmount the database.

Event ID:      8506
Unable to move mailbox Smith, John.
 A problem occurred while getting the properties for a message.

 Internal parent folder ID: 4-2F3A5F; Message ID: 4-3009C2; Error code: Maximum database size reached for database.

 Run ISINTEG to check for any problem in the database "First Storage Group\Mailbox Store (GW-EXCH)".

Event ID:      9172
Failed to copy messages to the destination mailbox store.
Error: The MAPI call failed.
MAPI or an unspecified service provider.
ID no: 80004005-0000-00000000

Event ID:      1203
Failed to delete the mailbox of /O=FIRST ORGANIZATION/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=JSMITH with error Maximum database size reached for database.

Event ID:      1024
Unable to delete a mailbox on 'GW-EXCH'. Result: An internal processing error has occurred. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.

Event ID:      1008
Unable to move mailbox 'John Smith.'
Error: The MAPI call failed.
MAPI or an unspecified service provider.
ID no: 80004005-0000-00000000

Event ID:      9175
The MAPI call 'OpenMsgStore' failed with the following error:
The attempt to log on to the Microsoft Exchange Server computer has failed.
The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0512-00000000

I'm nervous about attempting anything further until I hear from an expert.

Thanks.


0
Comment
Question by:ronet_it
  • 19
  • 16
36 Comments
 
LVL 74

Accepted Solution

by:
Glen Knight earned 2000 total points
ID: 26157958
This is probably due to your information store reaching it's limit.
In Exchange 2003 prior to Service Pack 2 this was limited to 16 GB
 
Check the application log on your Exchange Server for the following:
 
Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 1112
Description: The database "Mailbox Store (Server Name)" has reached the maximum allowed size. Attempting to unmount the database.
 
Event Type: Warning
Event Source: ESE
Event Category: Space Management
Event ID: 445
Description: Information Store (3160) The database D:\Program Files\Exchsrvr\MDBDATA\priv1.edb has reached its maximum size of 16383 MB. If the database cannot be restarted, an offline defragmentation may be performed to reduce its size.
 
If this is the case then Services Pack 2 can be applied for Exchange Server 2003 from here: http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=535BEF85-3096-45F8-AA43-60F1F58B3C40&displaylang=en
If you are running Small Business Server 2003 then you need to ensure that you have SP2 for Exchange along with SP2 for Windows and SP1 for SBS: http://www.microsoft.com/windowsserver2003/sbs/downloads/sp1/default.mspx
 
Once you are running SP2 for Exchange you can increase the size of your Information Store Limit but following this article: http://support.microsoft.com/kb/912375 upto a maximum of 75GB
0
 
LVL 3

Expert Comment

by:tusharnextgen
ID: 26158121
please mount the database manually and run cleanup agent on server to see the status of the mailboxes

then you would able to see disconnected mailboxes on one server and same mailboxes you might find connected in another server. (You can purge disconnected mailboxes if they are connected on another server after confirming connected one has complete data)

I do agree that you have reached the maximum database limit for exchange 2003 standard edition prior to sp2.

Please upgrade to exchange 2003 sp2 and follow the steps given below (extract of KB 912375) as suggested by demazter.

On the computer that is running Exchange 2003 SP2, click Start, click Run, type regedit, and then click OK.
Click one of the following registry subkeys, as appropriate for the store that you want to increase:
For a mailbox store, click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Server name\Private-Mailbox Store GUID
For a public folder store, click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Server name\Public-Public Store GUID
On the Edit menu, point to New, and then click DWORD Value.
In the New Value #1 box, type Database Size Limit in Gb, and then press ENTER.
Right-click Database Size Limit in Gb, and then click Modify.
Click Decimal, and then type an integer from 1 to 75 in the Value data box.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158156
tusharnextgen > thank you for confirming all the information I had already provided!!

It's not particularly courteous to repeat someone elses post!
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 

Author Comment

by:ronet_it
ID: 26158458
When I browse to the registry I get the following:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\GW-EXCH\Private-b956cd92-bd9e-4ae3-9f37-1a3ce31d5aea

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\GW-EXCH\Public-25fc9101-4c0f-47ee-ad44-0dce0f43cd20

Why the GREEK and not Private-Mailbox Store GUID and Public Store GUID?

Also, how do I mount the database manualy and run cleanup agent? Should I do this before I increase the size of the mailbox store?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158464
You won't be able to mount it unless you are running SP2 for Exchange.  As you have hit the 16GB limit as apposed to the 18GB limit this would suggest SP2 is not installed.

Do this first.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158467
Also those registry keys are correct what you should see is Private followed by the GUID of the store which is what you are seeing.
0
 

Author Comment

by:ronet_it
ID: 26158489
SP2 is installed and I have just increased the size of the database to 65GB in the registry. Iv'e yet to start and stop msexchangeis. Should I attempt to mount the database in System Manager?
 
I believe I do this by right clicking the Mailbox Store and then select Mount Store. Once I mount it, what do I do? You said there is a cleanup? Should I start and stop msexchangeis first?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158491
Restart the Microsoft Exchange Information Store service, then mount the mailbox store as you said.

To be honest 16GB is nothing at all and the normal cleanup procedures will sort this out for you in due course.
0
 

Author Comment

by:ronet_it
ID: 26158508
OK, I've stopped and started the msexchangeis and have mounted the Store, but my mailboxes are still GONE??? (PANIC)!! What now?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158513
When you say they are still gone what exactly do you mean?

Do they not appear in Exchange System Manager?
0
 

Author Comment

by:ronet_it
ID: 26158516
Yes. Under Frist Admin Group/Servers/GW-EXCH/First Storage Group/Mailbox Store (GW-EXCH) I still have a few left to move from the other server. They are still there.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158521
So the mailboxes still appear in Exchange System Manager?
So where are they missing from?
0
 

Author Comment

by:ronet_it
ID: 26158532
I may have worded my last relpy a little strange. When I browse to >Frist Admin Group/Servers/GW-EXCH/First Storage Group/Mailbox Store (GW-EXCH) there are ZERO mailboxes. It says "There are no items to show in this view". The old sever (City-Main2) still has mailboxes there that I still need to move over.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158541
Can you close System Manager and restart it?
You may need to just give all the Exchange Services a restart before you open the System Manager again.
0
 

Author Comment

by:ronet_it
ID: 26158550
Well, its been unmounted again. It has that red arrow pointing down again. Crap. What now?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158558
What does the event log say?
Did you change the value in both Registry Keys?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158560
Did you create the registry key EXACTLY as it appears in the link I provided?

This one: http://support.microsoft.com/kb/912375
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158562
Do you definately have Exchange 2003 SP2 installed on this new server?
If you don't those registry keys will be ignored.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158566
Goto C:\exchsrvr\bin find store.exe right click and select properties then under version what does it say?
0
 

Author Comment

by:ronet_it
ID: 26158567
I only changed the mailbox (Private) in the registry.
Here are some of the latest event id's:

Event Type:      Warning
Event Source:      MSExchangeIS Mailbox Store
Event Category:      Rules
Event ID:      1151
Date:            1/1/2010
Time:            11:47:39 AM
User:            N/A
Computer:      GW-EXCH
Description:
A rule synchronization error (1144) has occurred on Mailbox Store "First Storage Group\Mailbox Store (GW-EXCH)".

 The mailbox folder is Top of Information Store\Inbox.

 The distinguished name of the owning mailbox is ---.

 There are 24 of 24 retries remaining.

For more information, click http://www.microsoft.com/contentredirect.asp.


Event Type:      Warning
Event Source:      ESE
Event Category:      Space Management
Event ID:      445
Date:            1/1/2010
Time:            11:48:02 AM
User:            N/A
Computer:      GW-EXCH
Description:
Information Store (4608) First Storage Group: The database C:\Program Files\Exchsrvr\mdbdata\priv1.edb has reached its maximum size of 16383 MB. If the database cannot be restarted, an offline defragmentation may be performed to reduce its size.

For more information, click http://www.microsoft.com/contentredirect.asp.



Event Type:      Error
Event Source:      MSExchangeSA
Event Category:      MAPI Session
Event ID:      9175
Date:            1/1/2010
Time:            11:57:44 AM
User:            N/A
Computer:      GW-EXCH
Description:
The MAPI call 'OpenMsgStore' failed with the following error:
The attempt to log on to the Microsoft Exchange Server computer has failed.
The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0512-00000000

For more information, click http://www.microsoft.com/contentredirect.asp.


Event Type:      Error
Event Source:      MSExchangeSA
Event Category:      Monitoring
Event ID:      1005
Date:            1/1/2010
Time:            11:56:47 AM
User:            N/A
Computer:      GW-EXCH
Description:
Unexpected error <<0xc1050000 - Unknown Error. The logon to the Microsoft Exchange Server computer failed. Microsoft Exchange Server Information Store ID no: 80040111-03ee-80040111>> occurred.

For more information, click http://www.microsoft.com/contentredirect.asp.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158572
Doesn't look like SP2 is installed.
The limit is 18GB by default with SP2 and this is stopping at 16GB which was the pre-SP2 limit.

Can you check the store.exe version
0
 

Author Comment

by:ronet_it
ID: 26158579
Crap, I was thinking I needed R2 for Windows Server. Which I have. How do I check if I have R2 for Exchange?
0
 

Author Comment

by:ronet_it
ID: 26158584
Version: 6.5.6944.0
0
 

Author Comment

by:ronet_it
ID: 26158588
About Exchange Information Store
0
 

Author Comment

by:ronet_it
ID: 26158591
So I guess I don't have R2 or it would say so. I'll get started on downloading it. Thanks.
0
 

Author Comment

by:ronet_it
ID: 26158596
Can I safely delete that registry entry or should I leave it alone?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158605
Leave it there.
Just double check the Exchange server version.

In Exchange System Manager navigate to Administrative Groups > First Administrative Group and highlight servers then on the right hand side you will see a list of servers that have Exchange on there will also be a column that tells you the Service Pack level?
0
 

Author Comment

by:ronet_it
ID: 26158613
I have it on the old server but not the new. This appears to be my problem. I just hope I can recover those mailboxes after all this.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158620
Once you install SP2 and reboot it will all be back!
Don't panic!
0
 

Author Comment

by:ronet_it
ID: 26158771
OK. Life is better now in 2010 since installing SP2. Mailboxes are back. However, there is one more issue I need to finish this. The large mailbox that I tried moving that started all this is split. Part of the mailbox still resides in the old server and part is on the new server. Should I perform another mailbox move on the rest of the mailbox in the old server or is there more to it.

Thanks
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26158798
Yes perform a new move.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26159230
How did it go?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26160768
Did you accept the correct answer?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 26161639
Comment ID:26157958 gives the correct answer.
The 2nd comment that has been accepted as the answer was virtually identical except the content has been copied/pasted from the links I provided.

I then went into support the asker in identifying why the registry entries were not working.
0
 

Author Closing Comment

by:ronet_it
ID: 31671778
Very quick reply and stayed with me through the issue until it was resolved.
0
 

Author Comment

by:ronet_it
ID: 26204144
Sorry about that demazter, don't know what I was thinking when I awarded those points. You were a big help and I'm glad you were able to get full points since I meant to give them to you.
0

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes Top 9 Exchange troubleshooting utilities that every Exchange Administrator should know. Most of the utilities are available free of cost. List of tools that I am going to explain in this article are:   Microsoft Remote Con…
After a recent Outlook migration from a 2007 to 2010 environment, some issues with Distribution List owners were realized. In this article, I explain how that was rectified.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Suggested Courses

608 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question