• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 859
  • Last Modified:

Quirky Awstats Installation on Debian Lenny.

I had attempted to get awstats running on a debian (lenny 64bit) server, but my first couple of attempts brought me to a point were awstats_configure.pl couldn't locate certain files, or awstats so called "databases" were not being written in my log directory.  So I decided to do a aptitude remove awstats, and deleted the remnants of awstats, such as custom directories that I wanted to place my awstats.mysiteblahblahblah.com.conf files, as well as the few lines I added to apache2.conf.

I recently came across an article that shows a slightly different approach to the install on Debian, and thought I would give it another shot.  This time however, when I go to do a aptitude install awstats, everything seems to install properly, but the files in /etc/awstats/ are not there, it's just an empty folder.  Meaning I have no base config files.

I decided to look at /usr/lib/cgi-bin/ and the only file there is awstats.pl.  I can't even localte awstats_configure.pl anymore.

Just curious if anyone has encountered this problem, and if there's a solution to it.  I don't want use a different program as awstats seems to be good  (when it works).
0
metazend
Asked:
metazend
1 Solution
 
metazendAuthor Commented:
I guess I resolved the issue myself.  Still unsure why the default .conf files aren't being created during install, but I ran awstats_configure.pl in the command prompt and generate the files needed.  Only issue I came across where file locations being different in debian, and having to move it around so the perl script could locate it.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now