Most pages won't finish loading in multiple browsers on both xp and vista

I have recently acquired 2 new computers: 1- Lenovo desktop running Vista 2- Gateway netbook running XP
On both systems I am experiencing problems using any browser to access the web. Some pages like msn, microsoft pages, google searches run as expected but then I follow a link to wikipedia for example and it will take 10 minutes for the page to load if indeed it ever loads. Is this an isp problem?
wrenzoAsked:
Who is Participating?
 
nordtorpCommented:
This could be some problems with your ISPs DNS server.

Please run this test and paste the outcome to me.

1. Go to Start > Run... > 'cmd' > OK
2. Type 'ipconfig /all' and notice primary and secondary DNS server
3. Copy my code into notepad and put in primary and secondary DNS server IPs
4. Save it as DNStest.bat on C:\
5. Run this command in cmd: 'C:\DNStest.bat'


@echo on
cls
prompt $t 
nslookup www.google.com 208.67.222.222
nslookup www.google.com <primary DNS>
nslookup www.google.com <secondary DNS>

Open in new window

0
 
wrenzoAuthor Commented:
this is the result:


C:\>prompt $t

12:11:16.53 nslookup www.google.com 208.67.222.222
Server:  resolver1.opendns.com
Address:  208.67.222.222

Non-authoritative answer:
Name:    www.google.com.socal.rr.com
Address:  208.67.219.132

The syntax of the command is incorrect.

12:11:16.75 nslookup www.google.com <209.18.47.61>

12:11:16.75
0
 
nordtorpCommented:
Please remove < and > from the test and try again, then repost. Thank you
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
wrenzoAuthor Commented:
thanks for getting back quickly. I will do this in about 10 minutes.
0
 
wrenzoAuthor Commented:
I'm sorry, I don't see and anywhere. Please clarify.
0
 
nordtorpCommented:
Type your code as below.

Replace the secondary DNS in the same way.
@echo on
cls
prompt $t 
nslookup www.google.com 208.67.222.222
nslookup www.google.com 209.18.47.61
nslookup www.google.com <secondary DNS>

Open in new window

0
 
wrenzoAuthor Commented:
this is the batch file that I ran: (it appears to be exactly what you are asking for)

@echo on
cls
prompt $t
nslookup www.google.com 208.67.222.222
nslookup www.google.com <209.18.47.61>
nslookup www.google.com <209.18.47.62>
0
 
nordtorpCommented:
Try this:

@echo on
cls
prompt $t
nslookup www.google.com 208.67.222.222
nslookup www.google.com 209.18.47.61
nslookup www.google.com 209.18.47.62
0
 
wrenzoAuthor Commented:
the results:


13:40:07.79 prompt $t

13:40:07.79 nslookup www.google.com 208.67.222.222
Server:  resolver1.opendns.com
Address:  208.67.222.222

Non-authoritative answer:
Name:    www.google.com.socal.rr.com
Address:  208.67.219.132


13:40:07.96 nslookup www.google.com 209.18.47.61
Server:  dns-cac-lb-01.rr.com
Address:  209.18.47.61

Non-authoritative answer:
Name:    www.google.com.socal.rr.com
Address:  24.28.193.9


13:40:08.26 nslookup www.google.com 209.18.47.62
Server:  dns-cac-lb-02.rr.com
Address:  209.18.47.62

Non-authoritative answer:
Name:    www.google.com.socal.rr.com
Address:  24.28.193.9


13:40:08.54
0
 
nordtorpCommented:
With your DNS server it shows that it takes about 30 seconds and 28 seconds to resolve google.com.

The first server (OpenDNS) takes 17 seconds, try installing an DNS service on your computer or changing DNS server.

For instance OpenDNS.

Here is a video HowTo on the topic:
http://www.youtube.com/watch?v=wf8Rgw6A6y0

Homepage of OpenDNS
http://www.opendns.com/

You could also change the DNS server this way:
1. Go to Control Panel > Network Connections and select your local network.
2. Click Properties, then select Internet Protocol (TCP/IP).
3. Click Properties.
4. Set 209.18.47.61 as your primary DNS server and click OK twice.

Now you could try to surf the web and see if it is better.

You could also contact your ISP to check that everything is okay.
0
 
wrenzoAuthor Commented:
I've also discovered that the router didn't have an isp or domain name in its settings. I think I am on my way to resolving all of this. Thanks for staying with me.

W
0
 
nordtorpCommented:
Your welcome.

Good luck!
0
 
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
Ehem. The last digits of $t are 1/100 secs. The real timing is hence
nslookup www.google.com 208.67.222.222      170 ms
nslookup www.google.com 209.18.47.61           300 ms
nslookup www.google.com 209.18.47.62           280 ms
which are quite  normal timings. NSLookup is not using any cache, btw, and repeated queries will not get quicker, so the method of measurement is appropriate.

If you do a web request, or ping, or anything else, you will use your local DNS cache. The (volatile) entries are shown with ipconfig /displaydns. Once an entry is resolved, further references are compared against that cache, speeding up web access.

Both factors together show no reason for the enormous delays you report of.

Is there anything involved like
  • a Router with Web Filtering, Intrusion Detection, Antivirus check of streams;
  • a Web Proxy software
  • or whatsoever analyzes web traffic for malicious code?
Some of that techniques can lead to drop of packets for congestion, and that again introduces timeout and resend issues, which might explain some delay.

You can trace the routing path to one of the slow web sites, to exclude serious problems with e.g. packet MTU or MSS (packet payload size). A good tool to do so is mturoute (http://www.elifulkerson.com/projects/mturoute.php), which is used best for this purpose with   mturoute -t www.wikipedia.com. I would start a trace route in addition (tracert -d www.wikipedia.com).
0
 
wrenzoAuthor Commented:
While working on a possible dns problem I checked the router and found that there was no isp or domain name for it to connect to. I believe that correcting that has cured the problem. It's pinging much better.
0
 
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
I ignored that because I do not believe that a missing DNS domain suffix in the router should introduce big delays.
0
 
wrenzoAuthor Commented:
I'm away from that machine for a while. I will follow up tomorrow.
0
 
nordtorpCommented:
Olemo, you are correct regarding the test, it was late for me last night. A nslookup of 30 seconds IS quite long. I am sorry for that.
0
 
wrenzoAuthor Commented:
Well, friends. I believe that the problems were all in the router. Why would they be in the DNS settings if the DNS are auto generated by DHCP?

Apparently someone has reset the router and it was crippled with no host domain.

Does this make sense?
0
 
DjAriochCommented:
The issue not the settings but the response time from the DNS servers, that is irregardless of DHCP or static.

Change the DNS servers listings on an affected machine and test it out. I believe you will notice a difference. Go to http://www.dnsserverlist.org/ and get a time tested server to use for your location.
0
 
wrenzoAuthor Commented:
I believe I found my own solution but only with the assistance and presence of the gurus who told me where to look. Plus I learned in the process.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.