?
Solved

Cisco 877 NetVPN DSL "Interface Virtual-Access1, changed state to down"

Posted on 2010-01-02
8
Medium Priority
?
2,794 Views
Last Modified: 2013-12-14
I have been using AT&T NetVPN for a few years now but recently I have started to receive errors in my Cisco 877 routers log as follows:

000058: Jan  2 13:19:02.125 PCTime: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0
000059: Jan  2 13:19:02.129 PCTime: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
000060: Jan  2 13:19:03.125 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down
000061: Jan  2 13:25:31.197 PCTime: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
000062: Jan  2 13:25:31.201 PCTime: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
000063: Jan  2 13:25:50.069 PCTime: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

I am seeing this multiple times daily.  No configuration changes have been made in the router.  Can anyone give me some idea what could be causing this?  Our provider - AT&T - says the problem is on my end.  This is an ADSL circuit.
0
Comment
Question by:djpriceAtl
  • 4
  • 4
8 Comments
 
LVL 9

Expert Comment

by:predragpetrovic
ID: 26163004
hi,

when using ADSL circuit, are you getting new ip addresses or is it a static IP address. I have seen these errors when clients renegotiate IP address and when someone was messing with the cables in the Telco Box.

predrag
0
 

Author Comment

by:djpriceAtl
ID: 26163269
It is not static.  Here is the interface Dialer0 show running:
interface Dialer0
 ip address negotiated
 ip mtu 1452
 encapsulation ppp
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
 dialer pool 1
 no cdp enable
 ppp authentication pap callin
 ppp eap refuse
 ppp chap refuse
 ppp pap sent-username username@mydomain.com password 7 121D0019060A0055

I don't think I have any choice in the matter but it someone at the telco keeps messing with the lines we are going down regardless most likely.  This occurs anywhere from 5 to 15 times per day, for various lenghts of time from anywhere to a few seconds to sometimes 15-20 minutes.
0
 
LVL 9

Expert Comment

by:predragpetrovic
ID: 26163282
hi,

well this could be a problem with the line/modem or the cable. Could you re-check the cabling ?

predrag
0
Choose an Exciting Career in Cybersecurity

Help prevent cyber-threats and provide solutions to safeguard our global digital economy. Earn your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

 

Author Comment

by:djpriceAtl
ID: 26164174
I have re-checked the line/cabling.  I have switched out the DSL filters thinking it may be a bad filter but this made no difference.  I have also switched out the router with a know good spare.  The cabling comes in directly from the ISP's DMARK jack into the router.  So I think this elimitates a cable problem on the inside as well as a router or filter problem. Possibly a config issue on my router or an ISP copper line problem is what I am thinking?  I know the ISP had me switch from PPPoA to PPPoE some months ago and it seemed to crop up after that mabe???
0
 
LVL 9

Expert Comment

by:predragpetrovic
ID: 26165054
can you post the configs ?
0
 

Author Comment

by:djpriceAtl
ID: 26165347
Yes, here is my complete config:

version 12.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname dsl10
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 debugging
logging console critical
enable secret 5 $1$8Qag$ysJqFQbsD823h73d4rOxl1
!
username avcor privilege 15 secret 5 $1$5Skj$DhzncM/KbCwFY1U57InAY1
clock timezone PCTime -5
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
aaa new-model
!
!        
aaa session-id common
ip subnet-zero
no ip source-route
ip cef
!
!
ip tcp synwait-time 10
no ip bootp server
no ip domain lookup
ip domain name mydomain.com
ip ssh time-out 60
ip ssh authentication-retries 2
no ftp-server write-enable
!
!
!
!
!
!
!
interface ATM0
 no ip address
 ip route-cache flow
 load-interval 30
 atm ilmi-keepalive
 pvc 0/16 ilmi
 !
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
 hold-queue 224 in
!
interface FastEthernet0
 no ip address
 no cdp enable
!
interface FastEthernet1
 no ip address
 no cdp enable
!
interface FastEthernet2
 no ip address
 no cdp enable
!
interface FastEthernet3
 no ip address
 no cdp enable
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
 ip address 192.168.10.5 255.255.255.0
 ip route-cache flow
 ip tcp adjust-mss 1452
!
interface Dialer0
 ip address negotiated
 ip mtu 1452
 encapsulation ppp
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
 dialer pool 1
 no cdp enable
 ppp authentication pap callin
 ppp eap refuse
 ppp chap refuse
 ppp pap sent-username username@mydomain.com password 7 121D0019060A0055
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
!
logging trap debugging
access-list 101 permit ip any any
dialer-list 1 protocol ip permit
no cdp run
route-map clear-df permit 10
 match ip address 101
 set ip df 0
!
!
control-plane
!
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 exec-timeout 5 30
 password 7 104A0C1711161E5A
 no modem enable
 transport preferred all
 transport output telnet
 stopbits 1
line aux 0
 transport preferred all
 transport output telnet
line vty 0 4
 privilege level 15
 transport preferred all
 transport input telnet ssh
 transport output all
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

0
 
LVL 9

Accepted Solution

by:
predragpetrovic earned 2000 total points
ID: 26165516
hi,

you have some issues with ATM0 interface and Dialer interface. Please follow this guide:

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a729.shtml

predrag
0
 

Author Comment

by:djpriceAtl
ID: 26199487
Thanks, that link was helpful.   I made changes to my config following that guide 2 nights ago, yesterday had zero disconnects - which has not happened in a long while.  Hopefully, this may resolve the problem.  However, that original config is being used in 10 other locations without issue and it was given to me by the ISP.  I am guessing there may have been some original PPPoA settings left over, they had us change to PPPoE a while back and maybe problems have cropped up from that?  I would guess if the disconnects continue it is a problem and the ISP end.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
In this article I will be showing you how to subnet the easiest way possible for IPv4 (Internet Protocol version 4). This article does not cover IPv6. Keep in mind that subnetting requires lots of practice and time.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses
Course of the Month15 days, 1 hour left to enroll

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question