squid transparent proxy

I'm currently attempt to setup a transparent proxy between my linksys router and my wifi access point.

The hardware setup like the following
Linksys Router --> Ubuntu PC (2 Network Card) --> switch --> Access Point --> Laptop
On the Ubuntu PC, eth0 is connected to the router, eth1 is connected to the switch

I've read on how to setup transparent proxy using squid and seems to done all setting properly. When I was about to test it, it realize that
1) eth1 doesn't have an IP
2) Computer connected to access point cannot obtain IP address

So as of this point, I can not test to see if my transparent proxy is working or not. So here are my questions

1) How do I make the laptop that's connected to the access point obtaining IP address from router? Do I need to setup DHCP service on Ubuntu PC and give a different IP range?
2) Do I set a static IP for eth1? If I do, should I setup the static IP in the same range as eth0? (eth0 now is 192.168.1.0/24, should I setup eth1 within 192.168.1.0/24 or some other IP range like 192.168.200.0/24)
3) On my Ubuntu box there is only Apache Server and Squid2 are installed, am I missing any applications?

Thank you all in advanced
geoffryfAsked:
Who is Participating?
 
BlazConnect With a Mentor Commented:
You have two options - configure normally or configure Ubuntu as a bridge:

Normally
1) Yes you should install DHCP on Ubuntu
2) Yes, you should set the IP. The eth1 IP should be in a different subnet.
3) Only squid should be enough.

Bridge - you could configure the Ubuntu box as a bridge
http://freshmeat.net/articles/configuring-a-transparent-proxywebcache-in-a-bridge-using-squid-and-ebtables
1) The DHCP on Linksys will be used
2) The same IP as on eth0 will apply to eth1 as well (the IP of the bridge br0)
3) Only squid should be enough.


0
 
geoffryfAuthor Commented:
Thank you for your comments, let me give it a shot and I will get back to you.

Wish me good luck!
0
 
BlazCommented:
I believe I gave two possible solutions to the problem and answer all the (three)questions that the asker had asked (and all three for both solutions).

So I believe I should get the points for this question since the asker did not have any further questions.
0
 
geoffryfAuthor Commented:
Its working properly. I am sorry for not closing this post earlier.

Thanks
0
 
hemmiCommented:
Sure: geoffryf just did not answer to decent proposals!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.