Exchange 2010 After install when initialising it looks for the DC not the member server

Posted on 2010-01-02
Last Modified: 2012-05-08
After install when initialising it looks for the DC not the member server.

I have uninstalled exchange 2010 off the DC and installed on a member server. When I open EMC i receive the following error.

No CAS servers are available on local server or adjacent servers.

When i click retry i notice it tries to connect to the DC "server01" not the local server that exchnage is installed on.

Is there any way to change this?

I have uninstalled and reinstalled to no avail.

I have noticed there are not exchange services installed either. Further when i open exchnage powershell it asks me for the FQDN for the exchange server.

This is the error in powershell:-

         Welcome to the Exchange Management Shell!

 Full list of cmdlets:          get-command
 Only Exchange cmdlets:         get-excommand
 Cmdlets for a specific role:   get-help -role *UM* or *Mailbox*
 Get general help:              help
 Get help for a cmdlet:         help <cmdlet-name> or <cmdlet-name> -?
 Show quick reference guide:    quickref
 Exchange team blog:            get-exblog
 Show full output for a cmd:    <cmd> | format-list

Tip of the day #58:

The special variable $_ represents the objects being passed from one cmdlet to another cmdlet in the pipeline. The $_ va
riable is automatically initiated by the Shell and is bound to the current pipeline object. You can access the propertie
s of the object assigned to the $_ variable as you would any other object. The following example shows how you can view
the Name property of each mailbox object that is passed through the pipeline:

 Get-Mailbox | ForEach { $_.Name }

VERBOSE: Connecting to vcentre.magnumtechnology.local
[vcentre.magnumtechnology.local] Connecting to remote server failed with the following error message : The WinRM client
 received an HTTP status code of 403 from the remote WS-Management service. For more information, see the about_Remote_
Troubleshooting Help topic.
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
    + FullyQualifiedErrorId : PSSessionOpenFailed
WARNING: No Exchange Server is available in the current site. Connecting to a Server in an adjacent site.
_AutoDiscoverAndConnect : No CAS or other servers are available in the current site or adjacent sites. Cannot connect t
o Remote Powershell in a Management Tools only box and no cmdlets are provided by Remote Powershell.
At C:\Program Files\Microsoft\Exchange Server\V14\bin\ConnectFunctions.ps1:39 char:27
+             _AutoDiscoverAndConnect <<<<  $credential $Forest -useWIA:$useWIA -CheckCertificates:$false
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,_AutoDiscoverAndConnect

Failed to connect to any Exchange Server in the current site.
Please enter the Server FQDN where you want to connect: vcentre.amgnumtechnology.local
VERBOSE: Connecting to vcentre.amgnumtechnology.local
[vcentre.amgnumtechnology.local] Connecting to remote server failed with the following error message : WinRM cannot pro
cess the request. The following error occured while using Kerberos authentication: The network path was not found.
 Possible causes are:
  -The user name or password specified are invalid.
  -Kerberos is used when no authentication method and no user name are specified.
  -Kerberos accepts domain user names, but not local user names.
  -The Service Principal Name (SPN) for the remote computer name and port does not exist.
  -The client and remote computers are in different domains and there is no trust between the two domains.
 After checking for the above issues, try the following:
  -Check the Event Viewer for events related to authentication.
  -Change the authentication method; add the destination computer to the WinRM TrustedHosts configuration setting or us
e HTTPS transport.
 Note that computers in the TrustedHosts list might not be authenticated.
   -For more information about WinRM configuration, run the following command: winrm help config. For more information,
 see the about_Remote_Troubleshooting Help topic.
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
    + FullyQualifiedErrorId : PSSessionOpenFailed
[PS] C:\Windows\system32>
Question by:BMSupport
    LVL 7

    Expert Comment

    When you open the EMC / EMS it will first try to connect to the CAS server and get authenticated and then only it will start.
    It seems from the above errors that there are authenication issues on the powershell virtual directory of your IIS and some issues in the ApplicationHost.config file.

    1) In the IIS manager check on the Powershell Virtual Directory, in the Modules option -> Kerbauth.dll and Wsman.dll should be present. If it is not there you will have to add it by clicking on the Configure Native Modules.
    2) check if you have winrm iis Extensions installed from the servermanager. If it is not there then install WIN RM IIS Extension.

    Please try this and post the results.

    Author Comment

    I have IIS installed on the DC and also on the Member server. Do i need IIS installed on both?

    I have also looked at IIS on the member server and there are no virtual directories installed.

    What am I doing wrong?

    Thanks in advance
    LVL 7

    Accepted Solution

    IIS should be installed on the Member server. There is no need of IIS on the DC if it does not have exchange on it.

    Since the virtual directories are missing from the IIS, you will have to create the virtual directories.

    first check in the ADISEDIT if you have the virtual directories present. if not then you can run the prepareAd and this will create the virtual directories. else you will have to uninstall the CAS role and reinstall the CAS role so that the virtual directores will be created in the IIS.

    Author Comment

    Hi All,

    I followed this guide to the letter and all is fine.

    Illusionist is right. IIS needs to be on the member server not the DC.

    You guys are great thanks for everything.

    Author Closing Comment

    Was pointed inthe right direction but i found a guide myself.


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Set OWA language and time zone in Exchange for individuals, all users or per database.
    "Migrate" an SMTP relay receive connector to a new server using info from an old server.
    This tutorial will walk an individual through the process of upgrading their existing Backup Exec 2012 to 2014. Either install the CD\DVD into the drive and let it auto-start, or browse to the drive and double-click the Browser file: Select the ap…
    This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now