unix slave dns is not resolving query after primary dns is down

I configure master & slave dns server on solaris 10. once i down my promary dns server my internet is stop
TawseefAsked:
Who is Participating?
 
TawseefConnect With a Mentor Author Commented:
Finally I got a solution, its not related to DNS configuration. There was an issue of routing from VLAN's and due to that it was not allowing secondary DNS to resolve web pages. Whereas it was working fine when tried NSLOOKUP.

Basically routing and Caching was the issue for web users.
0
 
Chris DentPowerShell DeveloperCommented:

Does the server host any of its own zones? If so, do those continue to resolve?

If they do, check Forwards (if you have them in your global options) and check network level access (permission to send to external systems on UDP Port 53).

Chris
0
 
TawseefAuthor Commented:
Thanks Chirs

Yah server is act like the domain resover of differnet company
well on client end i provide my primary & secondary ip
if primary is down than internet stop but if i put my secondary ip on client side as primary so i get the internet
what i understand my both servers act like master server
but in seconday i define on each zone type as slave
so please advise

Adnan
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Chris DentPowerShell DeveloperCommented:

Sounds more like a problem on the client. What is the client? Are you able to verify whether or not it is actually sending a query to the alternate DNS server?

Can you run this from a client:

nslookup www.google.com SecondaryIP

That will at least test whether or not the secondary IP is able to service queries.

Chris
0
 
woolmilkporcCommented:
Hi,

how long did you wait for the client to get a DNS response?
The resolver's timeout value is 5 seconds by default, the number of attempts is 2 by default.

So, with an unresponsive DNS, your client will by default wait quite a while for the first DNS to respond!
According to your post your clients seem to have problems with such delays.
You could set the timeout value and the number of attempts to 1 (the minimum) to reduce the wait time to 1 seconds and see if this helps.

Additionally, to introduce some kind of "round robin" behaviour, you could set the "rotate" option, which will keep the resolver from always trying the first nameserver in the list first.

Your clients' /etc/resolv.conf would then contain these additional entries:

options rotate
options timeout:1
options attempts:1
Good luck!
wmp


0
 
TawseefAuthor Commented:

Well now i am facing very strange problem on my seondary dns server i build a Primary & Secondary dns on Solaris 10 (Intel Architecture) as i mentioned above
now my all clients i give pri & sec ip
the worst part is that when i switch off my primary dns my all client unable to browse the internet but if i do the nslookup it 'll resolve the things
secondly if i put any fake ip  like (192.168.168.168 ) as primary on client side and keep the secondary ip as it than my internet is working fine i can browse the internet and also i resolve the queries
so please advise how can i fix this issue
0
 
Chris DentPowerShell DeveloperCommented:

It suggests a few possible problems, but they do look to be client-side rather than server-side if you are able to resolve names using the secondary server and nslookup.

What client OS are you using? Are you able to monitor network traffic on there to see if it is still attempting to send queries to the first DNS server (and failing to send queries to the secondary)?

Chris
0
 
woolmilkporcCommented:
Could this be related to nscd caching? Do you use nscd?
If yes, check at one of your affected clients what happens when it's switched off.
0
 
TawseefAuthor Commented:
I am not using nscd caching
Last night i done another test acccording to my dns i define dns address outside of my network in home user annd switch off the primary dns and  the internet is working fine but the clients who we are providing internet services who got connected with my network they are unable to browse the internet

please advise
0
 
TawseefAuthor Commented:
Let me once again explain the whole scenario. This configuration is done for a company providing service to its clients for Internet (Sub ISP). Primary & Secondary DNS is configured, when primary DNS is down, the client are unable to browse. When I have forced NSLOOKUP to do resolution by using SERVER IP address of secondary DNS its working fine. From other internet provider when I have tried to access internet while primary DNS is down its working fine. The issue remains only from clients those using internet service from that company's provided internet service.
The NSLOOKUP from other internet service provider for Primary or Secondary DNS is working without any issue. The result of Debug command is clear and no issues found.
I would like to know is there any way I can verify that clients traffic is which suppose to reach primary & seondary DNS is not working as it suppose to work or is there any issue of network I can check which might be not allowing my network traffic or client traffic to reach secondary server and foward further to have resolution.
0
 
Chris DentPowerShell DeveloperCommented:

Sorry, busy day.

There should be a lot of packet sniffers available for Unix, will you need help using one? I'll have to get some help if so, I work far more with the MS side and would be extremely reluctant to tell you the best toosl to use for Unix.

If I were debugging this I would start by monitoring the incoming requests on the server and the outgoing requests on the client (packet sniffer for both). If the client sends, but the server doesn't see then equipment between needs checking.

Whatever happens, it should allow you to isolate where the error is occurring. The next step would be figuring out how to debug whichever component is failing.

Chris
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.