• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 204
  • Last Modified:

severe facebook ahre code issue with coldfusion

I have one code which when i try to share with facebook, my only prodID comes out only!

http://www.facebook.com/sharer.php?u=http://www.domain.us/productsDetails.cfm?prodID=1742&catID=91&catName=Q2xvdGhlcw==&subcatID=34&t=MT

now when i go to facebook and click the title, it returns only the the following:

http://www.facebook.com/sharer.php?u=http://www.domain.us/productsDetails.cfm?prodID=1742

and i get error in my website!

does there any other way of doing the same thing! i tried bunch of things but none worked!!
0
Gurpreet Singh Randhawa
Asked:
Gurpreet Singh Randhawa
  • 2
1 Solution
 
asafadisCommented:
I'm pretty sure that your problem is in the characters after the first question-mark "?".  You see, URLs can't have more than 1 question-mark.  In other words, you're confusing the server.

Try URL-encoding the address you're providing (doman.us): http://meyerweb.com/eric/tools/dencoder/

The firs link would look something more like:
The second link like:
Facebook will know how to decode the address.

If you're into ColdFusion, you can use its URLEncodedFormatI() function, and its counterpart, URLDecode().
0
 
Gurpreet Singh RandhawaWeb DeveloperAuthor Commented:
ye! i am using coldfusion, if u provide me the same help with how i do using urlencodedformat and urldecode i shall be very thankful to you

regards
0
 
asafadisCommented:
My ColdFusion is a bit rusty... but it should be something like:
<cfoutput>
http://www.facebook.com/sharer.php?u=#URLEncodedFormat('http://www.domain.us/productsDetails.cfm?prodID=1742')#
</cfoutput>

Open in new window

0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now