Problem with Cisco ASA 5505 static PAT for incoming SMTP

Posted on 2010-01-03
Last Modified: 2012-05-08
Please help.

I thought this would be simple but I've got something wrong and I can't get it to work.

The problem is I'm trying to configure a Cisco ASA 5505 to allow incoming and outgoing SMTP from the outside interface to a server on the inside VLAN.

I've researched the other articles on the site and I think I'm doing the right things but the config doesn't work and the packet tracer keeps telling me the fault is with the NAT rule.

I started using the ASDM UI and then the CLI just in case there was a bug in the UI.

Would someone please look at the config and tell me what I've got wrong cos it's doing me in!

: Saved
ASA Version 8.2(1)
hostname FAST-ASA-1
domain-name fast.local
enable password xxxjluP39KTQ6qcU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
name Office-Server
interface Vlan1
 nameif inside
 security-level 100
 ip address
interface Vlan2
 nameif outside
 security-level 0
 ip address
interface Ethernet0/0
 switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
boot system disk0:/asa821-k8.bin
ftp mode passive
dns server-group DefaultDNS
 domain-name fast.local
same-security-traffic permit intra-interface
access-list outside_access_in extended permit tcp any eq smtp host Office-Server eq smtp log
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
global (outside) 101 interface
nat (inside) 101
static (inside,outside) tcp interface smtp Office-Server smtp netmask
access-group outside_access_in in interface outside
route outside 5
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
class-map inspection_default
 match default-inspection-traffic
policy-map type inspect dns preset_dns_map
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny  
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip  
  inspect xdmcp
service-policy global_policy global
prompt hostname context
: end
asdm image disk0:/asdm-621.bin
no asdm history enable

Many thanks,

Question by:Jerry Collins
    LVL 79

    Accepted Solution

    NAT is correct, but not the access list
      no access-list outside_access_in extended permit tcp any eq smtp host Office-Server eq smtp log
      access-list outside_access_in extended permit tcp any interface outside eq smtp log
    LVL 2

    Author Closing Comment

    by:Jerry Collins
    Thank you very much, that works perfectly.

    Now I just need to work out what the difference was.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Suggested Solutions

    Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
    This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now