Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 569
  • Last Modified:

how to install certain packge with certain version using yum

Hi all,
I've installed yum-NetworkManager-dispatcher-1.1.16-13.el5.centos.noarch  using
yum install yum*

but I need to install yum-NetworkManager-dispatcher-1.1.16-12.el5 instead
when I try yum downgrade
I got this  message

[root@localhost ~]# yum downgrade yum-NetworkManager-dispatcher  
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, keys, kmod, list-data, priorities, protect-packages, protectbase, security,
              : tmprepo, verify, versionlock
Setting up Downgrade Process
Loading mirror speeds from cached hostfile
 * addons: centos.fastbull.org
 * base: centos.fastbull.org
 * extras: centos.fastbull.org
 * updates: centos.fastbull.org
0 packages excluded due to repository protections
Reading version lock configuration
Only Upgrade available on package: yum-NetworkManager-dispatcher-1.1.16-13.el5.centos.noarch
Nothing to do
[root@localhost ~]#

can any body help and tell me the right syntax
Iam using centos 5.4

thanks in advance
Regards
shang
0
mediabox
Asked:
mediabox
1 Solution
 
torimarCommented:
I'm sorry, but that package (yum-NetworkManager-dispatcher-1.1.16-12.el5.centos.noarch.rpm) does not seem to exist. The version number must have been skipped by the developers. Please see for yourself: http://rpm.pbone.net/index.php3/stat/22/idpl/12381323/com/changelog.html

The general way of downgrading via 'yum' is described here:
http://www.ultranetsolutions.com/Yum-downgrading-packages.html
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now