Outlook 2007 keep prompting for usename and password when connecting to Exchange 2007

Hi I have just migrated from sbs Exchnage 2003 to sbs Exchange 2007. Out of a sudden, the outlook 2007 client keep prompting for user name and password. Even i have entered the correct username and password, it will prompt again immediately.
i have went to the below article and make some registry change and still not working.
http://support.microsoft.com/kb/956531 

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC]
"UseWindowsUserCredentials"=dword:00000000
"DisableTransientFailureAuthPrompts"=dword:00000001

i am not too sure what i did for a while it was working and it happen again after i rebooted the server.

Please kindly help.
LVL 1
dnackAsked:
Who is Participating?
 
Glen KnightCommented:
First thing to do is make sure you have at least Rollup 9 installed for Exchange 2007

Then the following 2 websites provide solutions to the above.
I have had mixed comments some say the first work and some say the second work:

http://social.technet.microsoft.com/Forums/en/exchangesvrgeneral/thread/383d130e-869f-4fce-9502-8b340904b0ba


See the section about enabling Kernel Authentication: http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/0c94187d-bc97-4fa5-9413-e8762a25a360
0
 
AsrCommented:
remove *.ost file and all file from this folder and start up outlook.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Glen KnightCommented:
There is certainly no need to do that!!
This is purely an Exchange problem not outlook!
0
 
Narayan_singhCommented:
Run TestEmailautoconfiguration make sure you have the correct URLs and to set the Urls use the cmds in this articles : http://support.microsoft.com/kb/940726

Make sure you have follwoing authentication type set in virtual directories :

1)Autodiscover: Basic and Integrated authentication   SSL Optional
2) EWS : Integrated authentication                            NO SSL
3) Exadmin : Basic and Integrated authentication       NO SSL
4) Exchange : Basic and Integrated authentication      SSL Optional
5) Exchweb : Basic and Integrated authentication       NO SSL
6) Microsoft-Server-ActiveSync: Basic authentication   SSL Optional
7) OAB : Integrated authentication                             NO SSL
8) OWA : Basic authentication                                 SSL Optional
9) Public : Basic and Integrated authentication          SSL Optional
0
 
Alan HardistyCo-OwnerCommented:
Glen - Always good to see a standard answer to every question no matter what the question ;-)
0
 
Alan HardistyCo-OwnerCommented:
I would backup Demazter's comment about Exchange 2007 Rollup 9 fixing this problem (and don't award me any points for this post if you feel the urge - it is not worthy of points).
0
 
Glen KnightCommented:
Yes indeed - I am convinced it's a robot!

Author > Also please ensure you have convigured an autodiscover record in your external DNS to point to the external IP address of your Exchange Server.  This would be the same IP address you used for your OWA record.
0
 
gupnitCommented:
Hi,
Before making any changes to Exchange Server config, except the RU9 (as per Demazter), which would be recommended in any case, I would be tempted to delete the Outlook Propfile and recreate. See if that makes any change, assumign that only you are facing that problem not everyone. As a secondary step I would also check if Integrated Windows Authentication is enabled or not for Autodiscover under Defautl Website in IIS on CAS Server.
@Demazter/Alan - Who is glen .... :) and do you ever sleep properly...
Thanks
Nitin Gupta (gupnit)
0
 
Glen KnightCommented:
No, sleep is for Wimps!!
And me (demazter) is Glen! ;-)

The 2 links I have provided have fixed the problem for 3 or 4 exact same questions over the past week and 2 of my own installations which is why I posted them.
0
 
gupnitCommented:
;-)......Oh Great....So same questions coming in everytime :-).....I have been away from EE for long, trying to get back....so will see u guys more hahahaa...and hopefully you will accomodate me ;-) !!
0
 
Glen KnightCommented:
I think the reference from Alan was refering to the IIS settings which seem to appear for every single question that contains the word "outlook" "autodiscover" "activesync"

Unfortunately you will get used to it ;-)

Look forward to seeing you more gupnit ;-)
0
 
dnackAuthor Commented:
the second link solve the problem instantly. :)
0
 
Glen KnightCommented:
Excellent, it's good to know, that's about even on the first link and the second link now!

Thanks for the feedback.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.