Unable to ping/telnet/connect to external ip addresses, internal is fine

This is ludicrous... all internal pings/telnets/shares/email works fine. The ip is dynamic and exactly matches the setup of all other computers on the internal network, but this one pc cannot get out to the external world!  If I ping "domainname.com" I get the correct ip address identified by the internal dns server, but the ping request repeatedly times out.  If I ping the ip address directly, I simply get an immediate time out.

I have done ipconfig release/renew/flushdns dozens of times on all computers on network, all of them work perfectly except this one machine which will only work with internal ip addreses. It's driving me scatty, I have no idea what to try next. I have enabled/disabled firewall without any change.

I put a wireless card in the machine and it connected to the wireless office router fine and when I disabled the wiired network card, I could ping external ip addresses from the pc, but I don't want the pc to have to use the wireless network.  It's mad!  I cannot think of what could be causing this...
LVL 1
carledAsked:
Who is Participating?
 
bluepigCommented:
Bad network card. Put in a new one. Have seen flaky network cards do the strangest things!
0
 
jazzIIIloveCommented:
could you use tracert on destinationIP?
open cmd:
tracert externalIP

and post the result here.

Best regards.
0
 
carledAuthor Commented:
tracert fails in the same way - series of asterisks, no results.

Have manually configured ip adddess on windows pc to use same ip, dns & gateway address as was being assigned anyway and it works...  don't know why it won't work on automatic settings though.
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
carledAuthor Commented:
I thought dodgy card, but as I said, wrks perfectly on internal addresses and now I've configured it manually it works perfectly as well...
0
 
bsemailbsCommented:
Check C:\Windows\System32\drivers\etc\hosts file

Virus' or bad software can make entries into this file and redirect all your traffic to nothing... internal addresses would still work.

The default for this file is for it to be blank, with some comments on how to use the file.

Also, try virus scan from all the normal scanners... ALL of them.. each virus scanner has some virus' it always seems to miss... malwarebytes does pretty good... MS security essentials works well also.

This type of problem is typically caused by bad hardware or a virus.
0
 
carledAuthor Commented:
Yeah, I thought virus and hosts file, but nothing, it's exactly as it should be.  Once again, this wouldn't explain how manually setting the IP settings to the same ones allocated by the server works whilst setting it to auto doesn't!
0
 
jazzIIIloveCommented:
Hi there;

1) Are you able to ping your DHCP server?

2) Are you able to ping your router/gateway?

3) What is the DHCP scope available? What IP is your computer getting?

4) Could you arp -a? What is the result? Is there any static record? Could you drop it since maybe the gateway NIC may have changed? Did you change the NIC lately that there coudl be a static record in gateway machine regarding your machine?

5) Are you sure your computer has the same class as your other computers getting in the intranet?

6) Can you change your ip address from automatic to (the same) static address or vice-versa or another static address or another DNS something like 4.2.2.1 or 4.2.2.2?

7) Are there any intelligent switches such as Layer 2 switches? There could be a rule regarding?

8) Are you in a domain environment that somehow by local policies or group policies can block it?

Best regards.
0
 
carledAuthor Commented:
1 Yes
2 Yes
3 192.168.16.220 for 32 192.168.16.21
4 not at office anymore, will try tomorrow
5 absolutely positve!
6 As explained above, have manually set ip to 192.168.16.21, dns 1 to internal office server (192.168.16.208), dns 2 to 192.168.16. (router) and default gateway to same ip as router. This works.  If I set ip stuff to "auto" it sets ALL of the settings to the same as above, but it does not work. There are 7 other pcs on the same network, all of them get assigned the same settings automatically (apart from ip of course) and all of them work fine.
7 No
8 Yes, this is perhaps a possibility, although the machine in question ws working fine just before Christmas and no-one had been in the office until today and no-one else in the office knows how to even turn the server on and off, let alone edit group policies!
0
 
jazzIIIloveCommented:
>>ws working fine just before Christmas
system restore (Create a restore point for the current situation prior doing it)

Best regards.
0
 
jazzIIIloveCommented:
>>Could you drop it since maybe the gateway NIC may have changed?
To drop an arp record, simply do: arp -d
0
 
bluepigCommented:
Don't mean to be a pest, but I've seen a bad NIC behave exactly as you describe.
0
 
jazzIIIloveCommented:
Let the asker first perform the very steps, then we can throw the NIC
:)
0
 
carledAuthor Commented:
It's not a bad network card. I put in another card (the first one is built in on the motherboard) and the same problem persists. If I let dhcp handle it, nothing works. Enter the same details manually and it all works. It's baffling, utterly baffling.  I'll be in the office again on Tuesday to try out the other points.
0
 
bluepigCommented:
Since wireless is OK but wired is not, I'm thinking wiring. Thanks for trying the NIC, now what about a fresh wire from the NIC to a different port on the switch (maybe a port used by one of the working computers). Definitely a head-scratcher!
0
 
carledAuthor Commented:
Well I've not got time to pursue this now. I assume if I reinstalled or changed motherboards it'd all work, but I'm not doing that right now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.