• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1687
  • Last Modified:

Public folder synchronization

I'm in the middle of a migration from a SBS2003 to a SBS2008 server.
All the mailboxes are set to the new server without problems.
I moved all replica's to the new server en this morning checked if everything was fine but in the there are a lot of mails waiting in the SMTPRelayToTiRg with the following error:

451 4.4.0 Primary target IP address responded with:"421 4.2.1 Unable to connect."Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

With the mail flow troubleshooter I get the following errors:
The 'Remote delivery' queue (FIKASBS\3) on server FIKASBS is in retry status. Number of message(s) in the queue: 1339. Last error information: 451 4.4.0 Primary target IP address responded with: "421 4.2.1 Unable to connect." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

Second error:
Server mail.fysiotherapiekudelstaart.nl is a remote server to which server FIKASBS is trying to send messages but no 'Host' records of server mail.fysiotherapiekudelstaart.nl can be obtained from any DNS servers server FIKASBS uses. This may be causing message backups in the queue.

In the old mail server there are the following settings on the Default SMTP Virtual Server:
FQDN: fysiotherapiekudelstaart.nl

It's look like the server cannot deliver the mails from the public folder to the new server but I cannot findout what is causes.
0
venema5
Asked:
venema5
2 Solutions
 
Narayan_singhCommented:
The mailflow between ex 2003 nd ex 2007 should work for PF replication :

Make sure there is no Smarthost in Default SMTP virtual server mentioned

Check if you can ping FQDN of Ex2007 from Ex 2003 and vise-versa see if name resoltuion is happening.

check if you can telnet Port 25 of ex 2007 from ex 2003 and vise versa.

Make sure there is bidirectional routing group connector if there is delete it and re-create it .and restart SMTP service in Exchange 2003 and make sure Public folder referral is allowed on the connector.

create a mailbox in ex 2003 > log in to that mailbox and send a mail to user in Ex 2007 check if the mailflow is working.

Make sure there is PF store cretaed in Ex 2007 and in exc 2003 from system manager you have added 2007 PF store in replica list.

In ex 2003 right click on PF store and then click move replica  and see if replication happenes .


Remove-RoutingGroupConnector
http://technet.microsoft.com/en-us/library/aa998645.aspx

New-RoutingGroupConnector
http://technet.microsoft.com/en-us/library/aa998574.aspx
0
 
gupnitCommented:
Hi,
Run MailFlow Troubleshooter and see what it throws, apart from ExBPA.
Any firewall, Antispam spftware etc ...?
Thanks
Nitin
0
 
venema5Author Commented:
I checked again the mailflow troubleshooter and it says there is a problem with the connection on port 25.

We added the port 366 to the smtp default virtual server because it also is used by both servers to send mail out the internet. This is setup because the ISP is blocking port 25.

Thanks for your assistance.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now