[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4332
  • Last Modified:

Zend Optimizer not installed error - but it is

I'm running XAMPP 1.7.3 on my computer.

using http://localhost, i get the xampp webpage.

I load the phpinfo(), it says Zend Optimizer is installed (see code attachment)

I look in the php.ini, i see:

zend_extension_manager.optimizer_ts="C:\Program Files (x86)\Zend\ZendOptimizer-3.3.0\lib\Optimizer-3.3.0"
zend_extension_ts="C:\Program Files (x86)\Zend\ZendOptimizer-3.3.0\lib\ZendExtensionManager.dll"

I added:
zend_optimizer.enable_loader=1
System 	Windows NT PC 6.1 build 7600 ((null)) i586
Build Date 	Nov 20 2009 17:20:57
Compiler 	MSVC6 (Visual C++ 6.0)
Architecture 	x86
Configure Command 	cscript /nologo configure.js "--enable-snapshot-build"
Server API 	Apache 2.0 Handler
Virtual Directory Support 	enabled
Configuration File (php.ini) Path 	no value
Loaded Configuration File 	C:\xampp\php\php.ini
Scan this dir for additional .ini files 	(none)
Additional .ini files parsed 	(none)
PHP API 	20090626
PHP Extension 	20090626
Zend Extension 	220090626
Zend Extension Build 	API220090626,TS,VC6
PHP Extension Build 	API20090626,TS,VC6
Debug Build 	no
Thread Safety 	enabled
Zend Memory Manager 	enabled
Zend Multibyte Support 	disabled
IPv6 Support 	enabled
Registered PHP Streams 	https, ftps, php, file, glob, data, http, ftp, compress.zlib, compress.bzip2, phar, zip
Registered Stream Socket Transports 	tcp, udp, ssl, sslv3, sslv2, tls
Registered Stream Filters 	convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, zlib.*, bzip2.*

Zend logo This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies
    with eAccelerator v0.9.6-rc1, Copyright (c) 2004-2007 eAccelerator, by eAccelerator
    with Xdebug v2.0.6-dev, Copyright (c) 2002-2009, by Derick Rethans

Open in new window

0
bsemailbs
Asked:
bsemailbs
  • 2
1 Solution
 
Richard QuadlingSenior Software DeverloperCommented:
Check again C:\xampp\php\php.ini

At the command prompt can you type ...

C:\xampp\php\php -v
C:\xampp\php\php -m

and report the results?
0
 
bsemailbsAuthor Commented:
Figured out the problem...

Zend optimizer is not supported under windows 7... even though W7 has been out for a year... crazy.

The fix is to install zend server, and setup everything else manually (ftp/php/mysql/apache).... ridiculous.

Thanks for the help though.
0
 
Richard QuadlingSenior Software DeverloperCommented:
Can you provide any link for that as I'm interested in this issue - not on W7 yet.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now