dhcp default gateway and nslookup result


i've just re-installed windows sbs 2003 premium since our server crashed days ago. thankfully, everything seems to be right... active directory is working properly and the rest.

my current DC/DNS server's ip address is

my question is, in dhcp, how do i make sure or how to i create a policy wherein all the clients' (dhcp enabled) will get a default gateway to it's getting which is my firewall. if i remembered it right before the server crashed when i run ipconfig /all from a client i am getting this message

default gateway:
DNS Servers:

i wanted to have the same setting as before. i don't want my clients to connect directly to my firewall

another thing, when i run nslookup on a client's machine i'm getting this message:

*** Can't find server name for address Non-existent domain
*** Default servers are not available
Default Server:  UnKnown

wouuld appreciate your help.

thanks in advance.
Who is Participating?
joebrockmanConnect With a Mentor Commented:
You can add the additional DHCP options from the server by going to Administrative Tools > DHCP, expanding the server, expanding scope, click on scope options.  Within there you can change the settings for the scope.  The options you want to change are Router and DNS Servers.  Within there you can add multiple DNS servers and order them how you like.
Can you ping the server from a workstation?  If that is working well, is there anything else handing out DHCP (firewall)?  Make sure only one device is handing out DHCP, otherwise you will get conflicts.
gharzAuthor Commented:

yes i can ping the server from my workstation. there is only one dhcp server and that is dhcp server is my dns server as well.

in our previous setting, unfortunately the person who configured our server before left the company years ago and we don't have any documentation of the previous settings, when a dhcp enabled workstation gets it address from the server the default gateway is (server) and not the primary dns server should have been then and then this isn't the case now. workstations only get these values:

default gw:
dns server:

that's it.

is there any policy or setting that would make my server the default gateway and the primary DNS server?

Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

Is there a reason you want the workstations to use the server as the default route?  Generally I have seen the firewall/router used as the default route (or other networking appliance).  If you were to force that, you would need a conenctor or route of some sort setup so the server would forward all traffic to the router/firewall.
Rob WilliamsCommented:
Do you have 2 NIC's in the SBS. You need to in order to make the server the default gateway. It then routes traffic through the server to the router.
If you have 2 NIC's they will be properly configured as will DHCP by running the CEICW (Server management | internet and e-mail| connect to the Internet)
gharzAuthor Commented:

i've got only 1 NIC.


i'll check this one out later. thanks.
Rob WilliamsConnect With a Mentor Commented:
If only one NIC then the router has to be the default gateway. You have no choice. If you set it to be the server they will not have internet access. You can only have the SBS as the gateway if you have 2 NIC's.

SBS 2003 Premium comes with ISA server if you have 2 NIC's and install ISA it is an excellent firewall and proxy server for your clients. Again though ISA requires 2 NIC's.
gharzAuthor Commented:
it's getting more complex the more i add these features. i'll leave it as is as long as it is working. :)

thanks, guys.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.