Outlook 2007 keeps prompting for password

We just setup a new 2008 Small Business Server with Exchange. Everyone that is running Outlook 2003 has no issues. But everyone with Windows 7 and Outlook 2007 keeps getting prompted for their password. The funny part is that they have to just click cancel and they can send and receive. No matter what password they put in it is incorrect, and they just have to keep clicking cancel. Any suggestions?
level9techAsked:
Who is Participating?
 
Glen KnightConnect With a Mentor Commented:
First thing to do is make sure you have at least Rollup 9 installed for Exchange 2007

Then the following 2 websites provide solutions to the above.
I have had mixed comments some say the first work and some say the second work:

http://social.technet.microsoft.com/Forums/en/exchangesvrgeneral/thread/383d130e-869f-4fce-9502-8b340904b0ba


See the section about enabling Kernel Authentication: http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/0c94187d-bc97-4fa5-9413-e8762a25a360
0
 
joefreedomConnect With a Mentor Commented:
-Through Outlook 2007: Open up the account properties for an exchange users account.
-Go to 'More Settings...'
-Select the 'Security' tab, check to make sure that 'Always prompt for logon credentials' is not selected.

Also Try:
-From a workstation that is experiencing this issue go to "run" (windows key + 'R') and type "control keymgr.dll"
-This should bring up a Stored User Names and Passwords window
-Select 'Add', enter in your exchange server name, domain username and password. hit 'OK'.

Please post back results.
0
 
gupnitCommented:
Hi,
What Exchange are we talking about here....RTM/SP1/SP2?
Take it to highest SP....
Thanks
Nitin
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
gupnitCommented:
@Glen - Hahaha, now I know what Alan meant ;-) !!!
0
 
Glen KnightCommented:
In my experience this has nothing todo with outlook the problem is purely with Exchange.

I have had 3 customers with this issue and about 5 questions over the past 2 weeks the majority seem to be advising the second link fixes it more than the first one.

:-)
0
 
Glen KnightCommented:
Hi Gupnit > Alan was referig to the post from Naraya_Sing who posts the exact same post for every post.

At lease mine is actually tried and tested :-)
0
 
level9techAuthor Commented:
Exchange Server 2007

Microsoft Corporation

Version: 08.01.0240.006

Joe- I will try your solution first.
0
 
gupnitCommented:
Oh I See.....:-) .... just kidding.... :-) !! I went through both links myself right now...second one...well I need to read a bit more on why it would be the reason?
0
 
joefreedomCommented:
If for some reason my suggestion does resolve the problem I can't recommend it as others have posted a resolution that will fix it at the domain level.  My suggestion involves a client side fix for what is sounding more and more like an IIS authentication problem.  Hopefully the kernel auth. will fix your problem!
0
 
Glen KnightCommented:
I would not play with the outlook settings, it is an issue I have come across many times over the last few weeks, it's purely an exchange issue.
0
 
gupnitCommented:
I am surprised at the number of occourances offlate.....guess some RU caused it...
0
 
Glen KnightCommented:
That's all I can think of.  Possible SP2? Or
maybe a Windows Update as it's IIS
0
 
peakpeakConnect With a Mentor Commented:
First try this: Close Outlook, click Start->Run, type Outlook /cleanprofile
If that doesn't do the trick then recreate the Outlook profile. Profile corruption is the source of many strange behaviours in Outlook.
You may first want to save away the address cache (the .nk2 file) which contains the addresses the user has prevoiusly sent successfully. You find the .nk2 file here (XP):
C:\Documents and Settings\<user>\Application Data\Microsoft\Outlook
(Vista: C:\Users\{username}\AppData\Roaming\Microsoft\Outlook)
If you do not know how to recreate a profile: http://www.howto-outlook.com/faq/newprofile.htm
After recreating the profile you can restore the .nk2 file to the same location assuming you used the same name for the new Outlook profile.
0
 
Glen KnightCommented:
ITs not an issue with outlook!!! I am 99.9% certain of that.

I have seen this a number of times and the majority of the time it is resolved by setting the Kernel Authentication as per the second link in my first post.
0
 
peakpeakCommented:
Trying to help here  ... I act out of my experience and others out of theirs. Hopefully will the sum of this knowledge help the asker of the question.
0
 
level9techAuthor Commented:
Did the Kernel Authentication and that fixed it.
0
 
Glen KnightCommented:
So why were the others accepted as part of the solution of the Kernel fixed the problem?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.